Renaming saved search folder causes folder to lose search criteria

RESOLVED DUPLICATE of bug 376007

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 376007
10 years ago
8 years ago

People

(Reporter: Rob S, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 2.0.0.14 (20080421)

If a saved search is edited, its filters are lost

Reproducible: Always

Steps to Reproduce:
1. File, New, Saved Search then say "From" "contains" "somedomain.com".  Give the folder a name "Step 1", and create it as a subfolder of an imap account.  Select to just search the same IMAP mailbox's inbox. Click OK.
2. Confirm that you see "Step 1" search folder in the folder list, and that clicking on it shows messages that match the rule from step 1.
3. Right click on the Step 1 folder, and rename it to be "Step 3"
4. Right click on the "Step 3" folder, and choose "Properties".
Actual Results:  
The search criteria and folders-to-search list are both empty

Expected Results:  
The search criteria and folders-to-search list should match what was set up in step 1.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0
DUP of Bug 370071, isn't it?

Comment 2

10 years ago
duping to bug 376007. 
still do you see that in a newer 2.0.0.16 or 3 ?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376007
You need to log in before you can comment on or make changes to this bug.