Closed Bug 376007 Opened 13 years ago Closed 11 years ago

when renaming a saved search, I lost the criteria

Categories

(Thunderbird :: Mail Window Front End, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: moco, Unassigned)

References

Details

(Keywords: dataloss)

when renaming a saved search, I lost the criteria

steps to reproduce:

1) on my imap server (mozilla.com imap's server), I searched for emails with subject not containing "[bug" (for a crude 'not bugzilla' search).
2) click the "save as search folder" button to save the search as a child folder of my mozilla.com server folder
3) select the folder in the folder pane (I am in the "all view")
4) rename the folder by the right click context menu "Rename"

when I view the properties of the search, the 'subject not containing "[bug"' criteria was blank.
hmm, having problems reproducing this now, but I *swear* I saw it twice this morning and was able to reproduce it.

I'll keep trying for good steps-to-reproduce
I was just able to reproduce this.

when I renamed the search, and view the properties, it had indeed lost the criteria.

but, then I immediately exited and restarted, and the properties were there, as if they had been properly reloaded.

david / scott, are you able to reproduce this?
I don't think we ever intended to support renaming of VFs so your behavior is probably undefined :)

I intentionally disable changing the folder name in the properties dialog. It's probably an oversight that I never disabled the folder pane context menu. Oops!
thanks for the info.

perhaps this bug should morph to "disable rename command for saved searches"?

do you want (already have?) a RFE bug on supporting renaming?

Also, note, "File | Rename Folder" is enabled for my saved search folders as well.
Rather than disallowing the renaming of a search folder, it would be much nicer if this was handled.

Besides, the problem might still exist when I rename (or move) a parent folder that contains nested search folders.  This is how I encountered the problem in the first place.

My current workaround is to take screenshots of the search criteria for all of my search folders before I rename or move such things.  Otherwise it's difficult to remember and to re-create the search criteria for each search folder.  Obviously this is not ideal.
WORKSFORME with Thunderbird trunk 2007/7/17(MS Win-XP), when Search Folder(Virtual Folder) name dosn't contain special character such as "/", on both dummy POP3 account and dummy IMAP account, although garbage of old virtual folder(<virtual_foldr_name> and <virtual_folder_name>.msf) was observed when IMAP.
(POP3) 
 1. Create a Search folder(VF-A)
    => VF-A is added in virtualFolders.dat
    => VF-A / VF-A.msf were created in Mail
 2. Rename a Search folder(VF-A -> VF-B)
    => virtualFolders.dat was updated correctly (VF-A was changed to VF-B) 
    => VF-A / VF-A.msf disappeared, and VF-B / VF-B.msf appeared in Mail
    => Property of VF-B is correctly displayed
 3. Repeat step 2 multiple times => No problem.
(IMAP) 
 1. Create a Search folder(VF-A)
    => VF-A is added in virtualFolders.dat,
    => VF-A / VF-A.msf were created in ImapMail
 2. Rename a Search folder(VF-A -> VF-B)
    => virtualFolders.dat was updated correctly (VF-A was changed to VF-B) 
    => VF-A / VF-A.msf remained, and VF-B / VF-B.msf appeared in Mail
    => Property of VF-B is correctly displayed
 3. Rename a Search folder(VF-B -> VF-C)
    => virtualFolders.dat was updated correctly (VF-B was changed to VF-C) 
    => VF-A / VF-A.msf, VF-B / VF-B.msf, VF-C / VF-C.msf in MAil
    => Property of VF-C is correctly displayed

To Seth Spitzer:
(Q1) Does virual folder name contain special character?
(Q2) Renamed multiple time in a Thunderbird session?
(Q3) If "renamed multiple time", is previously used name involved in rename?
(Q4) Is similar problem observed on POP3 account? Or IMAP account only problem?
(Q5) Do you see problem even with Thunderbird trunk? 
Corerectrion: (Sorry for spam)
Garbage when IMAP was VF-A.sbd(directory)/VF-A.msf(file), VF-B.sbd/VF-B.msf.
Note: 
My WORKSFORME is for "property display" only. When IMAP, VF-A.sbd / VF-A.msf were created, instead of VF-A / VF-A.msf. Sorry but I dont't know whether Virual Folder works without mail folder file or not.
I'm not able to re-create the problem with renaming search folders that I had many months ago.  I'm currently using POP3 with TB 2.0.0.5 (20070716).  Today I can rename the search folder and/or the containing parent folder with no problems.  The search criteria are preserved and no orphan disk files remain.  So perhaps this has been fixed.  Please disregard my previous post.  Sorry.
Seth?

WADA, I don't see the garbage case you cite for imap using version 3.0a1pre (2007110302)


(In reply to comment #0)
>...
> when I view the properties of the search, the 'subject not containing "[bug"'
> criteria was blank.

noted in bug 376017 
(In reply to comment #10)
> WADA, I don't see the garbage case you cite for imap using version 3.0a1pre
> (2007110302)

Phenomenon of my Comment #6 still occurs on dummy IMAP account with Tb trunk of "version 3.0a1pre (2007110803)" on MS Win-XP.
 0. Create a dummy IMAP account
 1. Create a Search folder(VF-001) under the dummy IMAP account
    => VF-001.sbd(directory, not file of VF-001) / VF-001.msf(file)
 2. Rename a Search folder(VF-001 -> VF-002)
    => virtualFolders.dat was updated correctly (VF-001 was changed to VF-002) 
    => VF-001.sbd(directory, not file of VF-001) / VF-001.msf are not deleted
    => VF-002.sbd(directory, not file of VF-002) / VF-002.msf are created
 3. On each rename to new VF-nnn, VF-nnn.sbd & VF-nnn.msf are added
 4. Shutdown & Restart of Tb
 5. VF-001.msf to VF-[nnn minus 1].msf are deleted 
    VF-nnn.msf(last/valid msf file) remains
    VF-001.sbd to VF-nnn.sbd (directory, not file) remain

Problem of my comment #6 seems to be;
 (a) Directory of ".sbd" for sub-folders is always created.
     when virtual folder of IMAP account.
     (this problem is already resolved on Tb 2 when usual local mail folder)
 (b) Directory of ".sbd" is not deleted when rename of virtual folder.
 (c) ".msf" for old virtual folder name is not deleted when rename.
     It looks to be deleted while shutdown or restart of Tb.
This remains a problem (version 2.0.0.12 (20080213)).

I have been bitten by this several times when accidently dragging/dropping folders in the folder pane where a search folder is a sub-folder of the moved folder. I always move the folder back to it's correct location and the search folder is trashed.

This is made more 'interesting' because there's no easy way to then re-create the search (I have one search that has about 40 entries) other than fire up a text editor with a copy of the msf, rip out the rules with some search/replace and then re-create the search using the advanced find dialogue.

I've resorted to the 'Disable DragAndDrop' extension to avoid this:
https://addons.mozilla.org/en-US/thunderbird/addon/4591
Seth, see questions comment 6

Ronny, do you see this using trunk build? (note, do a backup of your profile first)
 ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-trunk/
Assignee: mscott → nobody
Severity: normal → critical
Keywords: dataloss
WFM on vista, version 3.0a2 (2008072418) and 2.0.0.16 same
I can rename, move ss or folders containing ss with no issues, (it just resets the sort order to ascending.. default)
Duplicate of this bug: 445325
FYI.
There are some known situations of "folder criteria loss by rename" with Tb trunk. See Bug 450059.
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090101 Shredder/3.0b2pre
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.