Ctrl+Tab: Holding tab should bring up tab-switching panel and repeat

RESOLVED FIXED in Firefox 3.1a2

Status

()

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: jruderman, Assigned: dao)

Tracking

(Depends on 1 bug, {platform-parity})

Trunk
Firefox 3.1a2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a1pre) Gecko/2008071602 Minefield/3.1a1pre

Steps to reproduce:
1. Make sure you have at least 3 tabs open.
2. Start holding Ctrl, then start holding Tab.
3. Wait a few seconds
4. release Tab and then Ctrl.

Result: Nothing happens until you release tab.

Expected: Key-repeat should kick in and cycle through tab in the panel quickly (for consistency with Cmd+Tab on Tiger).
Same actual & desired behavior on Ubuntu Linux.  (for consistency with alt-tab behavior)

OS & Platform --> All.
OS: Mac OS X → All
Hardware: PC → All
(Assignee)

Updated

11 years ago
Assignee: nobody → dao
Severity: enhancement → normal
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
I crashed shortly after following Jesse's STR using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a1pre) Gecko/2008071602 Minefield/3.1a1pre. I have not been able to reproduce. My Breakpad report is still processing: http://crash-stats.mozilla.com/report/index/33fba8c0-5374-11dd-a995-001a4bd43ef6
(Assignee)

Comment 3

11 years ago
Posted patch patch (obsolete) — Splinter Review
this applies on top of the patch in bug 445369
(Assignee)

Updated

11 years ago
Depends on: 445369
(Assignee)

Updated

11 years ago
Blocks: 395980
(Assignee)

Comment 4

11 years ago
Note that this already works as expected on Windows. For some reason, the keydown event is repeated on Windows but not on other platforms.
Keywords: pp
(Assignee)

Updated

11 years ago
Blocks: 445531
(Assignee)

Updated

11 years ago
Attachment #329978 - Flags: review?(gavin.sharp)
(Assignee)

Updated

11 years ago
Blocks: 446065
(Assignee)

Updated

11 years ago
Blocks: 446209
(Assignee)

Comment 5

11 years ago
Posted patch patchSplinter Review
updated to trunk
Attachment #329978 - Attachment is obsolete: true
Attachment #333074 - Flags: review?(gavin.sharp)
Attachment #329978 - Flags: review?(gavin.sharp)
Attachment #333074 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 6

11 years ago
http://hg.mozilla.org/index.cgi/mozilla-central/rev/23a09bfad7ca
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a2
Blocks: 450138
No longer blocks: 450138
Depends on: 450138
Dao: using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a2pre) Gecko/20080812022114 Minefield/3.1a2pre and following Jesse's STR, I am not able to cycle through tabs. This seems to work fine using the equivalent build on 10.5 - if I hold the tab key down I can cycle quickly through the tabs.
(Assignee)

Comment 8

11 years ago
(In reply to comment #7)
> Dao: using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US;
> rv:1.9.1a2pre) Gecko/20080812022114 Minefield/3.1a2pre and following Jesse's
> STR, I am not able to cycle through tabs.

This is due to the way bug 374076 has been fixed -- see bug 374076 comment 33.
You need to log in before you can comment on or make changes to this bug.