Last Comment Bug 445191 - Build XULRunner nightlies from mozilla-1.9.1 & mozilla-central
: Build XULRunner nightlies from mozilla-1.9.1 & mozilla-central
Status: RESOLVED FIXED
: fixed1.9.1
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: All All
: P2 normal (vote)
: ---
Assigned To: Chris AtLee [:catlee]
:
:
Mentors:
: 452255 (view as bug list)
Depends on: 445794 486400
Blocks: tomtom 607775
  Show dependency treegraph
 
Reported: 2008-07-14 11:06 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2013-08-12 21:54 PDT (History)
27 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Add upload target for xulrunner (312 bytes, patch)
2009-03-25 14:58 PDT, Chris AtLee [:catlee]
ted: review+
Details | Diff | Splinter Review
Add upload target for xulrunner, and upload SDK if it exists (859 bytes, patch)
2009-03-25 15:17 PDT, Chris AtLee [:catlee]
ted: review+
Details | Diff | Splinter Review
Add upload target for xulrunner, and upload SDK if it exists (1.97 KB, patch)
2009-03-26 14:40 PDT, Chris AtLee [:catlee]
ted: review+
Details | Diff | Splinter Review
Add xulrunner build to staging master (7.52 KB, patch)
2009-03-26 15:03 PDT, Chris AtLee [:catlee]
bhearsum: review-
dtownsend: review+
Details | Diff | Splinter Review
Add options to build and upload sdk for xulrunner builds (3.59 KB, patch)
2009-03-26 15:04 PDT, Chris AtLee [:catlee]
bhearsum: review+
Details | Diff | Splinter Review
Update tinderbox configs to upload 1.9.0 builds to latest-mozilla1.9.0 (2.21 KB, patch)
2009-03-27 05:52 PDT, Chris AtLee [:catlee]
bhearsum: review+
catlee: checked‑in+
Details | Diff | Splinter Review
Add xulrunner build to staging master (7.68 KB, patch)
2009-03-27 06:55 PDT, Chris AtLee [:catlee]
bhearsum: review+
catlee: checked‑in+
Details | Diff | Splinter Review
Add upload target for xulrunner, upload SDK if it exists, and add 'sdk', 'upload' targets to client.mk (1.79 KB, patch)
2009-03-30 12:27 PDT, Chris AtLee [:catlee]
ted: review+
ted: approval1.9.1+
ted: checked‑in+
Details | Diff | Splinter Review
Add options to build and upload sdk for xulrunner builds (4.24 KB, patch)
2009-03-31 11:25 PDT, Chris AtLee [:catlee]
bhearsum: review+
catlee: checked‑in+
Details | Diff | Splinter Review
Add xulrunner build to production master (7.34 KB, patch)
2009-03-31 12:42 PDT, Chris AtLee [:catlee]
bhearsum: review+
catlee: checked‑in+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2008-07-14 11:06:30 PDT
We need XULRunner 1.9.1 nightlies built from mozilla-central (hg) in addition to the 1.9.0.x nightlies built from CVS
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2008-08-26 12:11:51 PDT
*** Bug 452255 has been marked as a duplicate of this bug. ***
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2008-09-30 11:13:00 PDT
Any thoughts on an ETA for this? I know Ben talked about making some changes to the build code so we could build 2 different things from the same tree or something like that)
Comment 3 Ben Hearsum (:bhearsum) 2008-09-30 11:17:32 PDT
I've still gotta re-factor master.cfg/config.py for this :(. It's not a big patch, and I can likely do post-3.1b1. Is that OK?
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2008-09-30 11:20:20 PDT
Yep. Thanks
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2008-10-21 05:58:32 PDT
Since FF3.1b1 has been released, we are seeing some extension developers looking for xulrunner SDKs, so they can upgrade their binary components.

We need some nightly xulrunner 1.9.1 runtimes and SDKs ASAP, so we can not block add-on upgrade progress.
Comment 6 Wladimir Palant 2008-10-22 02:19:17 PDT
For TomTom HOME 2.5 release (which will be based on XULRunner 1.9.1b1) we have to link to the Firefox source code on our MPL page - this is rather ridiculous but at least Firefox source code and XULRunner source code are identical. And there is a XULRunner bug that we cannot report because we are not sure that it happens in official builds without our patches - simply because there are no official builds. Yes, this issue is something that should be resolved ASAP.
Comment 7 Ben Hearsum (:bhearsum) 2008-10-29 05:09:05 PDT
I'm sorry but I won't be able to get to this as soon as I thought - other things have taken priority.
Comment 8 Dirkjan Ochtman (:djc) 2008-12-10 07:28:54 PST
bhearsum, can you outline what's needed for this?
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2009-01-06 05:34:24 PST
joduinn / bhearsum - any idea on when we could move forward on this bug? at this point we have 1.9.1 and trunk to worry about.
Comment 10 Ben Hearsum (:bhearsum) 2009-01-06 08:45:19 PST
I'm happy to work on this but I'm deferring prioritization to joduinn.
Comment 11 Dan Cradler 2009-01-12 15:42:48 PST
I'm really hoping to see these builds soon - would love to start testing our XULRunner 1.9.0 based application on 1.9.1b2.
Comment 12 Mark Finkle (:mfinkle) (use needinfo?) 2009-02-10 18:29:13 PST
joduinn - Any idea on when we could move forward on this bug? at this point we have 1.9.1 and trunk to worry about.

We really need an SDK. I am willing to do as much work as possible on this. I think bhearsum wanted to do some foundation work first.
Comment 13 Ben Hearsum (:bhearsum) 2009-02-11 05:49:52 PST
(In reply to comment #12)
> joduinn - Any idea on when we could move forward on this bug? at this point we
> have 1.9.1 and trunk to worry about.
> 
> We really need an SDK. I am willing to do as much work as possible on this. I
> think bhearsum wanted to do some foundation work first.

That work ended up getting done when we branched for 1.9.1. I didn't think to dupe the dependent bug though :(
Comment 14 Dave Townsend [:mossop] 2009-03-04 16:44:38 PST
(In reply to comment #13)
> (In reply to comment #12)
> > joduinn - Any idea on when we could move forward on this bug? at this point we
> > have 1.9.1 and trunk to worry about.
> > 
> > We really need an SDK. I am willing to do as much work as possible on this. I
> > think bhearsum wanted to do some foundation work first.
> 
> That work ended up getting done when we branched for 1.9.1. I didn't think to
> dupe the dependent bug though :(

So what is the status of this bug now? Is there any plans for anyone from build to work on it and of not is there an overview on what others can do to fix it?
Comment 15 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2009-03-04 17:10:55 PST
(In reply to comment #14)
> (In reply to comment #13)
> > (In reply to comment #12)
> > > I think bhearsum wanted to do some foundation work first.
> > That work ended up getting done when we branched for 1.9.1. I didn't think to
> > dupe the dependent bug though :(
> So what is the status of this bug now? Is there any plans for anyone from build
> to work on it and of not is there an overview on what others can do to fix it?

Not sure what's left to do here, so dont even know what to explain for others to do. 

bhearsum: can you clarify where you left things, and whats left to do??

mfinkle: depending on whats left to do, and if the rest of our Q1 goals come together ok, we might get time to squeeze this in before end of Q1. Obviously, if you want to help, any help is always great, but lets see whats actually left to do first?
Comment 16 Ben Hearsum (:bhearsum) 2009-03-05 06:05:37 PST
We'll need at least the following to do these builds:
* 'make upload' support for XULrunner - not sure if the current target will "just work" (http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/packager.mk#508)
* MercurialBuildFactory (or a subclass thereof) support for XULrunner. This will be made easier once https://bugzilla.mozilla.org/show_bug.cgi?id=478229 lands. (http://hg.mozilla.org/build/buildbotcustom/file/tip/process/factory.py#l220)
* Enable them in config.py/master.cfg (http://hg.mozilla.org/build/buildbot-configs/file/tip/mozilla2-staging)
* Install the xrbld key on all slaves
* Install the chown script on all Mac slaves

There might be more to do, I'm not sure.
Comment 17 Dave Townsend [:mossop] 2009-03-05 06:43:27 PST
I believe we will also need to add a make upload-sdk target or similar to push the x86 and ppc sdks up to the server
Comment 18 Christopher Blizzard (:blizzard) 2009-03-19 09:04:13 PDT
Nick + Rey -

We talked about this at the Evangelism meeting today.  People use these builds to build binary extensions so getting them out the door to people is going to help with extensions compatibility.  So this is pretty important.
Comment 19 Rey Bango 2009-03-19 09:09:09 PDT
I'm on it. I've already chatted with MFinkle and SSidler to see how to get a build out and emailed Nick to get him in the loop.
Comment 20 Dan Cradler 2009-03-19 10:17:52 PDT
In addition to binary extension developers, there are those of us with stand-alone applications built on XULRunner. We use the binaries as well and would love to be able to test against the latest beta.
Comment 21 Ben Longoria 2009-03-19 10:24:38 PDT
Was thinking exactly the same as Dan. Working on two XULRunner apps right now, and would love to integrate the latest into them.
Comment 22 Samuel Sidler (old account; do not CC) 2009-03-23 19:46:43 PDT
John O'Duinn: Any way we can get this out of RE:Future and onto someone's radar for the next few weeks? I plan to bring this up at the next delivery meeting as well.
Comment 23 Chris AtLee [:catlee] 2009-03-25 14:58:58 PDT
Created attachment 369378 [details] [diff] [review]
Add upload target for xulrunner
Comment 24 Chris AtLee [:catlee] 2009-03-25 15:17:20 PDT
Created attachment 369381 [details] [diff] [review]
Add upload target for xulrunner, and upload SDK if it exists
Comment 25 Mike Shaver (:shaver -- probably not reading bugmail closely) 2009-03-26 13:49:32 PDT
(In reply to comment #6)
> And
> there is a XULRunner bug that we cannot report because we are not sure that it
> happens in official builds without our patches - simply because there are no
> official builds.

(You can't just build without your patches?  Building XULRunner isn't hard if you've already got a build setup that you know builds XULRunner!)
Comment 26 Chris AtLee [:catlee] 2009-03-26 14:40:35 PDT
Created attachment 369572 [details] [diff] [review]
Add upload target for xulrunner, and upload SDK if it exists

This also adds 'make-sdk' and 'upload' targets to client.mk.  We will then do 'make -f client.mk upload' to upload both arches on Mac.

This needs to land on both mozilla-central and mozilla-1.9.1 before we can start doing builds.
Comment 27 Chris AtLee [:catlee] 2009-03-26 15:03:04 PDT
Created attachment 369575 [details] [diff] [review]
Add xulrunner build to staging master
Comment 28 Chris AtLee [:catlee] 2009-03-26 15:04:10 PDT
Created attachment 369576 [details] [diff] [review]
Add options to build and upload sdk for xulrunner builds
Comment 29 Ben Hearsum (:bhearsum) 2009-03-26 15:23:42 PDT
Comment on attachment 369575 [details] [diff] [review]
Add xulrunner build to staging master

The contents of this patch are mostly OK, but we have to upload the XULRunner builds with the xrbld key (which can be found on xr-linux-tbox).

We also need to fix up the directories in /home/ftp/pub/xulrunner/nightly. Currently, latest-trunk is still cvs builds...which should become latest-mozilla1.9.0. You'll need to update mozilla/tools/tinderbox-configs/xulrunner (CVS) to fix that up, I believe.

The NightlyBuildFactory should push the 1.9.1/m-c builds properly to latest-mozilla-1.9.1 and latest-mozilla-central and we should symlink latest-trunk to latest-mozilla-central, as we do for Firefox.

Does that all make sense?


Also, Mossop, can you have a look at the mozconfig files and make sure they're OK. They're basically copied from the CVS ones with unnecessary options removed AFAICT.
Comment 30 Ben Hearsum (:bhearsum) 2009-03-26 15:26:08 PDT
Comment on attachment 369576 [details] [diff] [review]
Add options to build and upload sdk for xulrunner builds

>             self.addFactoryArguments(objdir=objdir)
>+            self.addFactoryArguments(inifile=inifile)
>+            self.addFactoryArguments(section=section)

I think you only want to call this once and pass all three to it.

The rest of this seems fine. r=bhearsum with that change but please don't check it in until we're deploying in production.
Comment 31 Chris AtLee [:catlee] 2009-03-26 18:51:08 PDT
(In reply to comment #29)
> (From update of attachment 369575 [details] [diff] [review])
> The contents of this patch are mostly OK, but we have to upload the XULRunner
> builds with the xrbld key (which can be found on xr-linux-tbox).

This is just for production, right?  Or also for staging?

> We also need to fix up the directories in /home/ftp/pub/xulrunner/nightly.
> Currently, latest-trunk is still cvs builds...which should become
> latest-mozilla1.9.0. You'll need to update
> mozilla/tools/tinderbox-configs/xulrunner (CVS) to fix that up, I believe.
> 
> The NightlyBuildFactory should push the 1.9.1/m-c builds properly to
> latest-mozilla-1.9.1 and latest-mozilla-central and we should symlink
> latest-trunk to latest-mozilla-central, as we do for Firefox.

If post_upload is run with --release-to-latest, and --release-to-dated, like we do for the firefox nightlies, will that work?
Comment 32 Wladimir Palant 2009-03-27 00:04:13 PDT
(In reply to comment #25)
> (You can't just build without your patches?  Building XULRunner isn't hard if
> you've already got a build setup that you know builds XULRunner!)

We can do everything - but it takes a lot longer than downloading a build, and for that particular minor issue it's just too long.
Comment 33 Dave Townsend [:mossop] 2009-03-27 02:36:18 PDT
Comment on attachment 369575 [details] [diff] [review]
Add xulrunner build to staging master

Yeah I don't believe there is any need to change the config from cvs to 1.9.1.
Comment 34 Ben Hearsum (:bhearsum) 2009-03-27 05:33:55 PDT
(In reply to comment #31)
> (In reply to comment #29)
> > (From update of attachment 369575 [details] [diff] [review] [details])
> > The contents of this patch are mostly OK, but we have to upload the XULRunner
> > builds with the xrbld key (which can be found on xr-linux-tbox).
> 
> This is just for production, right?  Or also for staging?
> 

We should do the same thing in staging so it matches production as close as possible IMHO. We'd want to generate a different xrbld key for staging, of course.

> > We also need to fix up the directories in /home/ftp/pub/xulrunner/nightly.
> > Currently, latest-trunk is still cvs builds...which should become
> > latest-mozilla1.9.0. You'll need to update
> > mozilla/tools/tinderbox-configs/xulrunner (CVS) to fix that up, I believe.
> > 
> > The NightlyBuildFactory should push the 1.9.1/m-c builds properly to
> > latest-mozilla-1.9.1 and latest-mozilla-central and we should symlink
> > latest-trunk to latest-mozilla-central, as we do for Firefox.
> 
> If post_upload is run with --release-to-latest, and --release-to-dated, like we
> do for the firefox nightlies, will that work?

Yeah, sorry, I was just stating the obvious in that last paragraph. The only thing we actually need to do about this is update the tinder-config.pl files (http://mxr.mozilla.org/mozilla/source/tools/tinderbox-configs/xulrunner) and fix latest-trunk.
Comment 35 Chris AtLee [:catlee] 2009-03-27 05:52:29 PDT
Created attachment 369659 [details] [diff] [review]
Update tinderbox configs to upload 1.9.0 builds to latest-mozilla1.9.0
Comment 36 Ben Hearsum (:bhearsum) 2009-03-27 05:56:09 PDT
Comment on attachment 369659 [details] [diff] [review]
Update tinderbox configs to upload 1.9.0 builds to latest-mozilla1.9.0

Looks good. If you modify the CLOBBER file in these directories when you check this in you can trigger a nightly to make sure the new builds end up in the right place.
Comment 37 Nick Thomas [:nthomas] 2009-03-27 06:01:57 PDT
I moved latest-trunk to latest-mozilla1.9.0 and updated mozilla/tools/tinderbox-configs/monitoring/XULRunner_trunk.txt. Further on we can add checks for m-1.9.1 and m-c.
Comment 38 Chris AtLee [:catlee] 2009-03-27 06:38:32 PDT
Comment on attachment 369659 [details] [diff] [review]
Update tinderbox configs to upload 1.9.0 builds to latest-mozilla1.9.0

Checking in linux/CLOBBER;
/cvsroot/mozilla/tools/tinderbox-configs/xulrunner/linux/CLOBBER,v  <--  CLOBBER
new revision: 1.7; previous revision: 1.6
done
Checking in linux/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/xulrunner/linux/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.10; previous revision: 1.9
done
Checking in macosx/CLOBBER;
/cvsroot/mozilla/tools/tinderbox-configs/xulrunner/macosx/CLOBBER,v  <--  CLOBBER
new revision: 1.8; previous revision: 1.7
done
Checking in macosx/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/xulrunner/macosx/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.9; previous revision: 1.8
done
Checking in win32/CLOBBER;
/cvsroot/mozilla/tools/tinderbox-configs/xulrunner/win32/CLOBBER,v  <--  CLOBBER
new revision: 1.8; previous revision: 1.7
done
Checking in win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/xulrunner/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.14; previous revision: 1.13
done
Comment 39 Chris AtLee [:catlee] 2009-03-27 06:55:53 PDT
Created attachment 369662 [details] [diff] [review]
Add xulrunner build to staging master

This uses a separate ssh key for the xulrunner build.
Comment 40 Ben Hearsum (:bhearsum) 2009-03-27 06:59:13 PDT
Comment on attachment 369662 [details] [diff] [review]
Add xulrunner build to staging master

You need a STAGE_USERNAME_XULRUNNER, too - we'll be uploading as 'xrbld'. r=bhearsum with that change.
Comment 41 Dave Townsend [:mossop] 2009-03-27 11:23:13 PDT
I've manually spun some builds for XULRunner 1.9.1b3, available from here: http://tinyurl.com/dkqyms
Comment 42 Ted Mielczarek [:ted.mielczarek] 2009-03-30 08:39:29 PDT
Comment on attachment 369572 [details] [diff] [review]
Add upload target for xulrunner, and upload SDK if it exists

test
Comment 43 Ted Mielczarek [:ted.mielczarek] 2009-03-30 08:40:36 PDT
Comment on attachment 369572 [details] [diff] [review]
Add upload target for xulrunner, and upload SDK if it exists

+make-sdk::  $(OBJDIR)/Makefile $(OBJDIR)/config.status
+	$(MOZ_MAKE) sdk

Please make this just "sdk" to match the objdir target.

r=me with that fix.
Comment 44 Chris AtLee [:catlee] 2009-03-30 12:27:02 PDT
Created attachment 370048 [details] [diff] [review]
Add upload target for xulrunner, upload SDK if it exists, and add 'sdk', 'upload' targets to client.mk
Comment 45 Ted Mielczarek [:ted.mielczarek] 2009-03-31 06:44:20 PDT
Comment on attachment 370048 [details] [diff] [review]
Add upload target for xulrunner, upload SDK if it exists, and add 'sdk', 'upload' targets to client.mk

Pushed to m-c:
http://hg.mozilla.org/mozilla-central/rev/a5556353ba2c
Comment 46 Chris AtLee [:catlee] 2009-03-31 11:25:06 PDT
Created attachment 370238 [details] [diff] [review]
Add options to build and upload sdk for xulrunner builds

We need to special case mozilla-central for now, until the upload target exists in client.mk on our other branches.
Comment 47 Ben Hearsum (:bhearsum) 2009-03-31 11:34:12 PDT
Comment on attachment 370238 [details] [diff] [review]
Add options to build and upload sdk for xulrunner builds

>-        self.addStep(SetMozillaBuildProperties,
>-         objdir='build/%s' % self.objdir
>-        )
>+        if self.productName == 'xulrunner':
>+            self.addStep(GetBuildID,
>+             objdir=self.objdir,
>+             inifile='platform.ini',
>+             section='Build',
>+            )
>+        else:
>+            self.addStep(SetMozillaBuildProperties,
>+             objdir='build/%s' % self.objdir
>+            )

Can you file a followup to get these unified? I think the *only* property we use since 'make upload' landed is the BuildID, and we can probably do this in a more robust way. Won't block you on this though.


>+        # Temporary workaround until all branches have the upload target in client.mk
>+        if self.branchName == 'mozilla-central':
>+            self.addStep(SetProperty,
>+             command=['make', '-f', 'client.mk', 'upload'],
>+             env=uploadEnv,
>+             workdir='build',
>+             extract_fn = get_url,
>+            )
>+        else:
>+            self.addStep(SetProperty,
>+             command=['make', 'upload'],
>+             env=uploadEnv,
>+             workdir='build/%s' % self.objdir,
>+             extract_fn = get_url,
>+            )
> 

Fine for now, please make sure to fix this once the client.mk patch lands on branch (and tracemonkey merges).

Patch looks good overall.
Comment 48 Ted Mielczarek [:ted.mielczarek] 2009-03-31 12:27:09 PDT
Comment on attachment 370048 [details] [diff] [review]
Add upload target for xulrunner, upload SDK if it exists, and add 'sdk', 'upload' targets to client.mk

Pushed to 1.9.1:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/078881d9b8e6
Comment 49 Chris AtLee [:catlee] 2009-03-31 12:42:25 PDT
Created attachment 370252 [details] [diff] [review]
Add xulrunner build to production master
Comment 50 Ben Hearsum (:bhearsum) 2009-03-31 12:45:22 PDT
Comment on attachment 370252 [details] [diff] [review]
Add xulrunner build to production master

>diff --git a/mozilla2/config.py b/mozilla2/config.py
>--- a/mozilla2/config.py
>+++ b/mozilla2/config.py
>@@ -12,8 +12,10 @@
> STAGE_USERNAME = 'ffxbld'
> STAGE_SERVER = 'stage.mozilla.org'
> STAGE_BASE_PATH = '/home/ftp/pub/firefox'
>+STAGE_BASE_PATH_XULRUNNER = '/home/ftp/pub/xulrunner'
> STAGE_GROUP = None
> STAGE_SSH_KEY = 'ffxbld_dsa'
>+STAGE_SSH_XULRUNNER_KEY = 'xrbld_dsa'
> AUS2_USER = 'cltbld'
> AUS2_HOST = 'aus2-staging.mozilla.org'
> DOWNLOAD_BASE_URL = 'http://ftp.mozilla.org/pub/mozilla.org/firefox'
>@@ -94,6 +96,8 @@
> BRANCHES['mozilla-central']['platforms']['linux-debug']['builds_before_reboot'] = None
> BRANCHES['mozilla-central']['platforms']['win32-debug']['builds_before_reboot'] = None
> BRANCHES['mozilla-central']['platforms']['macosx-debug']['builds_before_reboot'] = None
>+# Enable XULRunner / SDK builds
>+BRANCHES['mozilla-central']['enable_xulrunner'] = True
> # Enable unit tests
> BRANCHES['mozilla-central']['enable_unittests'] = True
> BRANCHES['mozilla-central']['unittest_build_space'] = 5
>@@ -278,6 +282,8 @@
>     'SYMBOL_SERVER_SSH_KEY': "/Users/cltbld/.ssh/ffxbld_dsa",
>     'TINDERBOX_OUTPUT': '1',
>     'MOZ_CRASHREPORTER_NO_REPORT': '1',
>+    'CHOWN_ROOT': '~/bin/chown_root',
>+    'CHOWN_REVERT': '~/bin/chown_revert',
> }
> BRANCHES['mozilla-central']['platforms']['linux-debug']['env'] = {
>     'MOZ_OBJDIR': OBJDIR,
>@@ -348,6 +354,8 @@
> BRANCHES['mozilla-1.9.1']['platforms']['linux-debug']['builds_before_reboot'] = None
> BRANCHES['mozilla-1.9.1']['platforms']['win32-debug']['builds_before_reboot'] = None
> BRANCHES['mozilla-1.9.1']['platforms']['macosx-debug']['builds_before_reboot'] = None
>+# Enable XULRunner / SDK builds
>+BRANCHES['mozilla-1.9.1']['enable_xulrunner'] = True
> # Enable unit tests
> BRANCHES['mozilla-1.9.1']['enable_unittests'] = True
> BRANCHES['mozilla-1.9.1']['unittest_build_space'] = 5
>@@ -522,6 +530,8 @@
>     'SYMBOL_SERVER_SSH_KEY': "/Users/cltbld/.ssh/ffxbld_dsa",
>     'TINDERBOX_OUTPUT': '1',
>     'MOZ_CRASHREPORTER_NO_REPORT': '1',
>+    'CHOWN_ROOT': '~/bin/chown_root',
>+    'CHOWN_REVERT': '~/bin/chown_revert',
> }
> BRANCHES['mozilla-1.9.1']['platforms']['linux-debug']['env'] = {
>     'MOZ_OBJDIR': OBJDIR,
>@@ -570,6 +580,8 @@
> BRANCHES['tracemonkey']['platforms']['linux']['upload_symbols'] = True
> BRANCHES['tracemonkey']['platforms']['win32']['upload_symbols'] = True
> BRANCHES['tracemonkey']['platforms']['macosx']['upload_symbols'] = True
>+# Disable XULRunner / SDK builds
>+BRANCHES['tracemonkey']['enable_xulrunner'] = False
> # Enable unit tests
> BRANCHES['tracemonkey']['enable_unittests'] = True
> BRANCHES['tracemonkey']['unittest_build_space'] = 5
>diff --git a/mozilla2/linux/mozilla-central/xulrunner/mozconfig b/mozilla2/linux/mozilla-central/xulrunner/mozconfig
>new file mode 100644
>--- /dev/null
>+++ b/mozilla2/linux/mozilla-central/xulrunner/mozconfig
>@@ -0,0 +1,11 @@
>+export MOZILLA_OFFICIAL=1
>+export JAVA_HOME=/tools/jdk
>+
>+ac_add_options --enable-application=xulrunner
>+ac_add_options --disable-tests
>+
>+CC=/tools/gcc/bin/gcc
>+CXX=/tools/gcc/bin/g++
>+
>+# Enable parallel compiling
>+mk_add_options MOZ_MAKE_FLAGS="-j4"
>diff --git a/mozilla2/macosx/mozilla-central/xulrunner/mozconfig b/mozilla2/macosx/mozilla-central/xulrunner/mozconfig
>new file mode 100644
>--- /dev/null
>+++ b/mozilla2/macosx/mozilla-central/xulrunner/mozconfig
>@@ -0,0 +1,9 @@
>+. $topsrcdir/build/macosx/universal/mozconfig
>+
>+export MOZILLA_OFFICIAL=1
>+
>+ac_add_options --enable-application=xulrunner
>+ac_add_options --disable-tests
>+
>+# Enable parallel compiling
>+mk_add_options MOZ_MAKE_FLAGS="-j4"
>diff --git a/mozilla2/master.cfg b/mozilla2/master.cfg
>--- a/mozilla2/master.cfg
>+++ b/mozilla2/master.cfg
>@@ -85,6 +85,8 @@
>             unittestBuilders.append('%s unit test' % base_name) 
>         if branch['enable_codecoverage'] and platform in ('linux',):
>             weeklyBuilders.append('%s code coverage' % branch['platforms'][platform]['base_name'])
>+        if branch['enable_xulrunner']:
>+            nightlyBuilders.append('%s xulrunner' % branch['platforms'][platform]['base_name'])
> 
>     # Currently, each branch goes to a different tree
>     # If this changes in the future this may have to be
>@@ -423,6 +425,44 @@
>              }
>              c['builders'].append(mozilla2_shark_builder)
> 
>+        if branch['enable_xulrunner']:
>+             mozilla2_xulrunner_factory = NightlyBuildFactory(
>+                 env= pf['env'],
>+                 objdir=pf['platform_objdir'],
>+                 platform=platform,
>+                 hgHost=HGHOST,
>+                 repoPath=branch['repo_path'],
>+                 buildToolsRepoPath=BUILD_TOOLS_REPO_PATH,
>+                 configRepoPath=CONFIG_REPO_PATH,
>+                 configSubDir=CONFIG_SUBDIR,
>+                 profiledBuild=False,
>+                 productName='xulrunner',
>+                 mozconfig='%s/%s/xulrunner' % (platform, name),
>+                 stageServer=STAGE_SERVER,
>+                 stageUsername=STAGE_USERNAME,
>+                 stageGroup=STAGE_GROUP,
>+                 stageSshKey=STAGE_SSH_XULRUNNER_KEY,
>+                 stageBasePath=STAGE_BASE_PATH_XULRUNNER,
>+                 codesighs=False,
>+                 uploadPackages=uploadPackages,
>+                 uploadSymbols=True,
>+                 nightly=True,
>+                 createSnippet=False,
>+                 buildSpace=buildSpace,
>+                 clobberURL=BASE_CLOBBER_URL,
>+                 clobberTime=clobberTime,
>+                 buildsBeforeReboot=pf['builds_before_reboot'],
>+                 packageSDK=True,
>+             )
>+             mozilla2_xulrunner_builder = {
>+                 'name': '%s xulrunner' % pf['base_name'],
>+                 'slavenames': pf['slaves'],
>+                 'builddir': '%s-%s-xulrunner' % (name, platform),
>+                 'factory': mozilla2_xulrunner_factory,
>+                 'category': name,
>+             }
>+             c['builders'].append(mozilla2_xulrunner_builder)
>+
> ####### STATUS TARGETS
> 
> from buildbot.status import html
>diff --git a/mozilla2/win32/mozilla-1.9.1/xulrunner/mozconfig b/mozilla2/win32/mozilla-1.9.1/xulrunner/mozconfig
>new file mode 100644
>--- /dev/null
>+++ b/mozilla2/win32/mozilla-1.9.1/xulrunner/mozconfig
>@@ -0,0 +1,10 @@
>+export MOZILLA_OFFICIAL=1
>+export JAVA_HOME=/d/jdk1.5.0_10
>+
>+ac_add_options --enable-application=xulrunner
>+ac_add_options --enable-jemalloc
>+ac_add_options --disable-installer
>+ac_add_options --disable-tests
>+
>+# Enable parallel compiling
>+mk_add_options MOZ_MAKE_FLAGS="-j4"
>diff --git a/mozilla2/win32/mozilla-central/xulrunner/mozconfig b/mozilla2/win32/mozilla-central/xulrunner/mozconfig
>new file mode 100644
>--- /dev/null
>+++ b/mozilla2/win32/mozilla-central/xulrunner/mozconfig
>@@ -0,0 +1,10 @@
>+export MOZILLA_OFFICIAL=1
>+export JAVA_HOME=/d/jdk1.5.0_10
>+
>+ac_add_options --enable-application=xulrunner
>+ac_add_options --enable-jemalloc
>+ac_add_options --disable-installer
>+ac_add_options --disable-tests
>+
>+# Enable parallel compiling
>+mk_add_options MOZ_MAKE_FLAGS="-j4"
>diff --git a/mozilla2/win32/tracemonkey/xulrunner/mozconfig b/mozilla2/win32/tracemonkey/xulrunner/mozconfig
>new file mode 100644
>--- /dev/null
>+++ b/mozilla2/win32/tracemonkey/xulrunner/mozconfig
>@@ -0,0 +1,10 @@
>+export MOZILLA_OFFICIAL=1
>+export JAVA_HOME=/d/jdk1.5.0_10
>+
>+ac_add_options --enable-application=xulrunner
>+ac_add_options --enable-jemalloc
>+ac_add_options --disable-installer
>+ac_add_options --disable-tests
>+
>+# Enable parallel compiling
>+mk_add_options MOZ_MAKE_FLAGS="-j4"
Comment 51 Chris AtLee [:catlee] 2009-03-31 14:18:13 PDT
Comment on attachment 369662 [details] [diff] [review]
Add xulrunner build to staging master

changeset:   1049:d5f99de9c9b6
Comment 52 Chris AtLee [:catlee] 2009-03-31 14:18:39 PDT
Comment on attachment 370252 [details] [diff] [review]
Add xulrunner build to production master

changeset:   1050:4eced28e6d3f
Comment 53 Chris AtLee [:catlee] 2009-03-31 14:18:58 PDT
Comment on attachment 370238 [details] [diff] [review]
Add options to build and upload sdk for xulrunner builds

changeset:   237:2d307103b608
Comment 54 Chris AtLee [:catlee] 2009-04-01 06:27:33 PDT
Nightly XULRunner builds are now being produced for mozilla-central and mozilla-1.9.1 repositories.
Comment 55 Ben Hearsum (:bhearsum) 2009-04-01 06:33:37 PDT
I just added a latest-trunk -> latest-mozilla-central symlink on /pub/mozilla.org/xulrunner/nightly on surf to match Firefox.
Comment 56 Ben Longoria 2009-04-06 08:34:07 PDT
The new nightly mac installers don't work captured here: 486493

Note You need to log in before you can comment on or make changes to this bug.