F6 (Move to Next Frame) Looses Focus after Location Bar is Selected

RESOLVED DUPLICATE of bug 426850

Status

()

Firefox
Keyboard Navigation
--
major
RESOLVED DUPLICATE of bug 426850
10 years ago
10 years ago

People

(Reporter: therube, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008072908 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008072908 SeaMonkey/2.0a1pre

 
F6 should ...

"F6 cycles through location bar (allegedly) <--> web document.  If the web content contains frames, F6 cycles through location bar --> frame 1 --> frame 2 --> frame 3 --> location bar."

https://bugzilla.mozilla.org/show_bug.cgi?id=249735#c24
 
This no longer occurs.

Currently, F6 cycles through location bar --> frame 1 --> frame 2 --> frame 3 --> location bar.  But once on the location bar, focus is lost, & will cycle no further.
 

Reproducible: Always

Steps to Reproduce:
 
1. Open URL
http://www.mozilla.org/quality/browser/front-end/testcases/drag-drop/drag-frame-to-frame/frame-test.html

2. Set focus to a frame
3. Hit F6 repeatedly
 
Actual Results:  
 
F6 cycles through the frames, goes to the Location Bar, then focus is lost.
 

Expected Results:  
  
F6 cycles through the frames, goes to the Location Bar, then cycles back to the frames ...
 

 
This happens in both SeaMonkey & Firefox.

Regression ranges:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032005 Minefield/3.0b5pre
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032106 Minefield/3.0b5pre

Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9b5pre) Gecko/2008032100 SeaMonkey/2.0a1pre
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9b5pre) Gecko/2008032107 SeaMonkey/2.0a1pre


I suspect what I am describing is the gist of Bug 434680
Note Neil's comment, about the focus ring.  That does not happen.

Some similar aspects here too, Bug 249735
(Reporter)

Comment 1

10 years ago
 
Oops, should read ...

This no longer occurs.

Currently, F6 cycles through            frame 1 --> frame 2 --> frame 3
--> location bar.  But once on the location bar, focus is lost, & will cycle no
further.
 
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Regression range is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2008-03-21+02%3A00&maxdate=2008-03-21+08%3A00
Maybe one of Smaug's bugs? 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3.1?
Keywords: regression, testcase
Version: 3.0 Branch → Trunk

Comment 3

10 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=426850

If you put the Google search bar to the left of the location bar so that it comes first in the DOM tree then the search bar gets focus and not the location bar by pressing F6. If nothing happens then the icon seems to get focus: press the Tab key once to shift the focus to the text area. Also if the side bar is on with the bookmarks or the history then F6 switches through the text fields in the side bar and the first text area in the navigation toolbox and the browser window. I have the Google bar on the main menu bar and the location bar on the nav bar.
Yes, probably a dupe of bug 426850.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3.1?
Resolution: --- → DUPLICATE
Duplicate of bug: 426850
You need to log in before you can comment on or make changes to this bug.