If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

detach/delete attachment doesn´t do anything on HTML mail with inline pictures

RESOLVED INCOMPLETE

Status

Thunderbird
Message Reader UI
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: mail.kfr, Unassigned)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-08-25)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: version 2.0.0.16 (20080708)

When a HTML mail is viewed as plain text, the inline pictures appear as attachments. If you try to detach/delete them, you are asked if you really want to remove them, but the message that is then uploaded to imap is just the same message, same size (3MB), with all pictures.

BTW: It´d be nice if you could just detach the pictures as viewed in the "simple HTML" - view.



Reproducible: Always

Steps to Reproduce:
1.Compose HTML message with picture. (Not attached, inline picture)
2.Send it to yourself

Actual Results:  
Picures cannot be detached. It seems to work, but the email is the same afterwards, same size, everything in it.

Expected Results:  
Expected the email text without the pictures. I don´t want to loose what my fried wrote, I just want to get rid of those 5-Megabyte-Pictures.

I think this was reported before as Bug 417646, only nobody noted that this multipart-MIME HTML stuff was responsible, they thought it was an apple issue.
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0

Comment 1

9 years ago
If you View>>message source, you will see that the content-type is listed as inline and not attachment. The plaintext view just portrays them as attachments. If you could delete them, this would be the equivalent of erasing portions of a written mail, and calling it the original.
This bug should be marked INVALID

Comment 2

9 years ago
(In reply to comment #1)
> This bug should be marked INVALID

Except that I see this when there are *both* inline *and* attached files (a zip archive, for example). Neither deleting just the zip nor deleting all works. In addition, there is NO feedback to the user that some or all files could not be deleted or why.

I see this in SeaMonkey on OS/2 & Linux, so this should be marked for all OSes (unless someone *doesn't* see this on something) and for MailNews, not just Tbird.

It's very frustrating...

Comment 3

9 years ago
Since TB development is being done entirely 3.x branch now, I doubt if anything will change in TB2
Thunderbird 3.0b1 will be released very shortly, I would suggest you give it a try. Look at http://www.mozillamessaging.com for release info.

Comment 4

9 years ago
As not many of us are running SuiteRunner builds of SeaMonkey, I doubt that TB 3.0b1 is going to shed much light on this, nor do I see migrating my corporate clients to beta software anytime. The current nightly of TB appears to be 3.0a2; I'm not sure when b1 will be coming down the pike, nor how that development will impact SeaMonkey in the near future.

Thanks for the insight, though, Joe.

Comment 5

9 years ago
Joe, I disagree with your analogy.  When attachments are deleted, there are usually still icons shown in the attachment area with the caption "Deleted:name of image" - so there would be a record that portions of the original had been removed.
How is this behaving on v3?
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader

Updated

7 years ago
Whiteboard: closeme 2010-08-25
closing incomplete for lack of information. if you feel this change was made in error, please update the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.