file: referring a missing dir then save crashes browser

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
19 years ago
19 years ago

People

(Reporter: devotip, Assigned: jband_mozilla)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000707
BuildID:
2000070720

when opening a file: url referring a missing dir it start to open a new browser every few
seconds you can stop the growth pushing the stop button

Reproducible: Always
Steps to Reproduce:
1.open the
suggested url or any file: referring a missing directory


Actual Results:  every few seconds a
new browser window is opened	

Expected Results:  page telling the error in the same browser
window

Comment 1

19 years ago
hmm, unable to reproduce this with the same build on win98 (070708).  I get an
"unknown file type dailog.  dismissing the dialog does nothing.

Comment 2

19 years ago
Quite a few "browser windows spawning all the time" bugs lately:

bug 44974 - Bloat dump stats keeps opening new windows
bug 45030 - context menu "open link in new window" doesn't stop opening new
windows
bug 45047 - File|OpenFile creates infinite windows and eventually crashes

Likely to be all related. What's more: There's been a selection bug in
filepicker the past days. On Linux it froze all. A fix was checked in today.
Wonder if it cures this bug as well.
(Reporter)

Comment 3

19 years ago
Another way to get the same effect is the "browser buster"
http://komodo.mozilla.org/buster/test_url_25.html
The first browser displays the expected stuff but a slow flood of empty page 
browsers keeps growing. (win98 build 20000071008)

Comment 4

19 years ago
unable to reproduce this wioth 071108 build on NT or 98.  Resolving worksforme,
reporter please reopen if you still see thi in current builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

19 years ago
More details: I discovered this by pushing the home icon, it was set to
file:///c%7C/IMAGES/NORMA/
With build 2000071108 the behaviour is different, instead of the flood of 
browsers it asks for "Unknown file type" "you are about to download a file of 
type plain/text" if you say save file and put a filename when prompted you get a 
crash.
I'm not alone, see also http://bugzilla.mozilla.org/show_bug.cgi?id=45134
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

19 years ago
OK, I think that this bug has morphed.  It should be a duplicate of bug 45047 
but rather than dupe it against a fixed bug I'll upodate the summary to reflect 
the new problem.
stack trace looks like this 
 
   nsXPCWrappedJSClass::GetInterfaceName
                                        
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 
1103]
     
   nsXPCWrappedJSClass::CallMethod 
                                        
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 
783]
     
   nsXPCWrappedJS::CallMethod 
                                        
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp, line 310]
     
   PrepareAndDispatch 
                                        
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
line 102]
     
   SharedStub 
                                        
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
line 125]

updating component and setting default owner.
Assignee: asa → jband
Status: UNCONFIRMED → NEW
Component: Browser-General → XPConnect
Ever confirmed: true
Keywords: crash
QA Contact: doronr → pschwartau
Summary: file: referring a missing dir opens infinite number of browsers → file: referring a missing dir then save crashes browser
(Assignee)

Comment 7

19 years ago
This works for with a new build. I get an "unknown content type" dialog. No 
cascade of windows. I see that a bug this is claimed to be a dup of is marked as 
fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

19 years ago
Perhaps now we are taking about a different bug. Is your option what to do.
I agree on the fact that the newer build is not anymore spawning a flood of 
browsers but:
1) a missing directory do not have content so a dialog offering to download it 
is not a good behaviour.
2) accepting the offer of download leads to a crash

The details are in a previous comment.
(Assignee)

Comment 9

19 years ago
Oh, then that makes this a dup of 40792
You need to log in before you can comment on or make changes to this bug.