Closed Bug 449066 Opened 11 years ago Closed 10 years ago

make Ogg Theora <video> tag support build on FreeBSD

Categories

(Core :: Audio/Video, defect)

x86
FreeBSD
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: reg, Unassigned)

References

Details

Attachments

(2 files, 6 obsolete files)

Attached patch Make Ogg Theora build on FreeBSD (obsolete) — Splinter Review
I could have sworn that I filed this already, but it's not there...  Anyway.

The new ogg theora code does not compile on FreeBSD, and probably any other platform other than the big three.  This patch gets it to work on FreeBSD.  The bulk of the patch is a rewrite of the OSS driver so it compiles on FreeBSD.  I have not tested this yet, since my FreeBSD box is currently headless...  that should be fixed by the end of the day.  The changes should work on Linux though, and would provide support if ALSA was not found there.
Attachment #332231 - Flags: review?(chris.double)
Is this related to Firefox? It sounds like a FreeBSD issue, or Ogg.
Is the new title better?  Generally if a bug has a patch, it is not an accident ;-)
Summary: Ogg Theora does not build on FreeBSD → make Ogg Theora <video> tag support build on FreeBSD
That file is actually part of the Annodex browser_plugin library. Ideally any changes we make should be fed back to them so I'll check with them to see what their plans are here.

Can you confirm if your changes worked on your FreeBSD box? I can test on Linux.
Assignee: reg → nobody
Component: DOM: Core & HTML → Video/Audio
QA Contact: general → video.audio
Duplicate of this bug: 450889
Attached patch WIP patch v2 (obsolete) — Splinter Review
Updated patch that not only compiles but plays audio on FreeBSD and Linux.  The patch still needs a little work.  I would like to get the timing to use the position rather than the wall clock, since that would be much more reliable.  I don't know why it doesn't work now.  The code reports the right position, but it stutters. 

Also, it may need some tweaking to get some sleeps right...  But anyway, it works as well as ALSA on my Ubuntu VM, so it could be used as a fallback on Linux if ALSA is not available.  This should work on other OSS systems too.
Attachment #332231 - Attachment is obsolete: true
Attachment #332231 - Flags: review?(chris.double)
There must have been a few changes on the trunk, because the patch doesn't
apply cleanly any longer. This is a stripped down version, which helped me
test the new multimedia browser capabilities on FreeBSD Stable.

I also have this stuttering. Not with all files, but especially when playing
http://www.double.co.nz/video_test/test2.html . I could help out with building
and/or testing if desired.
Attached patch WIP patch v3 (obsolete) — Splinter Review
This is a revised patch, which seems to work well for me on Linux and FreeBSD.  It removes the repeated malloc()/free()ing of the ring buffer with a single static buffer, converts writer thread to a state machine and implements playing and pausing properly.  It needs some cleaning and polishing, but it seems to work...
Attachment #334147 - Attachment is obsolete: true
Attachment #345898 - Attachment is obsolete: true
Blocks: 352822
Fixing bug 449754 broke the original v3 patch on mozilla-central (it still works
fine on the release branch mozilla-1.9.1 though).
Attached patch liboggplay part (obsolete) — Splinter Review
This is just the liboggplay part, submitted to annodex as https://trac.annodex.net/ticket/462.  Do I need to get this into a patch format with changes to README_MOZILLA? Other two parts coming in a second.

I'd like to get these into 1.9.1, so that it builds out the box...
Attachment #372156 - Flags: review?(chris.double)
Attached patch liboggz partSplinter Review
This bit is not controversial...
Attachment #372157 - Flags: review?(chris.double)
Argh... submitted upstream as https://trac.annodex.net/ticket/463.
This is the big fish...  revised OSS support.  Submitted upstream as https://trac.annodex.net/ticket/464.  This builds and works on Linux (Ubuntu) and FreeBSD.  Seemed a little laggy on Linux, but that might be because it's a VM, and there are other lag bugs floating around.
Attachment #350548 - Attachment is obsolete: true
Attachment #362489 - Attachment is obsolete: true
Attachment #372159 - Flags: review?(chris.double)
Flags: wanted1.9.1?
Comment on attachment 372157 [details] [diff] [review]
liboggz part

Please add a patch file and update update.sh so that the patch gets applied net time I refresh. Also add to README_MOZILLA referencing this bug number and the patch file. r+ with that.
Attachment #372157 - Flags: review?(chris.double) → review+
Comment on attachment 372156 [details] [diff] [review]
liboggplay part

r+ with addition of README_MOZILLA, patch file and update.sh change as mentioned in previous comment.
Attachment #372156 - Flags: review?(chris.double) → review+
Flags: wanted1.9.1? → wanted1.9.1+
Comment on attachment 372159 [details] [diff] [review]
libsydneyaudio part

r+ with  update to README_MOZILLA, a .patch file and a line added to update.sh to apply that patch. See the os/2 patches in the media/libsydneyaudio directory for example.
Attachment #372159 - Flags: review?(chris.double) → review+
Attachment #372156 - Attachment is obsolete: true
Comment on attachment 372156 [details] [diff] [review]
liboggplay part

This patch has been picked up from upstream.
Duplicate of this bug: 544371
WFM since the fix for bug 556455 landed. On x86 as well as on x86_64. I think it's safe to assume that this is fixed now. :-)
Status: NEW → RESOLVED
Closed: 10 years ago
Depends on: 556455
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.