Closed Bug 449949 Opened 13 years ago Closed 13 years ago

Changing sort of Subject or From to Descending breaks sorting

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mcow, Assigned: Bienvenu)

References

Details

(Keywords: regression, Whiteboard: [needs investigation])

Attachments

(2 files)

Shredder/3.0b1pre-0809, Win2K.  First noticed in an 0802 build.

If I sort a folder by Subject (or From), and then change the order from Ascending to Descending (by a second click on the column header OR by using the View menu), the items are displayed out of order.  If I select another folder and then come back, the items are still out of order, altho they may be differently out of order than they were when you left the folder.

I think this is probably more obvious in a folder with a lot of messages.  I think it gets worse with repeated reversals.

Changing sort back to Ascending, all appears to be well.  Problem does not manifest for Date sorting; I haven't tried other criteria.


Steps to reproduce:
1) Select a folder with a large number of messages - enough to more than fill the thread pane.
2) Sort unthreaded, by date, ascending (to set up the 'secondary' criterion).
3) Sort by Subject (or From) -- menu or column header.
4) Change sort to descending -- menu or re-click the column header.  Examine results; look at the local window, and scrolling through the list, including looking at the top and bottom ends of the list.

Actual results: 
4) Items are not in any specific order.

Expected results:
4) Items are sorted, in reverse "alphabetical" (ASCII) order from top to bottom 


The order that the items end up in sometimes looks like a partial sort.  I've seen cases where I'm in the middle of the list and have selected a message there, and change from Asc to Desc, and the items in view don't change order at all, but some items from the end now are at the beginning and some from the end are now at the end.
Flags: blocking-thunderbird3.0b1?
Incidentally, I'm seeing this in local folders; haven't tried screwing around with IMAP.
I thought this might have been a regression from bug 57898, but I see the problem as far back as 0612.
Attached image Example
I've just tried this and reproduced with one of my bugmail folders
David, I think you've done things in this area, could you take a look at this?

Accepting blocking as this is an obvious user-visible bug that I don't think we should be having in a beta (and it also makes things like finding bugs hard).
Assignee: nobody → bienvenu
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3.0b1+
Whiteboard: [needs investigation]
yes, I wrote all this code - I'll look into it.
Status: NEW → ASSIGNED
Attached patch proposed fix Splinter Review
we want to reverse the sign of the retval if we're doing an ascending sort...
Attachment #333425 - Flags: superreview?(neil)
Attachment #333425 - Flags: review?(neil)
Duplicate of this bug: 432906
Attachment #333425 - Flags: superreview?(neil)
Attachment #333425 - Flags: superreview+
Attachment #333425 - Flags: review?(neil)
Attachment #333425 - Flags: review+
changeset 87:2389ebadb06c
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 450688
V with Gecko/20080816031236 Shredder/3.0b1pre

I tracked this back to bug 229692's patch, which refactored the Negate to a Not.  That's a long time for that bug to have been around without being noticed...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.