Closed Bug 450854 Opened 13 years ago Closed 2 years ago

Error when importng from MS Outlook 2007 , settings and mail

Categories

(Thunderbird :: Migration, defect)

x86
Windows Vista
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: cossak2007, Unassigned)

Details

(Whiteboard: [needs followup work])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 

Mail...Errors  " unable to save your messsage as draft"
        " unable to open the temporary file. Check your temporary directory     setting." or " unable to open the temporary file %PO%. Check your temporary directory setting.

Settings... error  " An error occurred while importing settings"


Reproducible: Always

Steps to Reproduce:
1.Tools, Import, Mail,Outlook
2.
3.
Actual Results:  
Above mail importing errors and have to use task manager to close app as it will not close.
What version of TB you are running?
(In reply to comment #1)
> What version of TB you are running?
> 
TB 2.0.0.1.6

Running Vista Ultimate x64
Intel 3.2
2 G's memory
300 g hard drive
Have 5 archived and 1 main pst files.

Total 1 g
Could you give a try TB3 alpha2 to see if problem still exist?
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Version: unspecified → 2.0
(In reply to comment #4)
> Could you give a try TB3 alpha2 to see if problem still exist?
> http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
> 

Tried alpha2.  Imported the folders but failed in importing the content of all the folders.
It seems we don't support outlook 2007 yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 2.0 → Trunk
Will someone confirm that TB doesn't work with Outlook 2007.

Thanks
Terry
I did this as well, but all my messages are imported perfectly fine from Outlook 2007 to TB 2.0.0.16. All mail are IMAP.

However, it seems impossible to import the account settings! I have 42 IMAP accounts in my Outlook setup, and none are transferred to TB.

I have also tried to import account settings from Windows Mail, no luck there either.
Tried SeaMonkey. Imported the mail and addresses but would not import account settings.

Error 450854
Import of 'mail' from outlook 2007 works fine with the patch for 408323. 
But still crashes when importing 'settings'.
Outlook 2007 settings import works partially with this fix. Accounts & the basic information are imported. But still some settings like 'use secure connection' are not imported.
Attachment #344172 - Flags: review?(neil)
Assignee: nobody → sivakrishna
Comment on attachment 344172 [details] [diff] [review]
Fixes outlook settings import

This makes sense, pName and pEmail have been null-checked but pOrgName has not been checked yet.
Attachment #344172 - Flags: review?(neil) → review+
=> vers=2.0 since it's not trunk only and reported at 2.0

Siva, if this is ready to check in, you can add keyword checkin-needed

I am anxious to try this so I can test imports because I am getting "error importing mailbox" for every folder. Using outlook 2007 + TB trunk, import mail-only.
Severity: normal → major
Version: Trunk → 2.0
r=neil
Keywords: checkin-needed
Comment on attachment 344172 [details] [diff] [review]
Fixes outlook settings import

Although its a small patch, its in mailnews/ so it needs sr as well. However, as its small, I'm sure Neil will be happy to sr it as well.
Attachment #344172 - Flags: superreview?(neil)
Attachment #344172 - Flags: superreview?(neil) → superreview+
Keywords: checkin-needed
Siva, note that we are using Mercurial now, but the cvs patch applied to trunk, so I have checked it in there: http://hg.mozilla.org/comm-central/rev/d59e13b2f37e

(excuse the cvs rubbish in the commit comment, I didn't realise hg was going to do that).

Siva, I'll let you decide if to mark this as fixed or not - I don't know if you want to do more work here.
Keywords: checkin-needed
@Siva: import of settings from Outlook 2007 or 2003 (Bug 255102) still fails for me (no problem with mail or AB) ?

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b3pre) Gecko/20090215 Lightning/1.0pre Shredder/3.0b2pre
I'm unable to import configuration from Outlook 2007 using Thunderbird 3.0.1 under Windows XP (mail and address book is ok), the message is: "There was an error while importing the configuration. Maybe some data couldn't be imported" (translated from the es-ES message :P)
Siva appears to be gone, so someone should adopt the patch.  (I PMed him on 2009-05-21 and no response)
Whiteboard: [has patch][needs patch owner]
I am still not able to import outlook 2007 settings (pop and smtp parameters) with TB3.3 alpha (just tested has suggested here http://perso.hirlimann.net/~ludo/blog/archives/2010/11/outlook-user-wanted.html by Ludovic.
Would be great if the patch proposed above could be tested and implemented if functional.
So is the patch checked in as per comment 16?
(In reply to :aceman from comment #21)
> So is the patch checked in as per comment 16?

yes. 

I forgot about my comment 19 that Siva isn't responding.
And it still does not work?
So it would need somebody on Windows with a working Outlook installation to see what is still to be done.
Assignee: sivakrishna → nobody
Whiteboard: [has patch][needs patch owner] → [needs followup work]

Wayne, my understanding is that outlook up to 2017 imports now. Should this bug therefore be closed?

Flags: needinfo?(vseerror)

I'm not sure what versions are supported, but yes import was reenabled

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(vseerror)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.