Closed Bug 451457 Opened 13 years ago Closed 13 years ago

<video> seems to download from net even if the document has been closed/unloaded

Categories

(Core :: Audio/Video, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: smaug, Assigned: cajbir)

References

Details

Attachments

(1 file)

I was looking at gnome-system-monitor to see how much some <video>s take 
bandwidth, and when closing the tab which had a <video>, the streaming
seemed to continue still some time.
Then testing using a debug build where I get info whenever cycle collector
runs indicated that streaming stopped when the document was collected.
I think the streaming should stop sooner, right after unload or so.

I'm not at all familiar with <video> implementation, so I may be wrong here 
(which is why the state UNCONFIRMED).
nsVideoFrame doesn't seem to stop anything when it is destroyed. Should it?
Or does video streaming happen based on whether <video> is bound to document?
We can't just stop the video when nsVideoFrame is destroyed, because setting the video to display:none should not stop it playing.
nsIContent::DestroyContent() could be probably used here to stop playing
Status: UNCONFIRMED → NEW
Ever confirmed: true
Implements DestroyContent to stop video/audio
Assignee: nobody → chris.double
Attachment #340562 - Flags: superreview?(roc)
Attachment #340562 - Flags: review?(roc)
Attachment #340562 - Flags: superreview?(roc)
Attachment #340562 - Flags: superreview+
Attachment #340562 - Flags: review?(roc)
Attachment #340562 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/36a64c58d099
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
similar issue Bug 470636
It's different in that this bug was for when the window/tab was closed. The other is when the page is navigated away from in the same tab.
Something similar is still happing, see Bug 480819
You need to log in before you can comment on or make changes to this bug.