Dupe date entries for csv export of download stats

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: rbango, Assigned: morgamic)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
This csv export is showing two 8/19 entries:

https://addons.mozilla.org/en-US/statistics/csv/3590/downloads

Basil has reported that he's seen this same thing on other add-ons

Updated

10 years ago
Duplicate of this bug: 455764
(Assignee)

Comment 2

10 years ago
Created attachment 339614 [details] [diff] [review]
v1, remove duplicated

9/15 and 9/16 had multiple duplicate entries caused by an IP switch (see bug 455628).  This run-once script will repair duplicate entries for those days.  If it happens again, we can update the dates array.  I will file another bug for fixing the stats script to make sure it doesn't fail unpredictably in the case where the slave or master are not accessible.
Attachment #339614 - Flags: review?(fligtar)
(Assignee)

Comment 3

10 years ago
Created attachment 339619 [details] [diff] [review]
v2, fixed date in delete query
Assignee: nobody → morgamic
Attachment #339614 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #339619 - Flags: review?(fligtar)
Attachment #339614 - Flags: review?(fligtar)
(Assignee)

Updated

10 years ago
OS: Mac OS X → All
Hardware: PC → All
Comment on attachment 339619 [details] [diff] [review]
v2, fixed date in delete query

Looks good. I sorta wish it was easier to run the script for a specific date via the command line or have it check for all duplicate dates, because as this bug mentions, there are other dates besides those 2 that have duplicates.
Attachment #339619 - Flags: review?(fligtar) → review+
(Assignee)

Comment 5

10 years ago
r18471
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

10 years ago
Filed an IT bug to run this in production -- bug 456396.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.