bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

No drag shadow displayed in month/multiweek view anymore

VERIFIED FIXED in 0.9

Status

Calendar
Calendar Views
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: ssitter, Assigned: Berend Cornelius)

Tracking

({regression})

unspecified
regression
Bug Flags:
wanted-calendar0.9 +

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/2008090819 Sunbird/0.9

Steps to Reproduce:
1. Create an event and switch to Month or Multiweek view
2. Drag and drop the event to a different date
3. Observe the drag shadow

Actual Results:
No drag shadow is shown. There is no visual indication where the event will be dragged to.

Expected Results:
Drag shadow is displayed the same size as the normal event.

Regression range: Works in Sunbird 0.9pre (2008-09-07-20)
                  Fails in Sunbird 0.9pre (2008-09-08-19)

Checkins during regression range: http://tinyurl.com/6quh5d

Might be regressed by Bug 348009.
Flags: wanted-calendar0.9?
(Assignee)

Comment 1

10 years ago
Created attachment 337852 [details] [diff] [review]
patch v. #1

I am sorry, this was really stupid! Yes this is a regression to Bug 348009. I paid so much attention to the freeze story that I did not notice that the dropShadows do not exist at all. Yet it was just a disturbing bracket that destroyed the patch. So  this should be an uncritical patch.
I further noticed that the dropshadows covered the whole daybox although due to their styling they should only have a fixed height of 1.2em. I fixed this, too, although this is a different story. To be sure about this I ask for ui-review.
Assignee: nobody → Berend.Cornelius
Status: NEW → ASSIGNED
Attachment #337852 - Flags: ui-review?(christian.jansen)
Attachment #337852 - Flags: review?(daniel.boelzle)
(Reporter)

Comment 2

10 years ago
Christian already commented on the size issue in Bug 432701. Adding dependency.
Blocks: 432701

Updated

10 years ago
No longer blocks: 432701
Flags: wanted-calendar0.9? → wanted-calendar0.9+
Whiteboard: qawanted
(Reporter)

Updated

10 years ago
Blocks: 432701
(Assignee)

Updated

10 years ago
Attachment #337852 - Flags: ui-review?(christian.jansen)
(Assignee)

Comment 3

10 years ago
Comment on attachment 337852 [details] [diff] [review]
patch v. #1

Removing request for ui-review as Christian already commented on this.
I suppose that the wrong size of the drop-shadows is a regression to  Bug 322979 .
(Reporter)

Comment 4

10 years ago
Patch works fine for me on Windows XP.

Side note: Using a Trunk build the additional "}" results in a reported syntax error and the view is completely broken instead of just silently failing as in the Branch build.

Updated

10 years ago
Attachment #337852 - Flags: review?(daniel.boelzle) → review+
(Assignee)

Comment 5

10 years ago
patch checked in on trunk, MOZILLA_1_8_BRANCH and SUNBIRD_0_9_BRANCH
->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
OS: Windows XP → All
Hardware: PC → All
Whiteboard: qawanted
Target Milestone: --- → 0.9
(Reporter)

Comment 6

10 years ago
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/2008091120 Sunbird/0.9.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.