Last Comment Bug 348009 - Drag and Drop in Month view freezes Un*x desktops
: Drag and Drop in Month view freezes Un*x desktops
Status: VERIFIED FIXED
: relnote
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: unspecified
: x86 Linux
: -- critical with 4 votes (vote)
: 0.9
Assigned To: Berend Cornelius
:
Mentors:
: 348006 348013 348017 462850 462858 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 04:57 PDT by Ulf Stroehler
Modified: 2011-01-30 13:06 PST (History)
7 users (show)
bugzilla: wanted‑calendar0.8-
dbo.moz: wanted‑calendar0.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v. #1 (3.63 KB, patch)
2008-09-08 06:46 PDT, Berend Cornelius
dbo.moz: review+
Details | Diff | Review

Description Ulf Stroehler 2006-08-09 04:57:59 PDT
REPRODUCTION:
=============

 - in Lightning or Sunbird's Month View do:

 * create an event
 * drag and drop the event to the same day next week

RESULT:
=======

 * Mouse pointer is not released
 * means X is blocked (no key nor mouse events are handeled) and the user's desktop appears frozen

EXPECTED RESULT:
================

 * event gets dropped at the new date

Note:
 * possibly a side effect of Bug 312736
 * considering a 0.3 Release blocker
Comment 1 Matthew (lilmatt) Willis 2006-08-09 05:34:34 PDT
Nominating for blocking0.3
Comment 2 Joey Minta 2006-08-09 07:20:13 PDT
*** Bug 348006 has been marked as a duplicate of this bug. ***
Comment 3 Joey Minta 2006-08-09 07:20:31 PDT
*** Bug 348013 has been marked as a duplicate of this bug. ***
Comment 4 Joey Minta 2006-08-09 07:20:51 PDT
*** Bug 348017 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Sitter 2006-08-09 07:42:50 PDT
Works for me using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060807 Calendar/0.3a2+.
Works for me using Lightning/0.1+ (2006080907) with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060615 Thunderbird/1.5.0.4.
Comment 6 Stefan Sitter 2006-08-09 07:53:52 PDT
(In reply to comment #5)
I forgot: Test was done using storage provider.
Comment 7 Joey Minta 2006-08-10 19:59:39 PDT
Ulf, is this provider specific or no?

Can anyone else reproduce this?
Comment 8 Ulf Stroehler 2006-08-11 06:55:05 PDT
In reply to comment #7:
no, this is not provider specific. Reproducible for with the storage provider (always).

If you fail to reproduce try the following:

 * drag and drop the event multiple times to different days

 * use an ssh connection to a remote Lin*x host (ssh -X user@host) and launch tb + lightning

 
Comment 9 Damian Szczepanik 2006-08-13 02:18:09 PDT
(In reply to comment #7)
> Ulf, is this provider specific or no?
> 
> Can anyone else reproduce this?

Yep, this helps you (I hope)
Error: shadow.parentNode has no properties
Source File: chrome://calendar/content/calendar-month-view.xml
Line: 471

for more: I can not drag & drop event and when I release button event disappears from main view, is visible only in unifinder
I looks like drag&drop is not supported for month view, no matter if this is next week or day - can not drop event :(

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060812 Calendar/0.3a2+
Comment 10 Damian Szczepanik 2006-08-13 02:34:04 PDT
(In reply to comment #9)
> I looks like drag&drop is not supported for month view
Well sometimes it works, however when I report bug I always try to reproduce with clean profile - and then I could reproduce it.
For my working profile it works, strange, so maybe it depends of some settings?
Comment 11 Joey Minta 2006-08-14 11:58:58 PDT
I talked with intern-extraordinaire michael wu.  He made a couple of interesting points, which essentially boil down to: we can't fix this in Calendar.

1.) X works on an async drag-n-drop model, while mozilla works on a synchronous model.
2.) The X model has several bugs (patches have been submitted and accepted for the next X release)

because of (1) and (2)
3.) There are unavoidable race conditions in drag and drop. (This explains why connecting to a remote X session makes this more reproducable.)

As such, I don't see any benefit to blocking the 0.3 release on something that is out of our hands.  Blocking the release on this bug would simply mean sitting on our hands for awhile until X and Moz make their respective codebases interact better.
Comment 12 Simon Paquet [:sipaq] 2006-08-14 13:34:41 PDT
If we can't fix it, we should at least mention it in the release notes.
Comment 13 Matthew (lilmatt) Willis 2006-10-30 23:07:33 PST
Should this then dupe against whatever X vs. Moz drag n' drop bug(s) already exist rather than sitting in calendar land?
Comment 14 Matthew (lilmatt) Willis 2007-03-23 16:40:14 PDT
Not going to make the 0.5 train.
Comment 15 Ulf Stroehler 2007-12-18 02:08:37 PST
this surely needs fixing before 1.0 and still occurs on all kind of Un*x like systems. Imo blocking 1.0.
Comment 16 Daniel Boelzle [:dbo] 2008-01-03 03:12:12 PST
(In reply to comment #13)
> Should this then dupe against whatever X vs. Moz drag n' drop bug(s) already
> exist rather than sitting in calendar land?
I second this. This is not a calendar problem, but toolkit's... Anybody knows a toolkit bug we could dupe against?
Comment 17 Simon Paquet [:sipaq] 2008-02-08 01:12:25 PST
Not going to happen for 0.8.
Comment 18 Berend Cornelius 2008-09-08 06:46:04 PDT
Created attachment 337441 [details] [diff] [review]
patch v. #1

I am actually working on another drag'n drop issue when I ran into this problem. As it appears to me this indeed looks like a timing problem as Joey stated in comment #11. So while I have been working on that other issue I introduced some timeouts and everything worked fine and in several days I have never again have this problem. With my remote machine a 5 ms timeout was sufficient but in this patch I uses a 10 ms timeout to be sure.
Comment 19 Daniel Boelzle [:dbo] 2008-09-08 08:09:32 PDT
Comment on attachment 337441 [details] [diff] [review]
patch v. #1

Add calendar-month-view.xml to jar.mn

Quick and dirty, but works; will be overworked either way soon.

r=dbo (agreed with Philipp)
Comment 20 Berend Cornelius 2008-09-08 08:25:07 PDT
Checked in the patch on trunk, MOZILLA_1_8 and SUNBIRD_0_9
->FIXED
Comment 21 Stefan Sitter 2008-09-10 02:59:53 PDT
This checkin most probably regressed Bug 454478.
Comment 22 Andreas Treumann 2008-10-06 02:25:07 PDT
Checked in lightning 0.9 and sunbird 0.9 -> verified.
Comment 23 Stefan Sitter 2008-11-03 08:29:51 PST
*** Bug 462858 has been marked as a duplicate of this bug. ***
Comment 24 Scott Benninghoff 2008-11-03 10:49:11 PST
*** Bug 462850 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.