If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Investigate hard orange on fx-win32-1.9-slave09 (pgo01) unittest tinderbox

RESOLVED DUPLICATE of bug 450637

Status

Infrastructure & Operations
RelOps
--
blocker
RESOLVED DUPLICATE of bug 450637
9 years ago
4 years ago

People

(Reporter: dholbert, Assigned: xb95)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
The FF3.0 tinderbox fx-win32-1.9-slave09 (pgo01) has been orange with a single reftest failure (212563-1.html) ever since its first build a month ago, starting at 2008/08/12 18:20.  (aside from the occasional red cycle)

AFAICT, this box has never ever gone green during the month that it's been up. If this is a code or test bug, it should be fixed; if this is a tinderbox / hardware issue, we should take that tinderbox offline and fix it.

Log of first build (ignoring first few failed builds):
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.0/1218590449.1218600730.29936.gz

Log of most recent build:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.0/1221059015.1221066904.25000.gz

The failure is:
REFTEST UNEXPECTED FAIL: file:///E:/slave/trunk_2k3_pgo/mozilla/layout/reftests/bugs/212563-1.html
REFTEST   IMAGE 1 (TEST): http://tinyurl.com/5ml6vc
REFTEST   IMAGE 2 (REFERENCE): http://tinyurl.com/6q3qoc

(tinyurls substituted for data: uri's)
The testcase has an empty iframe, but reference has an iframe that says "foo".
(Reporter)

Comment 1

9 years ago
Below are bonsai links to the failing testcase, reference case, and their "inner" files used in their iframes.

Test:
http://bonsai.mozilla.org//cvsblame.cgi?file=mozilla/layout/reftests/bugs/212563-1.html
http://bonsai.mozilla.org//cvsblame.cgi?file=mozilla/layout/reftests/bugs/212563-1-inner.html

Reference:
http://bonsai.mozilla.org//cvsblame.cgi?file=mozilla/layout/reftests/bugs/212563-1-ref.html
http://bonsai.mozilla.org//cvsblame.cgi?file=mozilla/layout/reftests/bugs/212563-1-ref-inner.html
(Assignee)

Comment 2

9 years ago
FYI: This machine does not have a documentation link in the Inventory database.  But another similar Win2k3 machine did, so I followed the steps here:

    https://wiki.mozilla.org/Unittest:Win2k3:ITSupport

I did a full clobber, since I can see there were a few restarts in the command history, and the bug indicates this error has persisted.

If the clobber does not resolve this issue, we will have to pass this ticket to Release Engineering for further debugging.
Assignee: server-ops → mark
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 3

9 years ago
This is a dup of bug 450637, isn't it?
(Reporter)

Comment 4

9 years ago
Yup, it's a dupe -- my pre-bug-filing searches missed that bug.

Jesse - can you finish off any remaining todos for the patch on that bug?
Resolution: FIXED → DUPLICATE
Duplicate of bug: 450637
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.