bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Remove "Always show the tab bar" from the Tabs preferences

RESOLVED DUPLICATE of bug 855370

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 855370
10 years ago
5 years ago

People

(Reporter: dao, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 339239 [details] [diff] [review]
patch

Remove "Always show the tab bar" from the Tabs preferences, but keep the hidden pref. Not officially having to supporting browser.tabs.autoHide=true allows us to do other smart things, like removing the toolbar throbber and adding a "new tab" button to the tab bar.
Attachment #339239 - Flags: review?(mano)
(Reporter)

Updated

10 years ago
Blocks: 400398

Comment 1

10 years ago
Tabs are just a shoddy duplication of the functionality of the windowing system, and yes some of us prefer not to use them.

There should absolutely remain an option to disable tabs completely and I think it should even be the default on platforms antipathic towards tabs.

(Windows, KDE and GNOME have a taskbar and it makes no sense to show a tab bar which adds absolutely no functionality)
Well, some others of us prefer to always show the tab bar. I have about 150 tabs in Firefox plus about 40 in SeaMonkey, and having that many windows cluttering my taskbar would certainly be a "loss of functionality". When I happen to start one of those browsers on a clean profile (or almost clean), if the tab bar isn't there I'm lost.

When tabs were introduced in Firefox and IE didn't have them, they were one of the reasons (certainly not the only one ;-) ) why I switched. Γριφεγ, by your reasoning, Windows was at that time "a platform antipathetic towards tabs" and therefore Firefox ought never to have had tabs on Windows. I totally disagree with that kind of reasoning. It's not because the competition hasn't got it that we shouldn't have it either.

This said, the present tabbar pref is a checkbox (Always / Only if there are at least two tabs). If some people prefer never to see a tab bar, why not? I'm not adverse to replacing that checkbox by a three-way radiobutton or drop-down, but please don't remove the UI altogether.
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> If some people prefer never to see a tab bar, why not?

Because we can design a better UI if we can assume that the tab bar is there.
(Reporter)

Updated

10 years ago
Blocks: 456984

Comment 4

10 years ago
IMHO if they don't like to have tabs to begin with, they won't care much about the "better UI" if the tabs are being forced into them.

Comment 5

10 years ago
Yes, I understand that you want to design things around the default UI, and
that's fine, however a prime selling-point of Firefox is that it's extremely
customizable. Removing a standard and often used GUI customization option
sounds like a really bad idea. Changing it to "Hide tab bar with only one tab"
or something might make sense, but removing it altogether seems excessively
drastic.

I use tabs constantly but I personally don't like the dead space when I'm down
to just one tab, and we know that I'm not the only one. I actually support the
push to make tab browsing more obvious to users but turning it all on by
default, however that doesn't mean that we also have to push against those who
simply like to configure their browser differently. Yeah, you're not proposing
the removal of the hidden option, but users shouldn't need to configure things
like that.

Comment 6

10 years ago
"Because we can design a better UI if we can assume that the tab bar is there."

IMO, a better UI is one where I get lots of vertical space. I can get this if I select "Close other tabs."

What you are doing by forcing a tabbar - and then abrogating some of it for yourselves - is taking a piece of precious screen and using it for your own purposes. I know you want to do that UI, and you think you are doing something for the good, but this kind of thinking got us to school bureaucracies where teachers are less than half the employees.

Try making your UI somewhere else. For example, there is the Menu bar. You don't use it. I keep my search field up there, but there is plenty of room for new UI there.
Really, I have to agree with everybody here saying this shouldn't be done.  Firefox is great because you can customize it.

The tab bar isn't, because it's hard to customize.  You can't choose which layer it is in your toolbars (always on the bottom), and any extra buttons in it can't be moved around ,like the left and right arrow and the dropdown among the other items that are added.  Heck, you can't even add new items to it without an extension.

Before you force some UI on people, please make sure it is more customizable.  Just treat the tab bar as "a toolbar in a toolbar" before forcing UI on people.  (The same goes with the statusbar)

I know that the tab bar UI has to show up when a person opens a new tab (instead of a window) so it will always take space, but let people control the space through the customize screen
(Reporter)

Comment 8

10 years ago
Comment on attachment 339239 [details] [diff] [review]
patch

We're going to keep the visible pref for now, although enabling this will result in a suboptimal UI, as we add features to the tab bar.
Attachment #339239 - Flags: review?(mano)
(Reporter)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 9

10 years ago
Yes, please keep the pref. Having a tab bar with one tab is absolutely useless. However, do make the new tab button customizable in its placement (draggable from tab bar to main toolbar and back). As for the throbber, you can remove the throbber from the toolbar and replace the favicon with the throbber during page loading. The places throbber almost never appears, since most computers running Windows 2000 and up can do places queries fast enough that it doesn't appear at all.

Comment 10

10 years ago
" . . . as we add features to the tab bar."

Please make them features that can be dragged to other areas of the browser.

Updated

10 years ago
Duplicate of this bug: 457095

Updated

5 years ago
Assignee: dao → nobody
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 855370
You need to log in before you can comment on or make changes to this bug.