Last Comment Bug 855370 - Remove the ability to not "Always show the tab bar"
: Remove the ability to not "Always show the tab bar"
Status: VERIFIED FIXED
[see_comment_21_for_reason_and_fix]
: ux-minimalism
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: Firefox 23
Assigned To: Josiah Bruner [:JosiahOne] (needinfo for responses)
: Bogdan Maris, QA [:bogdan_maris]
Mentors:
: 455864 594614 755595 (view as bug list)
Depends on: 877479 903720
Blocks: 647714 647729 859920
  Show dependency treegraph
 
Reported: 2013-03-27 11:06 PDT by Josiah Bruner [:JosiahOne] (needinfo for responses)
Modified: 2014-05-19 09:56 PDT (History)
28 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
23+


Attachments
Fix. (13.66 KB, patch)
2013-03-27 13:10 PDT, Josiah Bruner [:JosiahOne] (needinfo for responses)
dao+bmo: review-
limi: ui‑review+
Details | Diff | Review
Fix (13.69 KB, patch)
2013-03-27 18:01 PDT, Josiah Bruner [:JosiahOne] (needinfo for responses)
dao+bmo: review+
josiah: ui‑review+
Details | Diff | Review

Description Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-03-27 11:06:02 PDT
We should not allow the ability to hide the tab bar ever. In this day and age, browser have tabs, and hiding the entire bar is useless and in addition causes problems with the new Australis theme.

Also cleanup the code that revolves around this. Meaning we are not just removing the ui-checkbox, but the entire implementation and pref.
Comment 1 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-03-27 13:10:16 PDT
Created attachment 730310 [details] [diff] [review]
Fix.

Removes the ability and code relating to this browser.tabs.autoHide pref. Blindly marking review to dao, and ui-review (I'm assuming it's needed) to Limi.
Comment 2 Dão Gottwald [:dao] 2013-03-27 14:42:54 PDT
Comment on attachment 730310 [details] [diff] [review]
Fix.

>     // In tabs-on-top mode, move window controls to the tab bar,
>     // and in tabs-on-bottom mode, move them back to the navigation toolbar.
>-    // When there is a chance the tab bar may be collapsed, put window
>-    // controls on nav bar.
>     var fullscreenctls = document.getElementById("window-controls");
>     var navbar = document.getElementById("nav-bar");
>-    var ctlsOnTabbar = window.toolbar.visible &&
>-                       (navbar.collapsed ||
>-                          (TabsOnTop.enabled &&
>-                           !gPrefService.getBoolPref("browser.tabs.autoHide")));
>+    var ctlsOnTabbar = window.toolbar.visible && navbar.collapsed;

This needs to be window.toolbar.visible && (navbar.collapsed || TabsOnTop.enabled), right?

>       <method name="updateVisibility">
>         <body><![CDATA[
>           if (this.childNodes.length - this.tabbrowser._removingTabs.length == 1)
>-            this.visible = window.toolbar.visible &&
>-                           !Services.prefs.getBoolPref("browser.tabs.autoHide");
>+          this.visible = window.toolbar.visible;
>           else
>             this.visible = true;
>         ]]></body>
>       </method>

indentation is off
Comment 3 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-03-27 18:01:12 PDT
Created attachment 730460 [details] [diff] [review]
Fix

Can't believe I missed those. Thanks Dão! This update addresses Dão's comments. Carrying ui-review+ flag.
Comment 4 Frank Yan (:fryn) 2013-03-27 18:18:58 PDT
*** Bug 755595 has been marked as a duplicate of this bug. ***
Comment 5 Frank Yan (:fryn) 2013-03-27 18:20:04 PDT
*** Bug 455864 has been marked as a duplicate of this bug. ***
Comment 6 Dão Gottwald [:dao] 2013-03-28 03:58:47 PDT
(In reply to Josiah Bruner [:JosiahOne] from comment #0)
> causes problems with the new Australis theme.

Can you elaborate on this? Any problem with this would also affect popups, right? So it would need to be dealt with either way.
Comment 7 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-03-28 05:23:54 PDT
(In reply to Dão Gottwald [:dao] from comment #6)
> (In reply to Josiah Bruner [:JosiahOne] from comment #0)
> > causes problems with the new Australis theme.
> 
> Can you elaborate on this? Any problem with this would also affect popups,
> right? So it would need to be dealt with either way.

No. Popups are not affected by this. I'll explain.

The first issue lies simply with an annoying ui-element revolving around bug 851652, which moves the position of the window control buttons downward. This works great, except for when the tab bar is closed. Then, the button *must* go back into their original position. Although this works, it does not look very good to have window control buttons which shouldn't move their position, move.

The second problem really won't get solved by this bug alone, but with a few others it will. This also relates to bug 851652. Right now we are constantly checking for changes in the mUnifiedTitlebarHeight to figure out whether there is or isn't a tab bar (which we won't have to check after this), and also if we are in panorama or the new customize window, which changes the mUnifiedTitlebarHeight too 0.

However, Private Browsing Mode, uses the same window as the panorama or customize window, which means we can not move the buttons down at all. Fine, but not ideal. Therefore, by removing the ability to hide the tab bar, along with some bugs increasing the titlebar height on Panorama and the customize window, the buttons need not change their position at all.

Popup windows are not affected because they don't return TRUE on mCanDrawInTitlebar, however Panorama, the Customize Window, and PBM do. This is the issue.

Hope that clears things up!
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-04-02 07:47:56 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b0e27a5ae2b6
Comment 9 Ryan VanderMeulen [:RyanVM] 2013-04-02 19:35:18 PDT
https://hg.mozilla.org/mozilla-central/rev/b0e27a5ae2b6
Comment 10 JoeG 2013-04-03 13:15:06 PDT
(In reply to Josiah Bruner [:JosiahOne] from comment #0)
> We should not allow the ability to hide the tab bar ever. In this day and
> age, browser have tabs, and hiding the entire bar is useless and in addition
> causes problems with the new Australis theme.
> 
> Also cleanup the code that revolves around this. Meaning we are not just
> removing the ui-checkbox, but the entire implementation and pref.

Over the fifteen years or so I've been with Netscape and Firefox, I have NEVER heard a similarly arrogant, inconsiderate, and myopic idea - and I've heard quite a few. 

I don't know who Mr. Bruner is, but I'd like to remind him that what has kept Firefox going over the years is the ability of users to adapt it to meet personal tastes and needs.

It would really be a profound personal loss to be forced to abandon my browser of choice after all these years, but if this one goes through, the choice will have been made for me.

I have used third-party themes for as long as they've been around, and I intend to do so as long as possible. When they go, I go, and I think I won't be alone.

I know this is Bugzilla and not the Mozilla Forum. However, if Mr. Bruner thinks he can dictate to millions of users that "In this day and age, browser have tabs ...", I have to say that I think he'd better learn a bit of modesty and come to understand that he is not the sole arbiter of what the Internet is or should be. 

Please excuse my rather shrill response, but at 66 years of age and with forty years of professional experience in education, I do not take kindly to the type of tone Mr. Bruner seems to believe he has the authority to use.

Joseph Greenman
Comment 11 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-04-03 13:45:47 PDT
(In reply to Joe Greenman from comment #10)
> (In reply to Josiah Bruner [:JosiahOne] from comment #0)
> > We should not allow the ability to hide the tab bar ever. In this day and
> > age, browser have tabs, and hiding the entire bar is useless and in addition
> > causes problems with the new Australis theme.
> > 
> > Also cleanup the code that revolves around this. Meaning we are not just
> > removing the ui-checkbox, but the entire implementation and pref.
> 
> Over the fifteen years or so I've been with Netscape and Firefox, I have
> NEVER heard a similarly arrogant, inconsiderate, and myopic idea - and I've
> heard quite a few. 
> 
> I don't know who Mr. Bruner is, but I'd like to remind him that what has
> kept Firefox going over the years is the ability of users to adapt it to
> meet personal tastes and needs.
> 
> It would really be a profound personal loss to be forced to abandon my
> browser of choice after all these years, but if this one goes through, the
> choice will have been made for me.
> 
> I have used third-party themes for as long as they've been around, and I
> intend to do so as long as possible. When they go, I go, and I think I won't
> be alone.
> 
> I know this is Bugzilla and not the Mozilla Forum. However, if Mr. Bruner
> thinks he can dictate to millions of users that "In this day and age,
> browser have tabs ...", I have to say that I think he'd better learn a bit
> of modesty and come to understand that he is not the sole arbiter of what
> the Internet is or should be. 
> 
> Please excuse my rather shrill response, but at 66 years of age and with
> forty years of professional experience in education, I do not take kindly to
> the type of tone Mr. Bruner seems to believe he has the authority to use.
> 
> Joseph Greenman

Sir, I greatly respect your opinion in this matter. However, I actually not an arrogant person, nor do I think I have the power or authority to dictate changes.

But I must also direct your attention to the fact Firefox must improve itself, and the Australis theme is part of this. Keeping it causes the new look to break, and thereby is blocking many, many bugs.

But please do not think I just waltzed up here and decided to remove it. I asked about it from the UX time, and, as you can see from the ui-review+, I am not the only one who is "dictating" changes as you assume to be the case. We new going in that many would not like it, but I must ask you? Do you use this feature? What do you suppose we are stopping in this case?


I will go back to the fact that I am aware I don't have real authority, but I am an active contributor, and while I don't know *nearly* as much as you do, I am quite sure this is the right approach. Everything breaks someone's workflow, but Firefox does need to remove this, not for my sake, or for the sake of change, but for progress, which must be made.

So, Mr. Greenman, I really would love to here the actual issues with this and am open to change (I have done it before and backed out a change). I may very well believe in change, and perhaps too much, but am confident that this does need to be done. But please, contribute to the conversation, I do appreciate it.

Josiah Bruner

P.S. "Mr. Bruner" is quite formal. Please, Josiah is all you need to use.
Comment 12 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-04-03 13:46:45 PDT
Er, s/I actually/I am actually.
Comment 13 xyz 2013-04-03 14:01:55 PDT
Well, while Removing that option is Partly a not that bad move, since when an everyday's computer user just clicks without planning that option and the tab bar disappears, this can only lead to the feeling of getting **** and frustrated. So that Change is partly understandable.

But would you really call it an improvement if That changes and the many other changes which are finally leading to Australis have a much greater impact of so far unknown size to Adons and Third Party Themes?

Taking away that options can not be an improvement, no matter how much improvement Australis will bring.

How is this fitting in the concept to make the Browser Better? You do know that many many many users are only staying at Firefox because of Customization and Full Themes? Destroying that for a smaller or larger part can take away a massive number of Firefox user base.

This i would not consider as a "Bugfix" - That Change for the better is actually suicide, i guess you know that ;)
Comment 14 Justin Dolske [:Dolske] 2013-04-03 14:02:24 PDT
Just so the record is clear: It's the professional opinion of the Firefox user-experience and engineering teams that this is a highly desirable change. See http://limi.net/checkboxes-that-kill/. Improvements like this are exactly the kind of thing that helped Mozilla go from zero to hundreds of millions of users over the past decade.

Thanks for your opinion, but attacking people (however politely) is unacceptable and will lead to account suspension.

P.S. I wish you the best of luck with your new browser.
Comment 15 xyz 2013-04-03 14:22:30 PDT
You did not understood my post correclty dear Sir, i did not attack anyone at all :) 

I just was wondering if a complete main theme refresh (Australis) is worth taking away for example a stil so far not really 100% known amount of Third Party Theme creation/usage ability.

And i do not plan to move away from Firefox, but that is the way how a normal not experienced Computer User will react. Was reading such a comment for example at a theme review today.

And since a bug request also can consist lists of possible Regresses, i truly think losing that ability of theme/addon usage or Developement abilities is a regress.

And i just wanted to hear an opinion if this change is really bringing lost market share back.
Comment 16 Ian Nartowicz 2013-04-03 14:30:15 PDT
Another backward step for people who don't want to use Chrome and like Firefox for its flexibility.
Comment 17 JoeG 2013-04-03 14:31:39 PDT
(In reply to Josiah Bruner [:JosiahOne] from comment #11)
> (In reply to Joe Greenman from comment #10)
> > (In reply to Josiah Bruner [:JosiahOne] from comment #0)
> > > We should not allow the ability to hide the tab bar ever. In this day and
> > > age, browser have tabs, and hiding the entire bar is useless and in addition
> > > causes problems with the new Australis theme.
> > > 
> > > Also cleanup the code that revolves around this. Meaning we are not just
> > > removing the ui-checkbox, but the entire implementation and pref.
> > 
> > Over the fifteen years or so I've been with Netscape and Firefox, I have
> > NEVER heard a similarly arrogant, inconsiderate, and myopic idea - and I've
> > heard quite a few. 
> > 
> > I don't know who Mr. Bruner is, but I'd like to remind him that what has
> > kept Firefox going over the years is the ability of users to adapt it to
> > meet personal tastes and needs.
> > 
> > It would really be a profound personal loss to be forced to abandon my
> > browser of choice after all these years, but if this one goes through, the
> > choice will have been made for me.
> > 
> > I have used third-party themes for as long as they've been around, and I
> > intend to do so as long as possible. When they go, I go, and I think I won't
> > be alone.
> > 
> > I know this is Bugzilla and not the Mozilla Forum. However, if Mr. Bruner
> > thinks he can dictate to millions of users that "In this day and age,
> > browser have tabs ...", I have to say that I think he'd better learn a bit
> > of modesty and come to understand that he is not the sole arbiter of what
> > the Internet is or should be. 
> > 
> > Please excuse my rather shrill response, but at 66 years of age and with
> > forty years of professional experience in education, I do not take kindly to
> > the type of tone Mr. Bruner seems to believe he has the authority to use.
> > 
> > Joseph Greenman
> 
> Sir, I greatly respect your opinion in this matter. However, I actually not
> an arrogant person, nor do I think I have the power or authority to dictate
> changes.
> 
> But I must also direct your attention to the fact Firefox must improve
> itself, and the Australis theme is part of this. Keeping it causes the new
> look to break, and thereby is blocking many, many bugs.
> 
> But please do not think I just waltzed up here and decided to remove it. I
> asked about it from the UX time, and, as you can see from the ui-review+, I
> am not the only one who is "dictating" changes as you assume to be the case.
> We new going in that many would not like it, but I must ask you? Do you use
> this feature? What do you suppose we are stopping in this case?
> 
> 
> I will go back to the fact that I am aware I don't have real authority, but
> I am an active contributor, and while I don't know *nearly* as much as you
> do, I am quite sure this is the right approach. Everything breaks someone's
> workflow, but Firefox does need to remove this, not for my sake, or for the
> sake of change, but for progress, which must be made.
> 
> So, Mr. Greenman, I really would love to here the actual issues with this
> and am open to change (I have done it before and backed out a change). I may
> very well believe in change, and perhaps too much, but am confident that
> this does need to be done. But please, contribute to the conversation, I do
> appreciate it.
> 
> Josiah Bruner
> 
> P.S. "Mr. Bruner" is quite formal. Please, Josiah is all you need to use.

Mr. Bruner,

Please excuse my "formality", but where I live, using "Mr." is quite normal among adults who don't know each other.

In your response you wrote 
1. "But I must also direct your attention to the fact Firefox must improve itself, and the Australis theme is part of this."
2. "I am quite sure this is the right approach."
3. " ... but Firefox does need to remove this, ... for progress, which must be made."

These assumptions are based upon your opinion. While you're certainly entitled to your opinion - which, by the way, I do not share in these three cases - I think your approach was inappropriate, and there are apparently other people who share my opinion.
http://forums.mozillazine.org/viewtopic.php?f=23&t=2687123&p=12773117#p12773117

And if your repeated use of the word "must" doesn't reflect a type of arrogance, I'm afraid, sir, we also disagree on the meaning of the word. 

This is what my dictionary says: " an attitude of superiority manifested in an overbearing manner or in presumptuous claims or assumptions". (http://www.merriam-webster.com/dictionary/arrogance)

But I'll try to keep this simple: Until today there was a choice to have the tab always visible bar or not. To answer your question, yes, I chose not to show it.  

You've taken this choice away. I, sir, am VERY upset that you have.

Thank you for your ongoing participation in this discussion.
Comment 18 Larry Snow 2013-04-03 14:34:12 PDT
As a longtime user of Firefox I hate this change.  It wastes so much valuable real estate when I am only using one tab, which is most of the time.  I use tabs, of course, but only when I need to have multiple pages open at the same time.
Comment 19 Justin Dolske [:Dolske] 2013-04-03 14:37:39 PDT
saphirjd: comment 14 was a reply to comment 10.

I see this is going off into the weeds, so I'm restricting comments. If someone has a constructive comment, post to firefox-dev.

[Comments now restricted to users with the editbugs privilege -- with privilege comes responsibility, so please consider carefully before commenting if you are able.]
Comment 20 Lukas Blakk [:lsblakk] use ?needinfo 2013-05-21 11:12:01 PDT
This has been noted in the Aurora 23 release notes:

http://www.mozilla.org/en-US/firefox/23.0a2/auroranotes/

If you would like to make any changes or have questions/concerns please contact me directly.
Comment 21 Josiah Bruner [:JosiahOne] (needinfo for responses) 2013-05-21 11:27:33 PDT
Since probably more people will be curious (and potentially frustrated) about this change, I do want to say one final thing, especially since this is going on release notes.

My first comment wasn't written very well. We are aware that some people may use this feature, and if more people where computer-savvy this change wouldn't be made, but the UX team has decided that certain options need to be removed for the sake of simplicity. In addition, our own development can not happen as quickly with this previous feature. Unfortunately a few people will be affected by this change, and I am sorry about that.

But, if you miss this feature, I direct you too: https://addons.mozilla.org/en-US/firefox/addon/hide-tab-bar-with-one-tab/

Which re-enables this previous ability. Cheers!
Comment 22 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-06-17 15:46:45 PDT
Adding this to the sign-off criteria for Firefox 23.0b1.
Comment 23 Bogdan Maris, QA [:bogdan_maris] 2013-06-19 07:26:26 PDT
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130619 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:23.0) Gecko/20130619 Firefox/23.0
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130619 Firefox/23.0

Verified in latest Aurora that "Always show the tab bar" is no longer available in Options/Preferences - Tabs.
Comment 24 Neil Deakin 2014-03-18 10:00:04 PDT
*** Bug 594614 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.