Closed Bug 456668 Opened 12 years ago Closed 11 years ago

Multiple forwarded (attached) messages given the same name

Categories

(MailNews Core :: Attachments, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: waynegwoods, Assigned: iann_bugzilla)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

This looks like a recurrence of bug 309208 from 2005...

If you "forward as attachment" for multiple selected messages, the messages are all given the same name - that of the first attached message. This isn't just a display problem in the attachment pane. The recipient sees them all with the same name as well.

STR:
1. Select several messages in the threadpane
2. Message -> Forward As -> Attachment
3. Look at the attachment pane - all messages have the sane name

Tested with the latest Shredder nightly build (20080922031046). No third party add-ons. Not sure of the regression point yet.
The regression seems to have occurred between the 2008091003 and 2008091103 builds. But on Bonsai I can't pick a likely candidate for that time frame.
Regression win: 2008-09-10 -> 2008-09-11 - both thunderbird and seamonkey
<http://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-09-10+03%3A03%3A49&enddate=2008-09-11+03%3A00%3A25>

Backing out bug 454182 fixes it...
Blocks: 454182
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
A better fix would be to only set the hdr when the uri contains "type=application/x-message-display" which it used to do before the fix on bug 366482 landed.
So something like in nsMsgComposeService::OpenComposeWindow
+          if (PL_strstr(originalMsgURI, "type=application/x-message-display"))
+            pMsgComposeParams->SetOrigMsgHdr(origMsgHdr);
-          pMsgComposeParams->SetOrigMsgHdr(origMsgHdr);

but I've not tested it yet and it might not be the best fix as the issue only seems to be with multiple attachments so we are probably working out information we already have access to.
This patch:
* Checks the number of attachments and if more than 1 passes null rather than the first header to force compose to correctly discover all the attachment subjects.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #344045 - Flags: superreview?(bienvenu)
Attachment #344045 - Flags: review?(neil)
Comment on attachment 344045 [details] [diff] [review]
Detect number off attachments patch v0.1

this looks good - you might want to wrap the line, and I think a comment would be good.
Attachment #344045 - Flags: superreview?(bienvenu) → superreview+
Attachment #344045 - Flags: review?(neil)
Changes since v0.1:
* Added comment.
* Wrapped line.
Attachment #344045 - Attachment is obsolete: true
Attachment #344159 - Flags: superreview+
Attachment #344159 - Flags: review?(neil)
Duplicate of this bug: 459247
Comment on attachment 344159 [details] [diff] [review]
Revised patch with comment v0.1a (Checked in: Comment 9)

>+                                          messageArray.length > 1 ? null : hdr,
It must be me, but ? null : just doesn't look right.
(I guess the alternative is == 1 ? hdr : null, but that takes up more room!)
Attachment #344159 - Flags: review?(neil) → review+
Comment on attachment 344159 [details] [diff] [review]
Revised patch with comment v0.1a (Checked in: Comment 9)

Checkin http://hg.mozilla.org/comm-central/rev/2086f5b7fb2a
Attachment #344159 - Attachment description: Revised patch with comment v0.1a → Revised patch with comment v0.1a (Checked in: Comment 9)
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
Duplicate of this bug: 463146
You need to log in before you can comment on or make changes to this bug.