Closed Bug 456706 Opened 14 years ago Closed 8 years ago

Replying to a CalDAV invitation returns MODIFICATION_FAILED but succeeds.

Categories

(Calendar :: Provider: CalDAV, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 540410

People

(Reporter: trs80, Unassigned)

Details

(Whiteboard: [not needed beta][no l10n impact][calconnect31])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 2008091719

Replying to a CalDAV invitation results in a MODIFICATION_FAILED dialog, although the reply is processed successfully.

Reproducible: Always

Steps to Reproduce:
1. Click invitations(1)
2. Click accept
3. Click OK
Actual Results:  
Error dialog saying "An error has occurred when writing to the calendar Work! 
Details:
Error number: MODIFICATION_FAILED
Description:", but the reply is sent successfully.

Expected Results:  
Reply is sent silently.

Server is Bedework 3.4.1.1, CalDAV scheduling enabled.

debug logs:
CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VEVENT
CREATED:20080924T085917Z
LAST-MODIFIED:20080924T090120Z
DTSTAMP:20080924T090120Z
UID:42553375-a88f-4f64-a9b3-dd65da1ac40e
SUMMARY:WotLK Released
ORGANIZER;RSVP=FALSE:mailto:greg@daa.com.au
ATTENDEE;RSVP=TRUE;CN=James Andrewartha;PARTSTAT=ACCEPTED;
 ROLE=REQ-PARTICIPANT:mailto:jamesa@daa.com.au
DTSTART;VALUE=DATE:20081113
DTEND;VALUE=DATE:20081114
LOCATION;X-BEDEWORK-UID=4b917b81-1c796171-011c-9396a740-00003b6c:The 
 World of Warcraft
SEQUENCE:1
TRANSP:TRANSPARENT
X-MOZ-GENERATION:1
END:VEVENT
END:VCALENDAR

CalDAV: Item modified successfully.

CalDAV: send: <calendar-multiget xmlns:D="DAV:" xmlns="urn:ietf:params:xml:ns:caldav">
  <D:prop>
    <D:getetag/>
    <calendar-data/>
  </D:prop>
  <D:href>/ucaldav/user/jamesa/calendar/In-4b917b81-1c796171-011c-9396a87d-00003b6e.ics</D:href>
</calendar-multiget>

CalDAV: send: <?xml version="1.0" encoding="UTF-8"?>
<calendar-multiget xmlns:D="DAV:" xmlns="urn:ietf:params:xml:ns:caldav">
  <D:prop>
    <D:getetag/>
    <calendar-data/>
  </D:prop>
  <D:href>/ucaldav/user/jamesa/calendar/In-4b917b81-1c796171-011c-9396a87d-00003b6e.ics</D:href>
</calendar-multiget>

CalDAV: Unexpected status deleting item: 500

Warning: There has been an error reading data for calendar: Work.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REMOVE_ERROR. Description: There was an error deleting the item from the server.

Error: An error occurred when writing to the calendar Work! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///C:/Documents%20and%20Settings/jan/Application%20Data/Thunderbird/Profiles/2txa67ku.James/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///C:/Documents%20and%20Settings/jan/Application%20Data/Thunderbird/Profiles/2txa67ku.James/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 952
Accepting an invitation to a changed event also returns MODIFICATION_FAILED, but this time the reply isn't sent. Debug logs:

CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Australia/Perth
X-LIC-LOCATION:Australia/Perth
BEGIN:STANDARD
TZOFFSETFROM:+0800
TZOFFSETTO:+0800
TZNAME:WST
DTSTART:19700101T000000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20080924T081753Z
LAST-MODIFIED:20080924T091249Z
DTSTAMP:20080924T091249Z
UID:616bbd17-4cfe-43f6-a3be-f58413cecd34
SUMMARY:Pub lunch Redux
ORGANIZER;RSVP=FALSE:mailto:greg@daa.com.au
ATTENDEE;RSVP=TRUE;CN=James Andrewartha;PARTSTAT=ACCEPTED;
 ROLE=REQ-PARTICIPANT:mailto:jamesa@daa.com.au
DTSTART;TZID=Australia/Perth:20080926T123000
DTEND;TZID=Australia/Perth:20080926T133000
DESCRIPTION:I wish...
LOCATION;X-BEDEWORK-UID=4b917b81-1c796171-011c-93a17a52-00003bb2:Basement 
 on Broadway
SEQUENCE:2
X-MOZ-GENERATION:1
END:VEVENT
END:VCALENDAR

CalDAV: Unexpected status on modifying item: 400
Warning: There has been an error reading data for calendar: Work.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_PUT_ERROR. Description: There was an error storing the item on the server.
Error: An error occurred when writing to the calendar Work! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///C:/Documents%20and%20Settings/jan/Application%20Data/Thunderbird/Profiles/2txa67ku.James/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///C:/Documents%20and%20Settings/jan/Application%20Data/Thunderbird/Profiles/2txa67ku.James/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 952
I'm unable to reproduce the first error today, and didn't have server logging enabled yesterday, all I have is the access log which notes "POST /ucaldav/user/jamesa/Outbox/ HTTP/1.1" 500 1207 so I guess ignore that for now.

The second error is reproducible, the Bedework logs report edu.rpi.cct.webdav.servlet.shared.WebdavBadRequest: Mismatched names which happens even when the name of the event hasn't changed. Putting in some debugging shows Lightning is trying to PUT In-4b917b81-1c985cd5-011c98c81d84-000002f1.ics which is the .ics of the update in the CalDAV Inbox, but Bedework is expecting In-4b917b81-1c985cd5-011c98c73425-000002dd.ics which is the .ics of the event in the main calendar. Is this a bug in Bedework or Lightning?
comment #1 bug is reproducible.

Accepting the event a second time after the organizer changed the start/endtime of the event leads to the modification failed error message.

error output:

Error: An error occurred when writing to the calendar Bedework - caluser2! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/ulb7u3fd.shredder/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/ulb7u3fd.shredder/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 944

I checked this with a second caldav server (non bedework) and I got the same error message.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → Trunk
Flags: blocking-calendar1.0+
I don't have a bedework server available right now.

Which other servers have this problem?

Daniel, ludovic, any ideas on why this may happen?
Keywords: qawanted
Whiteboard: [not needed beta][no l10n impact]
I think this is similar/identical to an issue I'm seeing. I'm using a Google Apps calendar via caldav. Everything appears to work ok (I can view/create events fine), but attempts to accept an invitation *always* fail with the MODIFICATION_FAILED message. I think a reply is sent to the meeting organiser, but the calendar event is *never* added to my calendar.

I'm using Thunderbird 3.0 Beta 3 and Lightning 1.0pre (nightly build 2009-08-20-05).

Console messages follow, but I'd say the most important one is:

"Cannot create/update events where you are not the organizer"

Full error console messages:

iTIP method: REQUEST

iTIP on REQUEST: no existing items.

iTIP operations: 1

iTIP options on: REQUEST

CalDAV: itemUri.spec = https://www.google.com/calendar/dav/{calendar id removed}/events/040000008200E00074C5B7101A82E00800000000008B5FF9A121CA01000000000000000010000000C0E8C0008370394CAF0B93C30B7C9728.ics

CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Korea Standard Time
BEGIN:STANDARD
DTSTART:16010101T000000
TZOFFSETFROM:+0900
TZOFFSETTO:+0900
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T000000
TZOFFSETFROM:+0900
TZOFFSETTO:+0900
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
LAST-MODIFIED:20090821T023826Z
DTSTAMP:20090821T023826Z
UID:040000008200E00074C5B7101A82E00800000000008B5FF9A121CA0100000000000000
 0010000000C0E8C0008370394CAF0B93C30B7C9728
SUMMARY:{subject removed}
PRIORITY:5
STATUS:CONFIRMED
ORGANIZER;CN={name removed}:mailto:{email removed}
ATTENDEE;RSVP=TRUE;CN={name removed};PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTI
 CIPANT:mailto:{email removed}
ATTENDEE;RSVP=TRUE;CN={name removed};PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIP
 ANT:mailto:{email removed}
ATTENDEE;RSVP=TRUE;CN={name removed};PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIP
 ANT:mailto:{email removed}
ATTENDEE;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPANT:mailto:{email removed}
DTSTART;TZID=Korea Standard Time:20090824T093000
DTEND;TZID=Korea Standard Time:20090824T100000
DESCRIPTION;LANGUAGE=en-US: {message removed}
CLASS:PUBLIC
TRANSP:OPAQUE
SEQUENCE:0
LOCATION;LANGUAGE=en-US:{subject removed}
X-MICROSOFT-CDO-APPT-SEQUENCE:0
X-MICROSOFT-CDO-OWNERAPPTID:-736852007
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INSTTYPE:0
X-MOZ-RECEIVED-SEQUENCE:0
X-MOZ-RECEIVED-DTSTAMP:20090820T042449Z
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT5M
DESCRIPTION:Default Mozilla Description
END:VALARM
END:VEVENT
END:VCALENDAR

CalDAV: recv: <HTML>
<HEAD>
<TITLE>Cannot create/update events where you are not the organizer</TITLE>
</HEAD>
<BODY BGCOLOR="#FFFFFF" TEXT="#000000">
<H1>Cannot create/update events where you are not the organizer</H1>
<H2>Error 403</H2>
</BODY>
</HTML>

CalDAV: Unexpected status adding item to Google: 403

Warning: There has been an error reading data for calendar: Google.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_PUT_ERROR. Description: There was an error storing the item on the server.

Error: An error occurred when writing to the calendar Google! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///C:/Documents%20and%20Settings/kkauper/Application%20Data/Thunderbird/Profiles/8ah7olhz.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/kkauper/Application%20Data/Thunderbird/Profiles/8ah7olhz.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 997
(In reply to comment #5)
> Console messages follow, but I'd say the most important one is:
> "Cannot create/update events where you are not the organizer"

See Bug 511098.
Simon, any idea why this is happening? Can you reproduce?
This bug seems to have the same root cause as bug 540398 (See my comment #6)
i have a fix for this in a thunderbird 3.1, lightning 1.0b2, horde kronolith H3 (2.3.4), jetty 6.1.22 environment, based on this post:
http://marc.info/?l=kronolith&m=121095297806530.

read/write sync works well by adding the following lines to /usr/local/share/horde/pear/php/HTTP/WebDAV/Server.php in the PUT switch statement:

case 'HTTP_CONTENT_TYPE': // defined on IIS and has the same value as CONTENT_TYPE
break;
                
case 'HTTP_CONTENT_LENGTH': // defined on IIS and has the same value as CONTENT_LENGTH
        break;


regards,
greg johnson
Whiteboard: [not needed beta][no l10n impact] → [not needed beta][no l10n impact][calconnect25]
Whiteboard: [not needed beta][no l10n impact][calconnect25] → [not needed beta][no l10n impact][calconnect31]
I've taken a look at this and the standard case works for me. The different organizer issue should be handled in bug 540410
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540410
You need to log in before you can comment on or make changes to this bug.