Closed Bug 540410 Opened 10 years ago Closed 5 years ago

Only last address of calendar-user-address-set is taken into account when determining if invited

Categories

(Calendar :: Provider: CalDAV, defect)

Lightning 1.0b1
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 865726

People

(Reporter: quillaud, Unassigned)

References

Details

(Whiteboard: [calconnect25])

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

Lightning 1.0b1 with CalDAV Scheduling enabled.

When a user has multiple calendar addresses, only the last one is taken into account when determining whether it is an invitation (in order to show accept/decline instead of an edit window)

As part of the bootstrap process, Lightning is issuing a PROPFIND, asking for the following:

<D:propfind xmlns:D="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav">
  <D:prop>
    <C:calendar-home-set/>
    <C:calendar-user-address-set/>
    <C:schedule-inbox-URL/>
    <C:schedule-outbox-URL/>
  </D:prop>
</D:propfind>

The server replies with:

<?xml version="1.0" encoding="UTF-8"?><D:multistatus xmlns:D="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav" xmlns:M="urn:ietf:params:xml:ns:carddav">
<D:response>
<D:href>/davserver/dav/principals/Arnaud.quillaud@sun.com/</D:href>
<D:propstat>
<D:prop>
<C:calendar-home-set><D:href>/davserver/dav/home/Arnaud.quillaud@sun.com/</D:href></C:calendar-home-set>
<C:calendar-user-address-set><D:href>mailto:arnaud.quillaud@sun.com</D:href><D:href>mailto:arnaudq@ics-s8.red.iplanet.com</D:href></C:calendar-user-address-set>
<C:schedule-inbox-URL><D:href>/davserver/dav/home/Arnaud.quillaud@sun.com/calendar-inbox/</D:href></C:schedule-inbox-URL>
<C:schedule-outbox-URL><D:href>/davserver/dav/home/Arnaud.quillaud@sun.com/calendar-outbox/</D:href></C:schedule-outbox-URL>
</D:prop>
<D:status>HTTP/1.1 200 OK</D:status>
</D:propstat>
</D:response>
</D:multistatus>

So the calendar-user-address-set contains 2 addresses:
* mailto:arnaud.quillaud@sun.com
* mailto:arnaudq@ics-s8.red.iplanet.com
If an invitation is sent (through CalDAV Scheduling) to the first address, the event is shown as a regular event (opening it brings up the edit window).
If an invitation is sent to the second address, the event is shown as an invitation (expected behavior)

Reproducible: Always
Summary: Only last calendar-user-address-set is taken into account when determining if invited → Only last address of calendar-user-address-set is taken into account when determining if invited
Version: unspecified → Lightning 1.0b1
I think this is a duplicate or similiar to bug #539916.

I do not understand why my address configured in the lightning calendar updates
is not used.
Duplicate of this bug: 539916
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86_64 → All
If we make more use of the ACL manager, we could get this bug squashed. Instead of just checking for one identity we could use the ACL manager to check for all configured identities.

Maybe I can hack something together for the coming calconnect XXV.
Whiteboard: [calconnect25]
Duplicate of this bug: 555936
I think TB 1.9.1 accepts now all invitations even those that are not for the user. Simply, everything that comes to inbox could be considered as invitation and TB/Lightning could respond to such invitation. 

However, Lightning still has problem with user email for invitations and responding.
Lightning is using only the last email (for sending invitations and for responding to invitations) received from CalDAV server:
Bug 865726 - Only last email used for Invitation/Acceptance
Duplicate of this bug: 451039
Duplicate of this bug: 456706
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865726
You need to log in before you can comment on or make changes to this bug.