Closed Bug 456863 Opened 13 years ago Closed 13 years ago

New/Edit Card tooltip not resetting in Header bar display

Categories

(Thunderbird :: Mail Window Front End, defect, P1)

x86
Windows Vista

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: ronkillmer1, Assigned: standard8)

References

(Blocks 1 open bug)

Details

(Whiteboard: [needs review dmose])

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: Shredder nightly 2008/09/24

From https://bugzilla.mozilla.org/show_bug.cgi?id=450724#c79

Found a bug in the New/Edit Card Inline feature set. The tooltip is not resetting.

After viewing a Signed message in Inbox I switched to Local > Drafts to look at
how the Star worked there. On hovering the From: I saw the Tooltip still
showing the info from the prior message viewed.

I switched to a news account and hovered the posters display name in the header
view.  It also was showing the tooltip from the first viewed message. The referenced screen shot shows this.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
Tooltip will match the full "DisplayName<email@name.x>" the cursor is hovering over in the Header Bar display.

See screen shot attachment: 
https://bugzilla.mozilla.org/attachment.cgi?id=340185
Nominate Blocking Tb 3.0
Flags: blocking-thunderbird3?
Attached patch The fix (obsolete) — Splinter Review
I miss read this bug when I first saw it. It is especially noticeable in the collapsed view.

To repeat it in simple steps, select an email where the from address is in your address book, then select an email where the from address isn't in your address book. Then hover over and read the tooltip - it has stuck with the email address that was in your address book.

This patch fixes that by reverting back to using tooltiptext rather than tooltipemail. I'd originally separated them because I wanted a separate tooltip on the star (tooltipstar) however, the updateEmailAddressNode function in mailWidgets.xml was still using the old tooltiptext - this was causing the problem as the tooltip wasn't refreshed in the right place.

The tooltip for the star still works, I expect that is because the inherited xul attribute overrides the normal one, via the tooltiptext=tooltipstar.
Assignee: nobody → bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #340329 - Flags: review?(dmose)
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Priority: -- → P1
Target Milestone: --- → Thunderbird 3.0b1
Whiteboard: [needs review dmose]
Attached patch The fix v2Splinter Review
Slightly updated patch that addresses a couple of other mistakes as well.

One was in UpdateEmailNodeDetails we were setting the wrong tooltip for the star if an email no longer had a card associated with it. This can be seen if you delete a card whilst display an email with which it is associated.

The other was in updateExtraAddressProcessing in mailWidgets.xml, in the for loop I had assumed that the number of email addresses (mAddresses.length) was the same as 2 * childNodes. This wasn't true. mAddresses contains all the current addresses for the element actually displayed, whereas childNodes can contain displayed email addresses as well as cached ones. So here we should be using mAddresses.length. This avoids assertions like "aAddressData is not defined" in msgHdrViewOverlay.js

To reproduce the second point you'd need to select an email with lots of to addresses, then select an email with only one email address.
Attachment #340329 - Attachment is obsolete: true
Attachment #340410 - Flags: review?(dmose)
Attachment #340329 - Flags: review?(dmose)
Comment on attachment 340410 [details] [diff] [review]
The fix v2

Looks good; r=dmose.
Attachment #340410 - Flags: review?(dmose) → review+
Patch checked in, changeset id 439:d0c6b8e99b06
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.