Closed Bug 456923 Opened 12 years ago Closed 12 years ago

add a build target to compare bin/ and the package list

Categories

(Calendar :: Build Config, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug 451185 / Bug 451981 +++

Robert's comment:

To be able to check if our package lists are OK, it would be nice to have a build target that outputs a diff of the dist/bin directory and the files in the package list. This gives us a fast check what we aren't packaging and what we have in the package list that isn't built any more. Our builder boxes could even execute that so we can look into their logs and see that package diff easily.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #340286 - Flags: review?(ause)
pack-list.txt still contains wildcards. the following line looks ugly but expands them:

grep "^bin" $(MOZ_PKG_MANIFEST) | sed -e 's/\\/\//g' | perl -e 'while(<>){if($$_=~/\*/){while(glob $$_){print $$_."\n";}}else{print $$_}}'| sort > $(DIST)/pack-list.txt
Yes, I noticed that but decided to use the same code as Thunderbird and SeaMonkey. I thought interpreting the output of the command above and deciding if the packages file needs to be updated is a different topic.
Comment on attachment 340286 [details] [diff] [review]
add package-compare target

though i would prefer an output that vanishes if everything is ok instead of pages of output to analyze. especially when used in automated builds.
Attachment #340286 - Flags: review?(ause) → review+
Keywords: checkin-needed
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/b7a5744f2be7>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Duplicate of this bug: 460011
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.