Dragging a url to the tabbar loads it in multiple tabs

VERIFIED FIXED in Firefox 3.1b1

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: bz, Assigned: mano)

Tracking

({regression, verified1.9.1})

Trunk
Firefox 3.1b1
regression, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3.5 +
in-testsuite ?
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

BUILD: 2008-10-01 morning debug build

STEPS TO REPRODUCE:
1)  Start the browser
2)  Load http://www.mozilla.org/projects/minefield/
3)  Make sure you have two tabs open
4)  Focus the tab the load from step 2 happened in
5)  Grab the lizard head icon in the url bar, drag it to the right-hand side of
    the tabbar (to the right of both existing tabs), and drop it.  Make sure to
    not hover the existing tabs in the process.

EXPECTED RESULTS: New tab loads with the url

ACTUAL RESULTS: New tab loads with the url, but the url is also loaded in the existing tab focused in step 4.

NOTES: The same result obtains if dragging any link from the document to the right-hand side of the tabbar.

Pretty sure this is a regression.
Flags: blocking-firefox3.1?

Updated

10 years ago
Blocks: 456048
I can't reproduce this ... but I'm not sure I've understood your
description.

I tested with today's Minefield nightly
(2008-10-01-02-mozilla-central) on OS X 10.5.5.

> but the url is also loaded in the existing tab focused in step 4

Don't you mean "reloaded" (since that tab already contained
http://www.mozilla.org/projects/minefield/, thanks to step 2)?

But I didn't see that tab reload, either.

Comment 2

10 years ago
I confirmed the issue in Windowx XP.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081001 Minefield/3.1b1pre
Created attachment 341432 [details] [diff] [review]
patch

Stopping propagation on the per-spec drop event doesn't stop the legacy draqdrop event. I'm not sure if this isn't something we should work around in gecko as well.
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #341432 - Flags: review?(mconnor)
Flags: blocking-firefox3.1? → blocking-firefox3.1+

Updated

10 years ago
Attachment #341432 - Flags: review?(mconnor) → review+
I no longer see this with today's nightly..

Fixed with https://bugzilla.mozilla.org/show_bug.cgi?id=454324 ???

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20081006 Minefield/3.1b1pre ID:20081006034237
a=beltzner for beta 1 landing, see bug 458696 comment 5; bz's right, since we repaired the core code which caused the crash and are now using the new drag & drop API to do tag drag n' drop, we should make an effort to reduce regressions in that new path for beta.
Landed for b1 with a=beltzner

http://hg.mozilla.org/mozilla-central/rev/060b7352c2ad
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
OS: Mac OS X → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b1
Version: unspecified → Trunk

Updated

10 years ago
Duplicate of this bug: 458879

Comment 9

10 years ago
Maybe this will help:

Also it seems that "draggesture" events can not be cancelled by event
listeners listening to "draggesture". (from Chrome/e.g. extensions)
verified fixed using  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20081007 Minefield/3.1b1pre.
Status: RESOLVED → VERIFIED
Also verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2) Gecko/2008091618 Firefox/3.0.2 ID:2008091618

Something we could cover with an automated test? Or shall we create a Litmus test for now?
Flags: in-testsuite?
Flags: in-litmus?

Updated

10 years ago
Duplicate of this bug: 458534

Updated

10 years ago
Duplicate of this bug: 458599

Updated

10 years ago
Depends on: 459334
https://litmus.mozilla.org/show_test.cgi?id=7393 added to Litmus FFT.
Flags: in-litmus? → in-litmus+
Keywords: fixed1.9.1
Keywords: fixed1.9.1 → verified1.9.1
You need to log in before you can comment on or make changes to this bug.