Closed Bug 458696 Opened 14 years ago Closed 14 years ago

Dropping a tab on Tabbar causes reload the page

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 3.1b1

People

(Reporter: hidenosuke, Unassigned)

References

Details

(Keywords: regression, verified1.9.1, Whiteboard: [fixed by bug 458070])

Bug 458048 has been fixed then we can drag and drop a tab again.
By the way dragging and dropping a tab cauases reloading the page.
This seems regression.

Steps to reproduce:
1. Open two tabs or more.
2. Dragging a tab and drop into any places on the tabbar.

Actual result:
Reloading the page.

Expeected result:
Not reload the page.

I observed with 20081006 Linux and Windows build.
Confirmed also on Vista HP SP1
Blocks: 456048
Severity: normal → major
Flags: blocking-firefox3.1?
Keywords: regression
one line fix..... add aEvent.preventDefault() to _onDrop method

      <method name="_onDrop">
        <parameter name="aEvent"/>
        <body>
          <![CDATA[
+           aEvent.preventDefault();
            var dt = aEvent.dataTransfer;
            var dropEffect = dt.dropEffect;
            var draggedTab;
            if (dropEffect != "link") { // copy or move
              draggedTab = dt.mozGetDataAt("application/x-moz-node", 0);
              NS_ASSERT(draggedTab && draggedTab.localName == "tab",
                        "copy or move action without a tab");
            }
I'm sure I've seen a duplicate of this bug somewhere.
(In reply to comment #3)
> I'm sure I've seen a duplicate of this bug somewhere.

Sounds similar to bug 458070
Given that one of the things we want people to test is the new tab d&d, and that it sounds like this bug makes it not happen at all, should this be blocking beta?
This is fixed by the patch in bug 458070.
Depends on: 458070
Landed patch in bug 458070:

http://hg.mozilla.org/mozilla-central/rev/060b7352c2ad
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Flags: blocking-firefox3.1?
Hardware: PC → All
Whiteboard: [fixed by bug 458070]
I confired to fix the problem with today's Linux build.
Thanks!
Status: RESOLVED → VERIFIED
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20081007 Minefield/3.1b1pre
Target Milestone: --- → Firefox 3.1b1
You need to log in before you can comment on or make changes to this bug.