Closed Bug 459045 Opened 11 years ago Closed 11 years ago

very first notification is empty

Categories

(Thunderbird :: Mail Window Front End, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: u294409, Assigned: Bienvenu)

Details

(Keywords: regression, Whiteboard: [no l10n impact])

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9.0.3) Gecko/2008092416 openSUSE/11.0 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9.1b1pre) Gecko/20081008 Lightning/1.0pre Shredder/3.0b1pre

every first notification in thunderbird is empty. every next isn't.

Reproducible: Always

Steps to Reproduce:
1. download TB nightly
2. configure
3. close and open again
Actual Results:  
empty notification

Expected Results:  
filled notification
Attached image very first notification
I'm seeing this as well. I believe it's because we have a folder in the list of folders with new messages that doesn't have new messages, and it makes the newmailalert code bail out early. I'll try to debug this when I get a chance...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090914 Shredder/3.0b4pre

This happens every time I start Thunderbird and have new mail, not only the first or second time I use Thunderbird.
Flags: blocking-thunderbird3?
Whiteboard: [no l10n impact]
not just linux i guess.
OS: Linux → All
Hardware: x86 → All
QA, it'd be super if we could get reliable STRs for this one.
Assignee: nobody → bienvenu
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Keywords: qawanted
this gets rid of the empty alert - in fact, it gets rid of the alert completely in the error case. I'd like to know why we're getting into this situation, but this fix should do for now.
Attachment #402724 - Flags: review?(mkmelin+mozilla)
Whiteboard: [no l10n impact] → [no l10n impact][has patch for review mkmelin]
Attached image Folder for said account
(In reply to comment #5)
> QA, it'd be super if we could get reliable STRs for this one.

I have a gmail account I'm willing to share that exhibit this behavior on first install. And does it reliabely.

Bienvenu see the screenshot for folders and their state.
Keywords: qawanted
Comment on attachment 402724 [details] [diff] [review]
get rid of empty alert

The return makes us not prefill the alert, but does it really not show at all?

Bug 471772 is likely dupe (cause wise)
(In reply to comment #8)
> (From update of attachment 402724 [details] [diff] [review])
> The return makes us not prefill the alert, but does it really not show at all?

Seems to, in my tests - basically, we don't throw an exception with this patch, which seems to make things a lot cleaner.

> 
> Bug 471772 is likely dupe (cause wise)
Comment on attachment 402724 [details] [diff] [review]
get rid of empty alert

r=mkmelin

That 160 char row could be wrapped though.
Attachment #402724 - Flags: review?(mkmelin+mozilla) → review+
Whiteboard: [no l10n impact][has patch for review mkmelin] → [no l10n impact][ready to land]
Target Milestone: --- → Thunderbird 3.0rc1
fix checked in, with long line wrapped
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][ready to land] → [no l10n impact]
You need to log in before you can comment on or make changes to this bug.