Closed Bug 459235 Opened 11 years ago Closed 11 years ago

[meta] Tp regressions by enabling Places Fsync stuff

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.1b2

People

(Reporter: sdwilsh, Unassigned)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #459197 +++

the latest push of fsync stuff caused a Ts and a Tp regression, and was backed out to investigate on possible ways of fixing it.

We should investigate on possible solutions to solve both issues (this bug is Tp only), actual ideas could be
- move some of the visit insert trigger work to an async query (update visit_count later?)
- move sync from places background to an async query and discard PlacesBackground (so we save time to create the thread)

Shawn has more precise numbers on the regressions
Linux shows no Tp regression (http://tinyurl.com/3umb8r)

Max OS X
10.4 shows a ~3% Tp regression(http://tinyurl.com/3vnwmm)
10.5's two machines are showing different values for the regression, but they do show a regression (http://tinyurl.com/5xdpm4)

Windows
XP looks like there might be a regression, but I'm not really sure either (http://tinyurl.com/47vwqy)
Vista doesn't seem to show a regression when the code was actually checked in, but seems to show one when we backed out?  weird... (http://tinyurl.com/4pg2rr)
Depends on: 459299
Depends on: 459315
With bug 459299 and bug 459315 applied and running local talos, I see no change. :(
Of course, it should be noted that I don't really see the regression locally either (it might be there, it might be noise)
Attached file profile
Here are the bits of the profile that are important for this.
While I don't see this behavior locally, it's quite possible tinderbox was hitting bug 454878.

Not seeing a bug for upgrading trunk to NSPR 4.7.2 yet, but I think we'll need it.
Depends on: 454878
Not sure if it's possible, but making mDBIsPageVisited would help us out too.
With updated patches in bug 459299 and bug 459315 and actually applying bug 456029 when profiling, I see very very little showing up from places now.
Try server (not that I trust it) seems to indicate that I've gotten us back to a sane point:
http://graphs-stage.mozilla.org/graph.html#show=184035&sel=1223669285,1223678303
latest tryserver appear showing still a little tp increase on OSX, could be noise though, linux appear sane, numbers on windows did not show up
New numbers:

Linux http://tinyurl.com/6efnbg (Tp win of 1% it looks like)
OS X 10.4 http://tinyurl.com/566etp (maybe very slight regression?)
OS X 10.5 http://tinyurl.com/55lzco (no change)
Windows XP http://tinyurl.com/5bkgr6 (no change)
Windows Vista http://tinyurl.com/6mlv8t (noisy - maybe a win?)
New numbers:

Linux http://tinyurl.com/6s8c8v
Two boxes show a 4% Tp win (20 ms)?!  One box seems to show no change though (two show a change).

OS X 10.4 http://tinyurl.com/5nugmt
no regression

OS X 10.5 http://tinyurl.com/5nugmt
no regression

Windows XP http://tinyurl.com/5sz7pa
no regression - maybe a win?

Windows Vista http://tinyurl.com/6zcd39
no regression - numbers are noisy
per comment 11, this is fixed
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b2
verified per the graph server
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.