Uninstall dialog is shown on restart after updating to current nightly

VERIFIED FIXED

Status

()

Toolkit
Application Update
--
major
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: Diego, Assigned: rstrong)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Uninstall dialog is shown on restart after updating to current nightly.

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081012 Minefield/3.1b2pre

see http://forums.mozillazine.org/viewtopic.php?f=23&t=898635&st=0&sk=t&sd=a&start=15

Comment 1

10 years ago
FWIW-Using the Minefield 20081011 nightly from its zip file-- that is extracting it to a folder and running it--then updating to the 20081012 nightly via "Help > Check for Updates..." the uninstall wizard dialog does not come up. However, if using the installer .exe file for the 20081011 nightly and the update process, the uninstall wizard dialog does come up.

STR:
1. Install the 20081011 nightly using the installer .exe file.
2. Start the browser.
3. Update via the "Help > Check for Updates..." process.
4. Restart the browser when prompted.

After the installation progress window closes the uninstall wizard dialog will open. The browser opens as expected and otherwise does not appear to be affected.

So far, happens all the time.

The uninstall wizard dialog should not open.

P.S. Also, I have read in the cited thread that Shredder is apparently also seeing this problem.

Updated

10 years ago
Version: unspecified → Trunk

Updated

10 years ago
Keywords: regression

Comment 2

10 years ago
Confirmed Windows Vista Home Premium.

Updated

10 years ago
Flags: blocking1.8.1.18?
Updating from the 10/10/2008 nightly does not have the issue, updating from the 10/11/2008 build does. 

Too bad we don't have a larger hourly archive. 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081012 Minefield/3.1b2pre Firefox/3.0 ID:20081012033432
Possibly caused by https://bugzilla.mozilla.org/show_bug.cgi?id=453733 ??
Severity: normal → major
Flags: blocking1.8.1.18? → blocking-firefox3.1?
OS: Windows XP → All
Component: Installer → Application Update
Flags: blocking-firefox3.1?
Product: Firefox → Toolkit
QA Contact: installer → software.update
Target Milestone: --- → mozilla1.9.1b2
Flags: blocking1.9.1?
(In reply to comment #4)
Most likely
Assignee: nobody → robert.bugzilla
Blocks: 453733
Status: NEW → ASSIGNED
Fixed by the partial backout of bug 453733. I will be re-adding a fixed version of the change I backed out to the cleanup work I am doing on the restart code.
Flags: blocking1.9.1?
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
The cleanup of the restart code will happen in bug 459615

Comment 8

10 years ago
The uninstall wizard is still shown after updating to the new nightly in Thunderbird 3.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081013 Shredder/3.0b1pre ID:20081013031030
Same with Minefield, Wizard still appeared.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081013 Minefield/3.1b2pre Firefox/3.0 ID:20081013033718
(In reply to comment #8 & 9)

Better reopen the bug then.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla1.9.1b2 → ---
Duplicate of this bug: 459661
(Reporter)

Comment 12

10 years ago
If I've understood correctly the bug is caused by the uninstalled version, not by the newly installed one.
So you'll see tomorrow if it's really fixed in today nightly.
You could test that by taking any hourly build after about Sun Oct 12 19:00 2008 PDT, and updating to the Oct 13th nightly.
Just tested with an hourly using changeset:
http://hg.mozilla.org/mozilla-central/rev/d7bd49d81084  
Oct 12, 2008  20:09 hrs PDT build

Did not see the 'Uninstall Wiz' on using: Tools->Check for Update

So this is indeed fixed it seems, going from nightly-to-nightly will be next, and final test this is fixed.
Changes to the updater require it to be updated before any fixes can be seen due to bug 366846. I verified this with both a custom build and the nightly using a custom update xml that this is fixed so reclosing.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 459723
Flags: blocking1.9.1?
Verified with nightly build:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081014 Minefield/3.1b2pre Firefox/3.0 ID:20081014032121
Status: RESOLVED → VERIFIED
Flags: blocking1.9.1?
You need to log in before you can comment on or make changes to this bug.