Last Comment Bug 459850 - Blocklist the DAEMON Tools Toolbar version < 1.0.0.5
: Blocklist the DAEMON Tools Toolbar version < 1.0.0.5
Status: VERIFIED FIXED
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: 3.2
: x86 Windows XP
: -- minor (vote)
: 5.0.1
Assigned To: Michael Morgan [:morgamic]
:
Mentors:
: 457898 (view as bug list)
Depends on: 464254
Blocks: 453927 457898
  Show dependency treegraph
 
Reported: 2008-10-14 09:03 PDT by Samuel Sidler (old account; do not CC)
Modified: 2016-03-07 15:30 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Post-fix screenshot; notification that the add-on will be disabled on restart (355.66 KB, image/png)
2009-01-28 10:52 PST, Stephen Donner [:stephend]
no flags Details
Post-fix screenshot #2; add-on successfully disabled (348.30 KB, image/png)
2009-01-28 10:53 PST, Stephen Donner [:stephend]
no flags Details
Bug 459850 - Blocklist the DAEMON Tools Toolbar version < 1.0.0.5 (deleted)
2009-05-03 12:32 PDT, Rowdy
no flags Details

Description Samuel Sidler (old account; do not CC) 2008-10-14 09:03:22 PDT
Two of our top crash reports (#1 and #4) tracked in bug 453927 and bug 457898 seem to be caused by the DAEMON Tools Toolbar. From what we can tell, this happens with DTToolbarFF.dll version 1.0.0.1.

The developers recently released DAEMON Tools Toolbar version 1.0.0.5 which includes changes to the DLL and extension which are supposed to fix the crashes. (The version number of the DLL was also upped to 1.0.0.5.).

I have an email from the developers that says we can blocklist all prior versions of the DLL/extension. I'm more than happy to forward that to whomever is needed.

It doesn't appear they have a bugzilla account, so I have no one to CC.
Comment 1 Rey Bango 2008-10-14 17:50:44 PDT
Ok. Thx Sam.
Comment 2 Samuel Sidler (old account; do not CC) 2008-10-23 13:12:14 PDT
Any update here? What more do we need to make this happen?
Comment 3 Rey Bango 2008-10-23 13:53:08 PDT
Asa suggested contacting beltzner and/or dveditz.
Comment 4 Mike Beltzner [:beltzner, not reading bugmail] 2008-10-23 14:23:03 PDT
Looks like we've got approval from the add-on developer themselves, so I'm fine to block it if it's a known startup crasher. There's an update available so that the users will get the option to move to the new, secure version, yes?
Comment 5 Samuel Sidler (old account; do not CC) 2008-10-23 16:17:13 PDT
(In reply to comment #4)
> to block it if it's a known startup crasher. There's an update available so
> that the users will get the option to move to the new, secure version, yes?

They should have the option now, this will just force it on them a bit more if they want the toolbar. Given the amount of crashes have hardly come down, I'm okay with forcing it. (Also having permission makes me more okay.)
Comment 6 Daniel Veditz [:dveditz] 2008-10-29 21:24:39 PDT
Why isn't this done already? Assigning to morgamic to find an appropriate victim on his team.
Comment 7 Daniel Veditz [:dveditz] 2008-10-29 23:52:06 PDT
Since it's not on AMO you'll need the ID for blocking. In the latest 1.0.0.5 version it's
  <em:id>DTToolbar@toolbarnet.com</em:id>
Comment 8 Samuel Sidler (old account; do not CC) 2008-11-04 14:33:32 PST
Mike, where are we here?
Comment 9 Michael Morgan [:morgamic] 2008-11-09 23:42:18 PST
Not sure if this really fits the criteria for blocklisting, but if you guys are in favor of this we can push this out on Tuesday with the rest of the AMO updates.
Comment 10 Michael Morgan [:morgamic] 2008-11-09 23:43:15 PST
Check that -- AMO update is Thursday but we can push this Tuesday night.
Comment 11 Michael Morgan [:morgamic] 2008-11-11 09:38:37 PST
Staged www changes: https://www.authstage.mozilla.com/en-US/blocklist/
Bug to update prevew: bug 464254

If that looks good we'll push it out tonight.  ss or stephend -- could you verify this?
Comment 12 Stephen Donner [:stephend] 2008-11-12 15:57:14 PST
Anyone know where I can find the old version (since it's not on http://www.disk-tools.com/download/dttoolbar, and changing the filename doesn't work since it's a hash), or have a contact that can hook me up?
Comment 13 Rey Bango 2008-11-13 06:12:05 PST
Two emails available:

bizdev1@toolbarnet.com
techsupport@toolbarnet.com
Comment 14 Stephen Donner [:stephend] 2008-11-14 00:31:23 PST
(In reply to comment #13)
> Two emails available:
> 
> bizdev1@toolbarnet.com
> techsupport@toolbarnet.com

Thanks, Rey; I emailed bizdev1@toolbarnet.com about obtaining access to an earlier version with which to test.
Comment 15 Stephen Donner [:stephend] 2008-11-17 18:08:15 PST
Reopening; neither Tony nor I could get blocklisting of version 1.0.0.0 to work against Firefox 3.0.4, using both local and remote blocklisting methods.
Comment 16 Michael Morgan [:morgamic] 2008-11-17 18:19:23 PST
Ok, we'll have to figure out why and push it when we do.
Comment 17 Tony Chung [:tchung] 2008-11-19 20:28:03 PST
we should remove the blocklist entry from http://www.mozilla.com/en-US/blocklist/ until this bug really is fixed and verified.
Comment 18 Michael Morgan [:morgamic] 2008-12-08 19:57:52 PST
I'll remove the entry.  If this is still a priority we should spend some time figuring out why it's not being disabled as expected.  Either way, moving to 4.0.5 since this won't get done tonight.

Not blocking 4.0.4, this change can go in anytime so the rest of the release should be able to get pushed.
Comment 19 Michael Morgan [:morgamic] 2008-12-08 22:45:31 PST
Entry was removed a few minutes ago.
Comment 20 Michael Morgan [:morgamic] 2008-12-08 23:01:53 PST
False alarm, entry is in staging but I had some issues pushing it to prod in kubla.  Working on that.
Comment 21 Michael Morgan [:morgamic] 2008-12-08 23:03:56 PST
So I don't have to rewrite it, the line is:
<li>Daemon Tools Toolbar, versions older than 1.0.0.5, for all applications (<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=459850">see bug 459850</a>)</li>
Comment 22 Michael Morgan [:morgamic] 2008-12-08 23:04:20 PST
Wil pushed this through, I probably didn't have permissions.
Comment 23 Fred Wenzel [:wenzel] 2008-12-16 11:42:23 PST
Is this fixed?
Comment 24 Stephen Donner [:stephend] 2008-12-16 11:43:32 PST
(In reply to comment #23)
> Is this fixed?

No, we just removed the entry from the blocklist page.
Comment 25 Michael Morgan [:morgamic] 2009-01-07 09:31:22 PST
Tony or Stephen - not sure what to do with this.  Have you looked at why it can't be blocklisted?
Comment 26 Stephen Donner [:stephend] 2009-01-07 16:43:25 PST
(In reply to comment #25)
> Tony or Stephen - not sure what to do with this.  Have you looked at why it
> can't be blocklisted?

I have this set up in a VM, with extensions.blocklist.url set to https://preview.addons.mozilla.org/blocklist/2/%APP_ID%/%APP_VERSION%/%PRODUCT%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/, and I followed the steps listed in https://wiki.mozilla.org/Extension_Blocklisting:Testing.

Last time I tested this alongside Tony, we even tried the local blocklist.XML option and couldn't get it to blocklist either.

Let me know when you have to troubleshoot with me; not sure what kind of further info you need.
Comment 27 Michael Morgan [:morgamic] 2009-01-23 11:44:00 PST
id was bad.  id should be:
support@daemon-tools.cc
Comment 28 Michael Morgan [:morgamic] 2009-01-23 14:48:53 PST
insert into blitems values (null, 'support@daemon-tools.cc', ' ', '1.0.0.5', 
null, now(), now());
Comment 29 Michael Morgan [:morgamic] 2009-01-28 10:27:57 PST
Stephen - added this to preview, could you see if it works now?
Comment 30 Stephen Donner [:stephend] 2009-01-28 10:52:20 PST
Created attachment 359317 [details]
Post-fix screenshot; notification that the add-on will be disabled on restart
Comment 31 Stephen Donner [:stephend] 2009-01-28 10:53:01 PST
Created attachment 359318 [details]
Post-fix screenshot #2; add-on successfully disabled
Comment 32 Stephen Donner [:stephend] 2009-01-28 10:53:56 PST
Verified FIXED per comment 30 and comment 31; I can feel my blood pressure subsiding already.

<3.
Comment 33 Dave Townsend [:mossop] 2009-04-15 03:04:17 PDT
It's perhaps a technicality but we probably should use the empty string ("") to represent no minVersion for the block version range. This will literally make the blocklist service ignore the minVersion and block every version below the maxVersion. Technically " " is a valid version.
Comment 34 Rowdy 2009-05-03 12:32:19 PDT
Created attachment 375534 [details]
 Bug 459850 -  Blocklist the DAEMON Tools Toolbar version < 1.0.0.5
Comment 35 Dave Miller [:justdave] (justdave@bugzilla.org) 2009-05-03 14:40:59 PDT
The content of attachment 375534 [details] has been deleted by
    Dave Miller [:justdave] <justdave@mozilla.com>
who provided the following reason:

Windows EXE file, unrelated to bug

The token used to delete this attachment was generated at 2009-05-03 14:40:54 PDT.
Comment 36 chris hofmann 2009-08-21 19:26:08 PDT
we still seem to get about 500 crashes a day from the DTToolbar.  wonder if those are just block list overrides?

503 total crashes for DTToolbarFF.dll on 20090819-crashdata.csv
307 start up crashes inside 3 minutes

DTToolbarFF.dll signature breakdown
signature distribution
       9
signature list
 387 DTToolbarFF.dll@0x4bc19
 106 DTToolbarFF.dll@0x6087e
   3 DTToolbarFF.dll@0x3d52d
   2 DTToolbarFF.dll@0x9165
   1 DTToolbarFF.dll@0x8eced
   1 DTToolbarFF.dll@0x5125a
   1 DTToolbarFF.dll@0x4fcd4
   1 DTToolbarFF.dll@0x3ff06
   1 DTToolbarFF.dll@0x39b70

os breakdown
 132 DTToolbarFF.dll@0x4bc19 Windows NT 5.1.2600 Service Pack 3
  79 DTToolbarFF.dll@0x4bc19 Windows NT 5.1.2600 Service Pack 2
  67 DTToolbarFF.dll@0x4bc19 Windows NT 6.0.6001 Service Pack 1
  31 DTToolbarFF.dll@0x6087e Windows NT 6.0.6001 Service Pack 1
  27 DTToolbarFF.dll@0x6087e Windows NT 5.1.2600 Service Pack 3
  24 DTToolbarFF.dll@0x4bc19 Windows NT 5.1.2600 Szervizcsomag 2
  19 DTToolbarFF.dll@0x6087e Windows NT 5.1.2600 Service Pack 2
  19 DTToolbarFF.dll@0x4bc19 Windows NT 5.1.2600 Dodatek Service Pack 2
  18 DTToolbarFF.dll@0x4bc19 Windows NT 6.0.6002 Service Pack 2
  13 DTToolbarFF.dll@0x6087e Windows NT 5.1.2600 Dodatek Service Pack 2
  13 DTToolbarFF.dll@0x4bc19 Windows NT 6.0.6000
   8 DTToolbarFF.dll@0x4bc19 Windows NT 6.1.7100

distribution of versions where the crash was found on 20090819-crashdata.csv
 227 Firefox 3.0.13
 202 Firefox 3.5.2
  24 Firefox 3.0.8
  17 Firefox 3.0.10
  14 Firefox 3.5
   8 Firefox 3.0.11
   3 Firefox 3.5.1
   3 Firefox 3.0.1
   2 Firefox 3.0.5
   2 Firefox 3.0.12
   1 Firefox 3.0.6

kinds of sites found with this signature:
       9

types of sites
 251 no URL
 113 http:
  76 about:blank
  34 \N
  23 about:sessionrestore
   2 https:
   2 file:
   1 wyciwyg:
   1 chrome:
Comment 37 Samuel Sidler (old account; do not CC) 2009-08-21 19:43:23 PDT
The version of DTToolbarFF.dll that is crashing is important here. If it's a new version, we might need to contact them and do more blocklisting.
Comment 38 chris hofmann 2009-08-21 20:10:16 PDT
here is a cut down list of unique signatures and version numbers.  if we checked these reports for dttoolbar version numbers we could be pretty confident we know whats going on with all the ddtoolbar crashes.

DTToolbarFF.dll@0x39b70 Firefox 3.0.13 http://crash-stats.mozilla.com/report/index/9a360386-6497-484e-94d5-ec4c02090818
DTToolbarFF.dll@0x3d52d Firefox 3.0.13 http://crash-stats.mozilla.com/report/index/5032a855-3312-4567-a035-47d8f2090818
DTToolbarFF.dll@0x3ff06 Firefox 3.5.2 http://crash-stats.mozilla.com/report/index/a39e030d-d76d-4067-819d-fbf042090818
DTToolbarFF.dll@0x4bc19 Firefox 3.0.1 http://crash-stats.mozilla.com/report/index/517fe23b-9612-442f-be6f-8af1a2090818

lots of these
DTToolbarFF.dll@0x4bc19 Firefox 3.0.10 http://crash-stats.mozilla.com/report/index/29d22ba5-5577-491c-a0b8-0e18a2090818
DTToolbarFF.dll@0x4bc19 Firefox 3.5.2 http://crash-stats.mozilla.com/report/index/0342a23f-caf3-4777-922c-7c7fb2090818

DTToolbarFF.dll@0x4bc19 Firefox 3.5 http://crash-stats.mozilla.com/report/index/0df6822b-15b6-4367-9e14-539002090818

DTToolbarFF.dll@0x4bc19 Firefox 3.0.6 http://crash-stats.mozilla.com/report/index/056c4573-9386-4df6-9d4d-4bfc62090818

DTToolbarFF.dll@0x4bc19 Firefox 3.0.8 http://crash-stats.mozilla.com/report/index/0d5a3cf5-75dd-4dc1-b8cc-d33ed2090818

DTToolbarFF.dll@0x4bc19 Firefox 3.5.1 http://crash-stats.mozilla.com/report/index/dd32e5e2-4452-45d3-96bc-db6dc2090818

DTToolbarFF.dll@0x6087e Firefox 3.0.10 http://crash-stats.mozilla.com/report/index/02305ebd-77f2-45cb-b422-3331a2090818
DTToolbarFF.dll@0x6087e Firefox 3.0.11 http://crash-stats.mozilla.com/report/index/1814c9e8-719a-4dc1-ba22-1851a2090818
DTToolbarFF.dll@0x6087e Firefox 3.0.12 http://crash-stats.mozilla.com/report/index/7428f100-faaf-40c1-b624-473ed2090818
DTToolbarFF.dll@0x6087e Firefox 3.0.13 http://crash-stats.mozilla.com/report/index/12229693-266e-490a-a3dd-bbc2b2090818

DTToolbarFF.dll@0x6087e Firefox 3.0.5 http://crash-stats.mozilla.com/report/index/a1a8447f-0f9a-40f8-9931-f5c5e2090818
DTToolbarFF.dll@0x6087e Firefox 3.0.8 http://crash-stats.mozilla.com/report/index/1ac58c26-4444-464d-8061-eba652090818
DTToolbarFF.dll@0x6087e Firefox 3.5.1 http://crash-stats.mozilla.com/report/index/190130cb-a613-4f00-9e4f-3a78b2090818

lots of these too
DTToolbarFF.dll@0x6087e Firefox 3.5.2 http://crash-stats.mozilla.com/report/index/85340e3f-db25-49b9-b5b8-25d402090818

DTToolbarFF.dll@0x8eced Firefox 3.0.5 http://crash-stats.mozilla.com/report/index/c510b3c1-ed86-4e3c-a32a-269c42090818
DTToolbarFF.dll@0x9165 Firefox 3.0.10 http://crash-stats.mozilla.com/report/index/12306fe3-53b9-40e7-9ac5-40a5a2090818
DTToolbarFF.dll@0x9165 Firefox 3.0.10 http://crash-stats.mozilla.com/report/index/472cc249-65a3-4742-894e-806c62090818
Comment 39 chris hofmann 2009-08-21 20:15:01 PDT
these are the heavy hitter signature/ff version combo's

DTToolbarFF.dll@0x4bc19 Firefox 3.0.10  DTToolbarFF.dll  	1.0.8.552
DTToolbarFF.dll@0x4bc19 Firefox 3.5.2   DTToolbarFF.dll  	1.0.8.552
DTToolbarFF.dll@0x6087e Firefox 3.5.2   DTToolbarFF.dll  	1.0.7.88
Comment 40 chris hofmann 2009-08-21 20:18:28 PDT
all of these at the top of the list are 1.0.8.552

DTToolbarFF.dll@0x39b70 Firefox 3.0.13
http://crash-stats.mozilla.com/report/index/9a360386-6497-484e-94d5-ec4c02090818
DTToolbarFF.dll@0x3d52d Firefox 3.0.13
http://crash-stats.mozilla.com/report/index/5032a855-3312-4567-a035-47d8f2090818
DTToolbarFF.dll@0x3ff06 Firefox 3.5.2
http://crash-stats.mozilla.com/report/index/a39e030d-d76d-4067-819d-fbf042090818
DTToolbarFF.dll@0x4bc19 Firefox 3.0.1
http://crash-stats.mozilla.com/report/index/517fe23b-9612-442f-be6f-8af1a2090818
Comment 41 chris hofmann 2009-08-21 20:29:29 PDT
I'd say most of these are the current version offered  1.0.8 http://www.daemon-toolbar.com/home or the previous version.
Comment 42 Samuel Sidler (old account; do not CC) 2009-08-21 20:34:31 PDT
chofmann: Please file a new bug for that issue. It's not likely to be seen in this bug. I can try and contact the extension authors again.
Comment 43 chris hofmann 2009-08-21 20:53:39 PDT
https://bugzilla.mozilla.org/show_bug.cgi?id=512040 for the 1.0.8 crashes
Comment 44 Jesse Ruderman on Windows 2009-09-19 16:16:15 PDT
*** Bug 457898 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.