If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Modifying an event remove its category

VERIFIED FIXED in 1.0b1

Status

Calendar
Provider: WCAP
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: Pierre-Luc Boucheron, Assigned: dbo)

Tracking

unspecified
1.0b1

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Build Identifier: Lightning 0.9 + Provider WCAP

Any modification of an event removed its category: this can be by editing it or simply by moving it across the calendar

This problem is not present when using the Local Storage ...

Reproducible: Always

Steps to Reproduce:
1. create a new event with a given category
2. modify it
3. the category is removed


Expected Results:  
Defined category still present

Comment 1

9 years ago
I checked this issue with Thunderbird2.0.0.17/lightning0.9 and Thunderbird3.0pre/lightning1.0pre. In both cases it works form me with default and self created categories without any problems -> WFM

Maybe this is a server issue? I checked this on a Sun Java System Calendar Express 6.3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
This might actually be a core bug, it was also reported for gdata, see bug 461995
(Reporter)

Comment 3

9 years ago
(In reply to comment #1)
> I checked this issue with Thunderbird2.0.0.17/lightning0.9 and
> Thunderbird3.0pre/lightning1.0pre. In both cases it works form me with default
> and self created categories without any problems -> WFM
> 
> Maybe this is a server issue? I checked this on a Sun Java System Calendar
> Express 6.3

Hello Andreas,

Thanks for looking at my problem.

I'm very surprised that every thing is ok for you.

Perhaps sorry for the question but can you confirm that:

1) you have test this connected to a WCAP calendar

2) you have tried:

in the week view, point an event with a category assigned and "drag and drop" it to another day and hour.

In my case after this, the category has been removed.

Can you confirm that in the same situation you are not affected by this problem ???

I'm quite sure this is a problem with Lightning because if I create an event with UWC and move it with Convergence the category is not removed.

Thanks for your answer,

PL

Comment 4

9 years ago
Hi Pierre-Luc,

thanks for your STR's, now it's possible for me to reproduce this bug. This is an known issue, see bug 393090.

Updated

9 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 393090

Comment 6

9 years ago
After some additional testing, this issue is not duplicate, sorry. It is only possible for me to reproduce this issue with WCAP calendars and with categories. Other providers (e.g. caldav) or local storage calendar works as expected.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

9 years ago
Created attachment 347754 [details] [diff] [review]
fix
Assignee: nobody → daniel.boelzle
Attachment #347754 - Flags: review?(philipp)
Comment on attachment 347754 [details] [diff] [review]
fix

r=philipp
Attachment #347754 - Flags: review?(philipp) → review+
(Assignee)

Comment 9

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/626f5b2d5b1d>

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0

Comment 10

9 years ago
Checked in sunbird and lightning build 20081130 -> VERIFIED.
Status: RESOLVED → VERIFIED

Comment 11

9 years ago
This is undoubtedly a new bug thread but in Lightning I cannot see the full category title in the drop down list.   Several titles are wider than the list box permits.   And there is no mouseover title.   Can we fix this?   Can't accurately assign a category unless I can see the full title of the categor
(In reply to comment #11)
Curtis, please file a separate bug report for your issue.

Comment 13

9 years ago
How do I do that?   Where?  Don't understand the process.  I also want to file one about the back-up and synchronizing headaches which Thunderbird's opening virtually every last file every time it's opened can cause. Takes eons of unnecessary time to back-up or synchronize Thunderbird.  I'd like to point that out somewhere someone might take note.  But I just don't know how to start a new bug report.
Curtis, go to https://bugzilla.mozilla.org/. You find a link 'New' in the top left corner of the page. The product, you have to choose, is 'Calendar'. You can also write me an email if you need further instructions.

Updated

9 years ago
Duplicate of this bug: 461995

Comment 16

8 years ago
Hello,

I have modified the file calWcapCalendarItems.js according to the diff file.

When I create a new event and choose a category, the category is concatened with the title to create a new title when I save the event.

Comment 17

7 years ago
I'm still experiencing this behavior in the current Lightning version, so I fear the bug may not be fully fixed.

Modifying an event stored externally in Google Calendar removes both category and reminder. It is not possible to recreate them. The only workaround is to create a new event instead of editing.

The problem does not show with locally stored calendars and also not with ics calendars stored externally at mediacenter.gmx.net. I have not had an option to check with other external storage.

Software used:
Lightning 1.0b2
Provider for Google Calendar 0.7.1
TB 3.1.5
I have 2 machines, one with Win XP and the other with Win 7, both exhibiting the problem.

It seems that the same problem is described here: 

http://www.sunbird-kalender.de/forum/viewtopic.php?f=5&t=2856

http://groups.google.com/group/provider-for-google-calendar/browse_thread/thread/e1adac994dfd08ee

 or

https://wiki.mozilla.org/Calendar:GDATA_Provider#I_have_set_a_category.2C_but_when_changing_the_event_it_vanishes
(In reply to comment #17)
werbegrab@gmx.de, please file a new bug on your issue. This one is rather old and does not involve the Provider for Google Calendar.
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
You need to log in before you can comment on or make changes to this bug.