Dragging text into text-input-box doesn't copy the selection. A new url of www.(selection).com is opened.

VERIFIED DUPLICATE of bug 459323

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 459323
9 years ago
9 years ago

People

(Reporter: zengbl, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1

In Firefox 3.03, it copies the selection, and not refreshes the current page.
In Firefox 3.1b1, it changes the current address to a new url.

Reproducible: Always

Steps to Reproduce:
1. Get a page with a text-input-box, e.g. https://bugzilla.mozilla.org/
2. Select some words, e.g. "release"
3. Drag and drop the selection into the text-input-box (left side to the "Find" button in this case)
Actual Results:  
The Firefox opens a new URL in the current window/tab. In this case, the new URL is www.release.com.

Expected Results:  
The selected text should be copied to the text-input-box.

I search bugs using keywords "drag copy" and find Bug 434210 (https://bugzilla.mozilla.org/show_bug.cgi?id=434210). It is similar but not the same situation.
(Reporter)

Updated

9 years ago
Keywords: regression
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 459323

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.