Closed Bug 461744 Opened 12 years ago Closed 11 years ago

Missing icon on minimonth dropdown button in miniday in today pane

Categories

(Calendar :: Calendar Views, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: andreas.treumann, Assigned: bv1578)

References

Details

(Keywords: regression)

Attachments

(5 files, 5 obsolete files)

Attached image miniday without month icon β€”
The month icon (little arrow on the right side) in the miniday control is gone. This is an 'windows only' bug. Same on Linux or MacOs is okay.
Though without button, if you click near mini-day's right border, the date picker mini-month pops up, moreover, bug 416161 doesn't exist any more: the calendar window doesn't freeze if you select a different year or month with drop-down buttons.
Lightning 1.0pre build 20081026055133.
The button uses class "toolbarbutton-menubutton-dropmarker" from toolbarbutton.css.

On MOZILLA_1_8_BRANCH this class defines an icon:
http://mxr.mozilla.org/mozilla1.8/source/toolkit/themes/winstripe/global/toolbarbutton.css#152

On Trunk it does not. Instead it's set to display nothing:
http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/themes/winstripe/global/toolbarbutton.css#165

Changes were done with Bug 348614. We should check this bug on how to use the new dropmarker button.
Summary: Missing month icon in miniday → Missing icon on minimonth dropdown button in miniday in today pane
Attached patch incomplete patch (obsolete) β€” β€” Splinter Review
This patch restores the look and feel of the minimonth dropdown button using winstripe theme as in Lightning 0.9. 

Unfortunately it breaks the display of the dropdown button in the search field in the mail toolbar. Removing the button.css include fixes this. But in that case the minimonth dropdown button has a different look and feel, similar to the one in the dropdown boxes.
Flags: blocking-calendar1.0?
Stefan, what should we do with this bug? I don't have a windows box to test this on, it looks fine for me on linux.
Duplicate of this bug: 481492
Attached patch proposal patch (obsolete) β€” β€” Splinter Review
I've tried to do the same patch proposed by Stefan Sitter but, since including the css file with the required class for the dropmarker breaks elements in Thunderbird's UI (in particular including toolbarbutton.css breaks close button of tabs), I've copied the css class from toolbarbutton.css file, inside today-pane.css file without including the file.
It seems working on Windows but I don't know if it breaks look of some elements on Linux and on mac.
Can anyone try it?
Attachment #380284 - Flags: review?(philipp)
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attached patch Fix - v3 (obsolete) β€” β€” Splinter Review
How does this work for you (especially on windows?)

For me this makes the button look much more like a button, it automatically gets a new hover state. I like this, not sure how others think about it.
Attachment #346983 - Attachment is obsolete: true
Attachment #380284 - Attachment is obsolete: true
Attachment #383420 - Flags: review?(bv1578)
Attachment #380284 - Flags: review?(philipp)
Attached patch Fix - v4 (obsolete) β€” β€” Splinter Review
Forgot to update the js.
Attachment #383420 - Attachment is obsolete: true
Attachment #383424 - Flags: review?(bv1578)
Attachment #383420 - Flags: review?(bv1578)
Attached image Screenshots Fix -v4 on WinXP β€”
(In reply to comment #7)
> 
> How does this work for you (especially on windows?)
> 

With patch Fix - v4 on Windodows XP, button look is the same as you get with the other patch for normal state and hover state (i.e. like it is on Lightning\Sunbird 0.9), but the little arrow is misplaced 2 pixels to the right (see screenshot).
Attached patch Fix - v5 (obsolete) β€” β€” Splinter Review
How about this one? I'd like to see this on a mac too, usually the dropmarker isn't shown on mac, so I wonder that this hasn't caused problems yet...
Attachment #383424 - Attachment is obsolete: true
Attachment #383659 - Flags: review?(bv1578)
Attachment #383424 - Flags: review?(bv1578)
(In reply to comment #10)
> Created an attachment (id=383659) [details]
> Fix - v5
> 
> How about this one?...

On Windows XP, result is the same of the previous patch Fix - v4 (see comment #9) but the arrow is misplaced only one pixel to the right.
Just curiosity, how does it look on Linux?
Attached image Screenshot - v5 Linux β€”
This is how it looks on linux. Maybe you can use the dom inspector to find out how to get rid of that pixel?
I tried to move the icon 1px to the left but it seems to me there is a strange behavior of the interface.
Below there are three way to modify your patch to obtain the right positioning of the icon on Win XP, but I guess that every case breaks the look of the button on Linux.
If someone want to try something different ...

Every modify refers to todaypane.css file of "Fix - v5" patch

 =========== 1 ===========
@@ -69,13 +69,14 @@
   font-weight: bold;
   font-size: 18px;
 }
 
 #miniday-dropdown-button {
   margin: 2px;
-  max-width: 15px;
+  -moz-padding-end: 6px;
+  max-width: 18px;
   -moz-user-focus: normal;
 }
 
 .monthlabel {
   -moz-margin-end: 0px;
 }
 
 
 =========== 2 ===========
 @@ -140,15 +140,18 @@
 
 #next-day-button[disabled],
 #previous-day-button[disabled][chromedir="rtl"] {
   -moz-image-region: rect(26px 21px 39px 16px);
 }
 
-#miniday-dropdown-button > .toolbarbutton-icon,
   .miniday-nav-buttons > .toolbarbutton-icon {
   margin: 1px;
+}
+
+#miniday-dropdown-button > .toolbarbutton-icon {
+    -moz-margin-end: -1px;
 }
 
 #miniday-dropdown-button > .toolbarbutton-text,
   .miniday-nav-buttons > .toolbarbutton-text  {
   display: none;
 }
 
 
 =========== 3 ===========
 @@ -140,15 +140,18 @@
 
 #next-day-button[disabled],
 #previous-day-button[disabled][chromedir="rtl"] {
   -moz-image-region: rect(26px 21px 39px 16px);
 }
 
-#miniday-dropdown-button > .toolbarbutton-icon,
   .miniday-nav-buttons > .toolbarbutton-icon {
   margin: 1px;
+}
+
+#miniday-dropdown-button > .toolbarbutton-icon {
+    -moz-margin-start: -6px;
 }
 
 #miniday-dropdown-button > .toolbarbutton-text,
   .miniday-nav-buttons > .toolbarbutton-text  {
   display: none;
 }
Duplicate of this bug: 514964
Attached image Screenshot - v5 Mac β€”
Just for reference, this is mac. It may be the box I m on, but there is no hover style, neither for the < o > nor for the dropdown. But otherwise it looks fine, other than it is a bit small.
Attached patch Fix - v6 β€” β€” Splinter Review
Are you sure these changes apply to the patch? It seems more they apply to the current tree?

I've tested

#miniday-dropdown-button > .toolbarbutton-menu-dropmarker {
   -moz-padding-start: 0;
}

And this seems to work for mac, windows and linux. Please take another look, maybe I did something wrong though.
Attachment #383659 - Attachment is obsolete: true
Attachment #399188 - Flags: review?(bv1578)
Attachment #383659 - Flags: review?(bv1578)
(In reply to comment #16)
> Created an attachment (id=399188) [details]
> Fix - v6
> 
> Are you sure these changes apply to the patch? It seems more they apply to the
> current tree?
>

I've just re-tried and yes, I add those changes to your patch 'Fix-v5' and the drop marker icon goes 1 pixel to the left, though they look strange.

> I've tested
> 
> #miniday-dropdown-button > .toolbarbutton-menu-dropmarker {
>    -moz-padding-start: 0;
> }
> 
> And this seems to work for mac, windows and linux. Please take another look,
> maybe I did something wrong though.

that is much better than my changes ;-), it works for me too on Win XP.
> > And this seems to work for mac, windows and linux. Please take another look,
> > maybe I did something wrong though.
> 
> that is much better than my changes ;-), it works for me too on Win XP.

Can that be considered as r+ ? Please mark the patch as appropriate if so.
(In reply to comment #18)
> 
> Can that be considered as r+ ? Please mark the patch as appropriate if so.

Yes it's a r+.
With patch 'Fix - v6' on Win XP, the icon is exactly in the center of the dropdown button.
I apologize Philipp but I don't know how to mark the patch as '+' (I have no authorization to mark or change flags in patches details).
Comment on attachment 399188 [details] [diff] [review]
Fix - v6

Marking r+ on behalf of Decathlon.
Attachment #399188 - Flags: review?(bv1578) → review+
Decathlon, I noticed that you don't have editbugs privileges. I just fixed that :)

Please read https://developer.mozilla.org/en/What_to_do_and_what_not_to_do_in_Bugzilla before trying out your new "powers" for the first time.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/a98db41b5ca7>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Flags: blocking-calendar1.0?
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.