Closed Bug 462109 Opened 11 years ago Closed 11 years ago

Convert eMail to event/task -> Recipient should not added to the attendees list

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: dbo)

References

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- convert an eMail to event/task
 
RESULT:
=======

- the recipient is added to the attendees list, but this makes no sense. If the recipient a mail alias all people gets an eMail with an ics-attechment, but it was only my decision to convert this eMail to an event. In this case the converter is the organizer of this event and not the creator of the eMail.

EXPECTED RESULT:
================

- converting an eMail should not add the recipient to the attendees list.

REPRODUCIBLE:
=============

- always
Flags: wanted-calendar1.0?
Duplicate of this bug: 460750
Attached patch fix - v1Splinter Review
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Attachment #350170 - Flags: review?(Berend.Cornelius)
Depends on: 459641
Flags: wanted-calendar1.0? → wanted-calendar1.0+
Comment on attachment 350170 [details] [diff] [review]
fix - v1

At first I did not understand why no attendees should be added to the list and discussed this over with Daniel but he persuaded me that this is more likely what the people want to get when doing a conversion.
As we are not yet available to set up "published events" maybe it will make sense to keep the function "addAttendees()" for later use but that's up to Daniel.
r=berend
Attachment #350170 - Flags: review?(Berend.Cornelius) → review+
I don't like unused code; we could recycle it from hg once we need it.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/0f85d87451f0>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Version: Trunk → unspecified
Checked in lightning build 20081209 -> VERIFIED.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 464023
No longer depends on: 459641
OK, but is there any way to default it to unchecked? Because if one doesn't pay attention (this has happened to me), then every one receives the invite.
Duplicate of this bug: 531390
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.