Closed Bug 464499 Opened 11 years ago Closed 11 years ago

Vertical scrollbar in Header pane after viewing a message with tag

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0b2

People

(Reporter: Paenglab, Assigned: tuukka.tolvanen)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081112 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081112 Lightning/1.0pre Shredder/3.0b1pre

After viewing a message with tag and then viewing a message without tag a vertical scrollbar appears on the header pane. I can then switch to View Header All and then back to Normal, the scrollbar rests until I restart Shredder. When I view again a message with tags the scrollbar vanishes but is here again on messages without tags.

This is visible since landing of Bug 223132. But this bug is not the problem, as it works correct with all headers. Only when tags are displayed the problem occurs.

Reproducible: Always

Steps to Reproduce:
1. Mesage header in expandedHeaderView, normal mode, no scrollbar visible
2. View a message with tags
3. View a message without tags
Actual Results:  
Scrollbar in the message header appears

Expected Results:  
No scrollbar as before
Blocks: 223132
Keywords: regression
confirmed 20081109 Thunderbird/3.0b1pre on linux, actually I hadn't noticed before that the vertical scrollbar was ever not there :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3+
Duplicate of this bug: 465950
fwiw, asking domi to delete the mail-tagfield#expandedTagsBox fixes the scrolliness; that doesn't happen by deleting any of the other headers. Undoing the delete retains the fixed state -- note that for the visible headers undo results in a blank value side until another message is loaded.
OS: Windows XP → All
Attached image domi screenshot
domi element outline flashing seems to claim a lingering label.tagvalue within the collapsed #expandedtagsBox is occupying space at the bottom left corner of the header pane.
Attached patch patch1Splinter Review
looks like collapsed for the tag header means very narrow and invisible; the phantom tags stack up vertically, so if the last tagful msg you looked at had lots of tags you get a taller blank scrollspace. header values sticking around in collapsed headers seems to be the norm, usually their display just doesn't misbehave. here's a hack to collapse harder in the case of this header. could be put in themes but this seems to be a structural sort of issue so I didn't.
Assignee: nobody → tuukka.tolvanen
Status: NEW → ASSIGNED
Attachment #357585 - Flags: review?
Attachment #357585 - Flags: review? → review?(philringnalda)
Attachment #357585 - Flags: review?(philringnalda) → review+
Comment on attachment 357585 [details] [diff] [review]
patch1

Lovely, thanks for figuring it out! I'll push it, switched to multiple lines so that style-of-the-file is only two different things instead of three, once the tree gets a little less colorful.
http://hg.mozilla.org/comm-central/rev/3b06329fff94
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b2
I've tested with the newest nightly. It works now as expected. Thanks to all.
Status: RESOLVED → VERIFIED
Depends on: 513318
Philor, should this patch be backed out now that core Bug 513318 is fixed?
You need to log in before you can comment on or make changes to this bug.