crash quicksearching in threaded folder [@ nsMsgThreadedDBView::MoveThreadAt]

RESOLVED FIXED in Thunderbird 3.0b1

Status

defect
--
critical
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: myk, Assigned: Bienvenu)

Tracking

({crash})

unspecified
Thunderbird 3.0b1
x86
Linux
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand, crash signature, )

Attachments

(1 attachment, 1 obsolete attachment)

1.06 KB, patch
neil
: review+
Details | Diff | Splinter Review
When I enter a search in the quicksearch field while on an IMAP folder that is in threaded mode, today's Linux Thunderbird nightly crashes every time.  The crash is not folder-specific or related to the search string itself, but it only happens in threaded mode; it doesn't occur when the folder is unthreaded.

Here's a sample crash report:

http://crash-stats.mozilla.com/report/index/a9903bc5-94fe-499c-98d5-4c3c20081113
need to fix this for beta 1 - it's not imap specific, I don't think.
Flags: blocking-thunderbird3+
Summary: crash quicksearching in threaded IMAP folder → crash quicksearching in threaded folder
Target Milestone: --- → Thunderbird 3.0b1
Assignee: nobody → bienvenu
Posted file proposed fix (obsolete) —
quick search's override of AddHdr wasn't setting the resultIndex...I'd love to check this in before the builds are made for the test day...
Attachment #348135 - Flags: superreview?(neil)
Attachment #348135 - Flags: review?(neil)
Whiteboard: fix in hand
Comment on attachment 348135 [details]
proposed fix

nsMsgDBView::AddHdr overrides the result index, is that intentional, or does this belong in the threaded case only?
Signature	nsMsgThreadedDBView::MoveThreadAt(unsigned int)
UUID	a9903bc5-94fe-499c-98d5-4c3c20081113
Frame 	Module 	Signature [Expand] 	Source
0 	thunderbird-bin 	nsMsgThreadedDBView::MoveThreadAt 	nsMsgThreadedDBView.cpp:798
1 	thunderbird-bin 	nsMsgThreadedDBView::OnNewHeader 	nsMsgThreadedDBView.cpp:675
2 	thunderbird-bin 	nsMsgQuickSearchDBView::AddHdr 	nsMsgQuickSearchDBView.cpp:136
3 	thunderbird-bin 	nsMsgQuickSearchDBView::OnSearchHit 	nsMsgQuickSearchDBView.cpp:293
4 	thunderbird-bin 	nsMsgSearchSession::AddSearchHit 	nsMsgSearchSession.cpp:580
5 	thunderbird-bin 	nsMsgSearchOfflineMail::AddResultElement 	nsMsgLocalSearch.cpp:780
6 	thunderbird-bin 	nsMsgSearchOfflineMail::Search 	nsMsgLocalSearch.cpp:732
7 	thunderbird-bin 	nsMsgSearchSession::TimeSliceSerial 	nsMsgSearchSession.cpp:692
8 	thunderbird-bin 	nsMsgSearchSession::StartTimer 	nsMsgSearchSession.cpp:656
9 	thunderbird-bin 	nsMsgSearchSession::BeginSearching 	nsMsgSearchSession.cpp:443
10 	thunderbird-bin 	nsMsgSearchSession::Search 	nsMsgSearchSession.cpp:271
11 	libxpcom_core.so 	libxpcom_core.so@0x652f6 	
12 	thunderbird-bin 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2405
Keywords: crash
Summary: crash quicksearching in threaded folder → crash quicksearching in threaded folder [@ nsMsgThreadedDBView::MoveThreadAt]
it probably belongs in the threaded/grouped case only, but for some reason this crash doesn't happen on Windows, which is just strange. I'm investigating that now.
Posted patch proposed fixSplinter Review
previous patch was completely wrong, except that it stopped the crash :-)

With this patch, we'll figure out the newIndex if AddHdr doesn't set it for us.
Attachment #348135 - Attachment is obsolete: true
Attachment #348199 - Flags: superreview?(neil)
Attachment #348199 - Flags: review?(neil)
Attachment #348135 - Flags: superreview?(neil)
Attachment #348135 - Flags: review?(neil)
Attachment #348199 - Flags: superreview?(neil)
Attachment #348199 - Flags: superreview+
Attachment #348199 - Flags: review?(neil)
Attachment #348199 - Flags: review+
fix checked in.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
oh, for fun, the reason windows (at least, debug builds) didn't have an issue is that the uninitialized local var seemed to always be set to 0.
Duplicate of this bug: 464987
Duplicate of this bug: 465011
Crash Signature: [@ nsMsgThreadedDBView::MoveThreadAt]
You need to log in before you can comment on or make changes to this bug.