Closed Bug 465256 Opened 11 years ago Closed 11 years ago

Dragging bookmark in Bookmarks Toolbar broken; opens new Tab instead.

Categories

(Firefox :: Bookmarks & History, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.1b2

People

(Reporter: trisweb, Assigned: mano)

References

Details

(Keywords: verified1.9.1)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081116 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081116 Minefield/3.1b2pre

Latest Minefield nightly build as of November 16th. Dragging a bookmark within or into the Bookmarks toolbar causes an arrow to appear in the tab bar. When the mouse drag is released, a new tab of the dragged bookmark opens. The desired behavior was for the position of the bookmark in the Bookmarks Toolbar to change to the cursor location (shown correctly with an I beam marker).

Reproducible: Always

Steps to Reproduce:
1. Click and hold bookmark in Bookmarks Toolbar
2. Attempt to drag bookmark to new location.
Actual Results:  
New tab opened in browser window.

Expected Results:  
Bookmark re-positions at location under mouse cursor indicated by I beam.

Sometimes the I beam indicating the drag target and the Arrow indicating dragged tab position flicker back and forth.

As far as I can tell, I did this approx. 2 days ago and it worked as expected, so it's a regression.
if reproiduceable this could be a regression from bug 225680
Confirmed in new profile on XP.
works 20081114034305
broken 20081115150852
Confirmed on XP x64
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: Macintosh → PC
Version: unspecified → Trunk
Flags: blocking-firefox3.1?
Blocks: 225680
In today's nightly Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081117 Minefield/3.1b2pre ID:20081117040154 rather than opening a new tab when dragging a bookmark, nothing happens at all. The ibeam shows the drop location, but the cursor shows the stop sign and the bookmark never moves. Probably due to landing of Bug 465179?
Confirmed behavior noted in #4 in 11/16 nightly; dragging bookmarks now does not work at all. Also after drag ends, seems to freeze the dragging for further attempts and (at least in OSX) causes window to be dragged instead.
Duplicate of this bug: 465503
Fixed.
Assignee: nobody → mano
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081118 Minefield/3.1b2pre ID:20081118125341

VERIFIED
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Target Milestone: --- → Firefox 3.1b2
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090127 Shiretoko/3.1b3pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.