Closed Bug 465293 Opened 14 years ago Closed 14 years ago

Edit bookmark

Categories

(Firefox for Android Graveyard :: Bookmarks, enhancement)

Other
Maemo
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
fennec1.0b1

People

(Reporter: christian.bugzilla, Assigned: enndeakin)

References

Details

(Keywords: uiwanted)

Attachments

(1 file)

No description provided.
It should be possible to edit a bookmark (and bookmark folder)
We do allow editing a bookmark using the "star" button. Do you mean editing a bookmark using a different trigger?

Currently, we don't support folders. See bug 456482. Is this a dupe?
Currently you can only edit a bookmark if you actually are on that page. That seems a bit cumbersome :)

So there should be an option to actually edit a bookmark when you are in the "bookmark app". Same thing for folders. 

So I don't think this is a dupe.
Another thing is you can't edit the URL in the current "star button invocation"
Blocks: 467670
Flags: blocking-fennec1.0+
Target Milestone: Fennec A2 → Fennec A3
Duplicate of this bug: 456490
Attached patch edit bookmarksSplinter Review
Adds Edit buttons into the bookmark list for editing of bookmarks. Also updates the Star button to edit only the current page, and allows editing of the url.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #352406 - Flags: review?(mark.finkle)
if you're going to rename urlbar, shouldn't it be to bookmarks.xml or something?
It also contains URL bar stuff...
Comment on attachment 352406 [details] [diff] [review]
edit bookmarks

The only nits I have are related to the use of "BrowserUI." from inside BrowserUI methods. Using "this." seems more conventional.
Attachment #352406 - Flags: review?(mark.finkle) → review+
At some point, it might be nice to refactor out the bookmark list behavior into a helper class. But that might just be my personal bias.
style nit:
+  stopEditBookmark : function()
+  {

please put the { on the same line, like the rest of the file
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
it's possible to edit a bookmark on builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.3a1pre) Gecko/20090818 Fennec/1.0a3pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090821
Fennec/1.0b3pre

and

Mozilla/5.0 (Macintosh; U; Intel Mac OSX 10.5; en-US; rv:1.9.2a2pre)
Gecko/20090808 Fennec/1.0b3pre
Status: RESOLVED → VERIFIED
Component: General → Bookmarks
You need to log in before you can comment on or make changes to this bug.