Allow showing unread counts per-folder (total is also required in addition to unread count)

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: davida, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Dependency tree / graph
Bug Flags:
wanted-thunderbird +
blocking-thunderbird3 -
blocking-thunderbird3.1 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has l10n impact])

(Reporter)

Description

10 years ago
We should also be able to provide an option to show the total number
of messages in the folder pane (in a single column).

Strawman UI in Folder Properties, first tab:


Folder layout:  *Inbox (2*/320*)*  //5KB//

  [X] Show unread message count 
  [X] Show total message count
  [X] Show disk space used

"(Inbox",  "2" and ")" are bold, "5KB" is italicized, /320 is plain.
Flags: blocking-thunderbird3+

Comment 1

10 years ago
See bug 464973 comment #8 and #14

Comment 2

10 years ago
Is there a particular reason why you want "5KB" italicized? I don't think it's desired to have all three of normal, bold, and italic fonts in such a small label.
// is just to indicate a light colored font, not an italic style  

looks like a mis-copy from bug 464973 Comment #7
If we have bug 465568, then I wouldn't care about having disk space on the folder pane (although obviously we could pref it).

One thought about the unread counts. Rather than having a number, how about being able to have some other form of indication, e.g. a bit like a battery full indicator. I could set a limit (account or per folder?) and at that limit or anything above would show a full icon, and then we could probably manage a 75%, 50% and 25% icons, as well as an empty.

Hovering over the icon would show the unread count in a tooltip.

For things like trash/archive folders, we'd probably just want a way to not show the ui, or show a special symbol, as they'd probably be over the limit most of the time.

Although its my suggestion, I'm not sure about setting the full limit, I can see some issues there, but it would get away without having two numbers right next to the folder name.

Comment 5

10 years ago
I really don't quite get why you would want to hide those numbers so much. Right now I'm sure enough I would be one of those people who would turn those numbers on, whenever that becomes possible.
(In reply to comment #5)
> I really don't quite get why you would want to hide those numbers so much.
> Right now I'm sure enough I would be one of those people who would turn those
> numbers on, whenever that becomes possible.

That was my personal suggestion, not a TB dev we must do this. For me the only reason to have the numbers is to give me an indication of how much email I have in a folder, when I look at my folders at the same time, I don't need to know I have precisely 134 emails in one folder and 133 in another, I just need to know I've got a lot, and those two folders relative to my folder with only 10 emails are ones I should process again first.

I'm just suggesting an alternative (prettier?) way of doing it. It might not work in all instances, and might initially be more extension fodder rather than TB core, but I'd rather suggest it whilst we're still looking at this, rather than later and wish I'd done it earlier.
I like the suggestion.  I don't think the space indicator is going to be a necessary constant visual element assuming we have bug 465568.  Hopefully since we continue to provide the size on disk value then we might be able to see extensions do something different and interesting like your suggestion with the values.  The size on disk indication hasn't seen any kind of innovation or development in a long time.
(Reporter)

Comment 8

9 years ago
Given that we can't do span styling in table cells, we can't have italic, light fonts, or bold.  

Anyone interested in taking this bug?
more than a week has gone by... going to have to bump this off the list.  If someone wants to take this on we can aim it for one of the releases but I think we'll have to ship b2 without this for now.
Target Milestone: Thunderbird 3.0b2 → ---
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists

Updated

9 years ago
Blocks: 476840
As this likely affects strings, would be good to get in by b4.
Keywords: helpwanted
Whiteboard: [affects l10n]
Target Milestone: --- → Thunderbird 3.0b4

Updated

9 years ago
Whiteboard: [affects l10n] → [has l10n impact]
The Thunderbird drivers wish to release Thunderbird 3 as soon as possible. As a
result, we feel that this bug shouldn't stand in the way of all the other good
work getting into the hands of users sooner rather than later. Therefore we are
retargeting it for 3.1. See http://ccgi.standard8.plus.com/blog/archives/242
for more details. The 3.1 release is expected to be a quick release soon after
Thunderbird 3.
Flags: blocking-thunderbird3.1+
Flags: blocking-thunderbird3-
Flags: blocking-thunderbird3+
Target Milestone: Thunderbird 3.0b4 → ---
Adding "total" in bug summary for ease of search.
Summary: Allow showing unread counts per-folder → Allow showing unread counts per-folder (total is also required in addition to unread count)
Duplicate of this bug: 535852
As far as I know, we still want this, so I gave it the unversioned wanted-thunderbird+.  My understanding from our various meetings is that this would NOT block a release.  Bryan, if you disagree given 3.1's major update focus, please renominate or set the multi-state blocking flag.
Flags: wanted-thunderbird+
Flags: blocking-thunderbird3.1-
Flags: blocking-thunderbird3.1+
For workaround, see bug 464973 comment #23. Add-on of "Extra Folder Columns" is already available. 
> https://addons.mozilla.org/en-US/thunderbird/addon/9716/

Comment 16

2 years ago
This works in current versions without addons
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.