Move search box to sidebar in inproduct mode

VERIFIED FIXED in 1.0

Status

VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: cilias, Assigned: paulc)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only, URL)

(Reporter)

Description

10 years ago
For KB articles, the search box was moved to the sidebar, as a result of bug 442182. We forgot to make that same change to inproduct mode (mozip.css).
Let's get this in before 3.1 is out.
Target Milestone: --- → 0.9

Updated

10 years ago
Target Milestone: 0.9 → 1.1

Comment 2

10 years ago
I thought we decided to remove in-product mode.

Comment 3

10 years ago
Nevermind, it was just proposed and I didn't read through the rest of that beast of a thread.
(Reporter)

Comment 4

10 years ago
We didn't decide to remove inproduct mode, but make it applicable to the entire KB plus search results. Right now, it's only applicable to articles in the "Linked from in-product help" category.

Updated

10 years ago
Assignee: nobody → paul.craciunoiu
(Assignee)

Comment 5

10 years ago
Waiting on input from David or Chris, etc. We need to re-style the pages for inproduct mode once we remove the big search. They look kinda ugly. See screenshot in bug 465872 comment 10
Bug 451445 comment 10, that is. This should be cleared up now. :)
(Assignee)

Comment 7

10 years ago
r23459 / r23460
Needs testing to make sure I only changed the right pages. The sidebar is only shown on KB articles in inproduct mode. This may be unnecessary, but I just wanted to make sure I don't change other inproduct pages.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

10 years ago
There should be a search box in the sidebar.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

10 years ago
r23466 / r23467
Good point. Forgot to add the template file. Sorry!
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Target Milestone: 1.1 → 1.0
(Reporter)

Comment 11

10 years ago
The sidebar search didn't get pushed to prod.
<http://support.mozilla.com/en-US/kb/Menu+reference?style_mode=inproduct>
I tried assigning the module to mozip.css, but that didn't do it.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

10 years ago
I actually see two now, but only when logged out. When logged in, all is fine.

This is a cache issue. I've reopened bug 398773 for this. Needs to be assigned to someone who can clear the cache.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Verified FIXED on http://support.mozilla.com/en-US/kb/Menu+reference?style_mode=inproduct logged in and out; cache has updated its CSS.
Status: RESOLVED → VERIFIED
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.