Closed Bug 466421 Opened 13 years ago Closed 6 years ago

Deleting a large number of history items shows the slow script warning

Categories

(Firefox :: Bookmarks & History, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mossop, Unassigned)

References

Details

(Keywords: perf, Whiteboard: [TSnappiness])

I deleted a large number of history entries today from the bookmarks organiser (some 32k). The browser hung for a long time with a lot of:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://browser/content/places/treeView.js:370
This probably happens more frequently now given that the patch for bug 453157 has landed (see bug 453157 comment 63).
Perhaps. I am apparently running a build without that patch in it though.
Bug 468209 will reduce the number of slow script warnings to one, that is due to the TreeView update, particularly we stop in _refreshVisibleSection.
Keywords: perf
Did bug 468209 help?
Whiteboard: [TSnappiness]
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Depends on: 681420
Duplicate of this bug: 479666
Duplicate of this bug: 677058
Duplicate of this bug: 671540
This still happens on FIrefox 8. I have been waiting over 5 mins and firefox is still trying to delete 1870 messages which I filtered and opted to delete.
(In reply to Jithin Emmanuel from comment #9)
> This still happens on FIrefox 8. I have been waiting over 5 mins and firefox
> is still trying to delete 1870 messages which I filtered and opted to delete.

Bug 681420 's fix has landed in Firefox 9, which should resolve this too. Can you try Firefox beta channel (where Firefox 9 currently resides) and see if that helps please:
http://www.mozilla.org/firefox/channel/

If you'd rather not try the beta, Firefox 9 will be released in non-beta form on ~20th Dec.

Thanks :-)
yeah, this should be WFM currently, we pause during removals.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Deleting 18k history entries this morning in an otherwise-idle browser redlined my CPU (top reports Firefox using 100%+ CPU), popped up slow-script warnings in the history window and beachballed Firefox on my current-gen MBP for close to fifteen minutes.

Steps to reproduce for me were to:

- Have around 100K history entries. 
- Pick some large subset of them to delete, (in my case searching on "imgur"), select all
- delete them.

Relatedl, the slow script warning dialog doesn't appear to actually work - the button to stop that script didn't - but I'm not sure if that's an expected behavior in this context or another bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Resetting to WFM, moving my comment to 871908 per a conversation with mak.
Status: REOPENED → RESOLVED
Closed: 10 years ago6 years ago
Resolution: --- → WORKSFORME
same problem as others described but in 63.0 (64-bit) FireFox for Arch Linux.
100% cpu usage on only *one* core, freezing all of ff.

Script warnings pop up `chrome://browser/content/places/controller.js:306`.

Please reopen :)
There are other bugs tracking the same problem, there's no point into reopening this, just search for open bugs.
You need to log in before you can comment on or make changes to this bug.