Closed Bug 479666 Opened 13 years ago Closed 10 years ago

Deleting a lot of history entries via the all history view shows unresponsive script warning (chrome://browser/content/places/controller.js:967/1000)

Categories

(Firefox :: Bookmarks & History, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 466421
Tracking Status
blocking2.0 --- -

People

(Reporter: whimboo, Unassigned)

References

Details

(Keywords: hang, Whiteboard: [tsnap])

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090221 Minefield/3.2a1pre Ubiquity/0.1.5 ID:20090221020633

I have a really huge amount of history entries in my places.sqlite database file (26MB) and deleting all those entries inside the library comes up with the unresponsive script warning dialog. The warning is shown for these both lines:

chrome://browser/content/places/controller.js:967
chrome://browser/content/places/controller.js:1000

I don't know how many people will be affected by this problem. But my setting for "keep my history for" is set to 90 days, which is the default value. I think it's worth asking for blocking FF3.1.
Flags: blocking-firefox3.1?
Really don't think we should block on this.  Likely a result of bug 418176.  In fact, this might even be a duplicate.
we can't do anything about that for now, treeview needs to update many items if you remove history by doing select all and delete... clearly a user should use the new clear recent history dialog, select all and delete is expected to be slow sadly.
and notice this is now better since before you were getting 3 or 4 of those dialogs, while now you'll get only one.
This changed some time ago when the measure to show the dialog has been changed in the platform (can't recall bug now)
(In reply to comment #2)
> you remove history by doing select all and delete... clearly a user should use
> the new clear recent history dialog, select all and delete is expected to be
> slow sadly.

Sorry, I cannot use this dialog without deleting my download list too. It's the only way I can clear the history for now.

(In reply to comment #3)
> and notice this is now better since before you were getting 3 or 4 of those
> dialogs, while now you'll get only one.

No, I probably end-up in an infinite loop. I stopped after 3 dialogs.
Not blocking on this, it's not a regression and not primary UI. This is a high priority target for 3.2.
Severity: critical → major
Flags: blocking-firefox3.1? → blocking-firefox3.1-
Priority: -- → P2
Target Milestone: --- → Firefox 3.2a1
Doesn't look like this will make 3.6 (and certainly not a1 ;)

Perhaps for 3.7?
blocking2.0: --- → ?
Target Milestone: Firefox 3.6a1 → ---
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
The treeview is smarter now. Is this still reproducible?
Whiteboard: [tsnap]
While this isn't ideal, I don't think this blocks the release of Firefox 4.0.
blocking2.0: ? → -
Still reproducible in Firefox 4.0?
Duplicate of this bug: 546627
Depends on: 681420
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466421
You need to log in before you can comment on or make changes to this bug.