Open Bug 466835 Opened 12 years ago Updated 4 years ago

float within nowrap ==> content outside of viewport (wrong width of containing element)

Categories

(Core :: Layout: Floats, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

People

(Reporter: s.a.moeller, Unassigned)

References

Details

(Keywords: regression, testcase)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081116 SeaMonkey/2.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Having a floating element next to a normal positioned element inside a container with white-space:nowrap, the normal positioned element gets shifted out of the viewport.

Reproducible: Always

Steps to Reproduce:
See attached testcase.
Component: General → Layout: Floats
Keywords: testcase
Product: Firefox → Core
This is a regression from Bug 300030.
Keywords: regression
Version: unspecified → Trunk
I think this is the same as bug 441400.  The case referred to there doesn't have the container floating like this case but looks the same otherwise.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441400
Similar result with 
  position:absolute; right:0;
instead of
  float: right;

Probably related with bug 349255.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted1.9.1?
Do other browsers (e.g., Safari, Opera) match the Firefox 2 layout, the Firefox 3 layout, or do they put one below the other?
Fx2, Opera9.6, IE7, IE8 beta2 match.
Safari 3.2 does the same as Fx3
Flags: wanted1.9.1?
Flags: wanted1.9.1-
Flags: blocking1.9.1-
QA Contact: general → layout.floats
Webkit nightly does the same as Fx3
Opera 10 does the same as Fx2
Mozilla/5.0 (Windows NT 10.0; rv:46.0) Gecko/20100101 Firefox/46.0
Mozilla/5.0 (Windows NT 10.0; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested your issue on latest FF release (v. 46.0), latest Nightly build (49.0) and managed to reproduce it. 

Reproducible also on: Chrome and IE
You need to log in before you can comment on or make changes to this bug.