Clicking on the "Today" button in the minimonth doesn't refresh the calendar view

RESOLVED FIXED in 1.0b1

Status

Calendar
Calendar Views
--
minor
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: martinschroeder, Assigned: Przemyslaw Bialik)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

Created attachment 350314 [details] [diff] [review]
Patch v1

Clicking on the "Today" button in the minimonth doesn't refresh the calendar view. It should refresh because another day is selected in minimonth. If you select a day directly per click, the calendar view is refreshed.

The issue was reported to me by Ludovic, and he also created the patch. First requesting just ui-review from Christian.
Attachment #350314 - Flags: ui-review?(christian.jansen)

Comment 1

9 years ago
As far as I can remember this was done on purpose. The behavior is similar to the < and > buttons in the minimonth that don't change the views but only the minimonth itself. Only a selection of a specific date in the minimonth will change the view but only if the calendar view is displayed. For example selecting a specific date in the minimonth in the Today Pane needs a different action.

Comment 2

9 years ago
Stefan, you're right about this but when you click on the "Go to Today" button, it does select the current day. If it does select, it should also change the view.

Updated

9 years ago
Attachment #350314 - Flags: ui-review?(christian.jansen) → ui-review+

Comment 3

9 years ago
Comment on attachment 350314 [details] [diff] [review]
Patch v1

Makes sense & would save one click. ui+
Comment on attachment 350314 [details] [diff] [review]
Patch v1

>+                            oncommand="var d = new Date(); this.kMinimonth.selectDate(d);
>+                                       this.kMinimonth.dayClicked(this.kMinimonth.getBoxForDate(d));"
Aside from the fact that the oncommand attribute is now duplicate, I'd rather see this fixed in the minimonth binding if possible. I guess I can live without that for now though.

r=philipp with first oncommand attribute removed.
Attachment #350314 - Flags: review+
(Reporter)

Comment 5

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/ac5088aa887e>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Reporter)

Comment 6

9 years ago
Error: this.kMinimonth.dayClicked is not a function
Source File: chrome://messenger/content/messenger.xul
Line: 1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

9 years ago
Ludovic, can you provide a patch to fix the error and make the feature work? Otherwise I'd recommend to back out the patch.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 475507
(Reporter)

Comment 9

9 years ago
Backed out from comm-central <http://hg.mozilla.org/comm-central/rev/2e3bd45d1468>
(Assignee)

Comment 10

9 years ago
Created attachment 359101 [details] [diff] [review]
Proposed fix v2
Attachment #359101 - Flags: review?(Berend.Cornelius)
Summary: Clicking on the "Today" button in the minimonth doesn't refresh the calendar view → Clicking on the "Today" button in the minimonth doesn't refresh the calendar view [this.kMinimonth.dayClicked is not a function]
(Reporter)

Updated

9 years ago
Assignee: lmarcotte → firefox
Status: REOPENED → ASSIGNED
(Reporter)

Updated

9 years ago
Attachment #350314 - Attachment is obsolete: true

Updated

9 years ago
Attachment #359101 - Flags: review?(Berend.Cornelius) → review-

Comment 11

9 years ago
Comment on attachment 359101 [details] [diff] [review]
Proposed fix v2

At first this solution looked very elegant. To make it even better you could also directly assign the commmand "calendar_go_to_today_command".
But I am sorry to deny the review: The minimonth is not necessarily linked to the calendar views as it would with your solution. For example you can configure a minimonth  in the today-pany above the agenda-listbox and control the date of the agenda-listbox with it without having any impact on the calendar-views.
(Assignee)

Comment 12

9 years ago
(In reply to comment #11)
The patch refreshes calendar views when go to today is clicked on the minimonth above agenda-listbox.
Is this not wanted ?
If it is wanted + select day -> refresh the calendar views than the last part is another bug. ?
I've just noticed that there is a bigger problem (not related to the patch) with the go to today button and minimonth + agenda-listbox - the day in agenda-listbox is not refreshed to display events for today.
(Assignee)

Comment 13

9 years ago
Please reply because I'm not sure what is wanted / what are the side effects of the proposed fix from your side.

Comment 14

9 years ago
In our application we have several minimonths and we do not want each of them to set the calendar-views to "today". Only the minimonth with the id "calMinimonth" is supposed to do this.

Comment 15

9 years ago
>The patch refreshes calendar views when go to today is clicked on the minimonth
>above agenda-listbox.

This is not the desired behaviour of that minimonth. I guess my explanation for this in commment #11 was not unambiguous.

Comment 16

9 years ago
I think this bug is related to what I found here:

https://bugzilla.mozilla.org/show_bug.cgi?id=476312

If someone agrees, I think it may be appropriate to list this bug as a dependency, or else create a new one that encompasses the entire class of these bugs.

I don't think this is a minor bug - I think the root cause of this bug, namely the decoupling of information displayed in the Today pane with the actual task/event information is responsible for several open or unconfirmed bugs.

I would appreciate a developer looking at my bug (and my comments) and offering their insight - if it turns out I'm completely wrong, I'm happy to admit it. But I think this points to a systemic flaw in the coupling of displayed information (within the Today Pane) to the actual object information.

Comment 17

9 years ago
(In reply to comment #16)
No. Currently it works as specified. The patch above that wanted to change the current the behavior introduced the error in comment #6 and therefore was backed out. There is no relation to bug 476312.
Summary: Clicking on the "Today" button in the minimonth doesn't refresh the calendar view [this.kMinimonth.dayClicked is not a function] → Clicking on the "Today" button in the minimonth doesn't refresh the calendar view
(Assignee)

Comment 18

9 years ago
Created attachment 361540 [details] [diff] [review]
Proposed fix v3

Fixes this bug +
<quote>
I've just noticed that there is a bigger problem (not related to the patch)
with the go to today button and minimonth + agenda-listbox - the day in
agenda-listbox is not refreshed to display events for today.
</quote>

Please test for regressions ;)
Attachment #359101 - Attachment is obsolete: true
Attachment #361540 - Flags: review?(berend.cornelius09)
(Assignee)

Updated

9 years ago
Attachment #361540 - Flags: review?(berend.cornelius09) → review?(philipp)
Attachment #361540 - Flags: review?(philipp) → review+
Comment on attachment 361540 [details] [diff] [review]
Proposed fix v3

Works fine, r=philipp
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/3096bf930f58>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.