Closed Bug 467417 Opened 11 years ago Closed 11 years ago

remove support for CFM plugins on Mac OS X

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jaas, Assigned: jaas)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

We should remove support for CFM (Code Fragment Manager) plugins on Mac OS X. PPC NPAPI plugins on Mac OS X should be mach-o binaries. Plugin vendors were informed of this change in August of 2008. Barring any major complications, this change should take effect in Gecko 1.9.2 (or whatever comes after 1.9.1).
Attached patch fix v1.0Splinter Review
This needs to be tested on PPC Mac OS X, all major plugins should continue to function. We need to make sure plugins can load and interact with mouse and keyboard and also die cleanly (no crash when closing a tab with an active plugin instance in it).
Attachment #350836 - Flags: review?(smichaud)
Attachment #350836 - Flags: review?(smichaud) → review+
Comment on attachment 350836 [details] [diff] [review]
fix v1.0

This looks fine to me.

I tested it (together with the v1.0 patch for bug 467429, attachment
350850 [review]) on my old PPC G4 running OS X 10.4.11, and didn't have any
problems using any of the following plugins:

1) Flash 9.0 r124 (installed by Apple)

   http://rogerdean.com

2) QuickTime 7.5.5 (installed by Apple)

   Movie trailers at http://www.apple.com/trailers

3) Silverlight 1.0 (last version to support PPC)

   Examples at http://www.vectorforum.com/silverlight

4) Real Player 11.0

   Movie trailers at http://www.film.com/movies/trailers

5) Flip4Mac 2.2.1.11

   Examples at http://www.windowsmedia.com/MediaGuide/Home

(The Flip4Mac examples worked pretty badly ... but they were no worse
than in Firefox 3.0.4.  I suspect the Flip4Mac trouble is caused by a
plugin resizing itself after it's been loaded.  See bug 436945 and bug
453445.)
Attachment #350836 - Flags: superreview?(jst)
Attachment #350836 - Flags: superreview?(jst) → superreview?(roc)
Attachment #350836 - Flags: superreview?(roc) → superreview+
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/01831806827a
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.