dragover attribute is not always cleaned up correctly

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

({polish, verified1.9.1})

Trunk
Firefox 3.6a1
polish, verified1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy][polish-interactive][polish-p3])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
Created attachment 351187 [details] [diff] [review]
patch

when we drag over a folder child of a toolbar menu we null out overfolder to avoid closing the parent, but this way we will never unset "dragover" attribute.

This is a style issue only, we don't use that dragover for anything other (notice this "dragover" is not the same we set on menupopups)
Attachment #351187 - Flags: review?(dietrich)
(Assignee)

Updated

9 years ago
Target Milestone: --- → Firefox 3.1
(Assignee)

Comment 1

9 years ago
Created attachment 351190 [details] [diff] [review]
patch

while there a nit on a wrong comment
Attachment #351187 - Attachment is obsolete: true
Attachment #351190 - Flags: review?(dietrich)
Attachment #351187 - Flags: review?(dietrich)
(Assignee)

Updated

9 years ago
Duplicate of this bug: 422289
Comment on attachment 351190 [details] [diff] [review]
patch

r=me. please provide STR for QA to verify.
Attachment #351190 - Flags: review?(dietrich) → review+
(Assignee)

Comment 4

9 years ago
i tested this on XP where the blu hilight is quite visible.
1. create a new folder A on the bookmarks toolbar
2. create a new folder B inside folder A
3. create a new bookmark C on bookmarks toolbar
4. drag C inside B
5. close all menus, click on A, it should NOT be highlighted as if we were dragging on it
(Assignee)

Comment 5

9 years ago
Created attachment 354820 [details] [diff] [review]
patch v1.1

i wrongly removed var parent = popup.parentNode; in previous version, it should be there clearly since we check on it.
Attachment #351190 - Attachment is obsolete: true
(Assignee)

Comment 6

9 years ago
http://hg.mozilla.org/mozilla-central/rev/6b8fb1215fd7
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 3.1 → Firefox 3.2a1
(Assignee)

Comment 7

9 years ago
Comment on attachment 354820 [details] [diff] [review]
patch v1.1

asking approval for this polish bug, no risk.
Attachment #354820 - Flags: approval1.9.1?
(Assignee)

Updated

9 years ago
Keywords: polish
Comment on attachment 354820 [details] [diff] [review]
patch v1.1

a191=beltzner
Attachment #354820 - Flags: approval1.9.1? → approval1.9.1+

Updated

9 years ago
Whiteboard: [polish-easy]
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/1f72b977ac0e
Keywords: fixed1.9.1
(Assignee)

Updated

9 years ago
Duplicate of this bug: 464142
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090127 Shiretoko/3.1b3pre
Keywords: fixed1.9.1 → verified1.9.1

Updated

9 years ago
Status: RESOLVED → VERIFIED
This bug's priority relative to the set of other polish bugs is:
P3 - Polish issue that is in a secondary interface, occasionally encountered, or is not easily identifiable.
Whiteboard: [polish-easy] → [polish-easy][polish-interactive][polish-p3]
You need to log in before you can comment on or make changes to this bug.