If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[W2K] Customizing main mail and compose toolbars does not work

RESOLVED DUPLICATE of bug 502356

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 502356
9 years ago
8 years ago

People

(Reporter: Ton, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: w2k_only, has regressionwindow in comment #8)

(Reporter)

Description

9 years ago
For the recent couple of months, customizing the main mail and compose window toolbars has’t been possible anymore in nightly and current TB3b1 versions. Can’t tell when exactly this started to fail unfortunately.

OS: win2000. May be related to bug 455248 as the error console shows the same error.
(Reporter)

Updated

9 years ago
Component: General → Mail Window Front End
QA Contact: general → front-end
Summary: Customizing toolbars doesn not work → Customizing toolbars does not work

Comment 1

9 years ago
Works fine over here.
Have you disabled all extensions?
Target Milestone: Thunderbird 3 → ---
(Reporter)

Comment 2

9 years ago
I don’t use any extensions for testing (trunk) versions, unless in specific profiles for e.g. Lightning. TB does show the Flash 10.0r12 plugin used by FF 3 (trunk) and the WMP dll though, but I doubt these would do any harm. Disabling both does not help.

This happens on all freshly used zips and on either profile, on my own locale as well as en-US (even today’s build with a new one). I also keep seeing the ‘menuItems[0] is undefined’ and ‘a._updateVisibleText is not a function’ errors in the log when opening or closing the customize box. May be related to bug 467933 and/or bug 358446?
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> May be related to bug 467933?

Sorry, meant bug 382058. Also recall another one I haven’t bookmarked unfortunately.

Updated

9 years ago
Keywords: regression
Summary: Customizing toolbars does not work → Customizing main mail and compose toolbars does not work

Comment 4

8 years ago
Ton, do you still see this on most recent tb3.0 pre build?

If not, please resolve duplicate of bug 382058.
Whiteboard: closeme
(Reporter)

Comment 5

8 years ago
Unfortunately yes, and I’m quite sure this has nothing to do with the bugs mentioned above. This behaviour was clearly introduced during the timeframe on TB only - Firefox 1.9.1 does not suffer from it.

Checking bonsai via http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-10-31+00%3A00%3A00&maxdate=2007-11-01+23%3A59%3A00&cvsroot=%2Fcvsroot did not lead me to anything that relates to either toolbar or copy/paste issues, although that’s from a non-developers point of view.

As a test, I moved some files between both zip versions from the period above, and it turned out using the 2007-10-31 thundebird .exe (only) on all other 2007-11-01 files makes both (!) issues disappear - a trick thath does not work for the latest builds, of course. Could someone take a look at this particular timeframe or give a hint on what has else changed that day, like a change in compilation perhaps? I’m willing to help in any way I can.

From http://www.mozillamessaging.com/en-US/thunderbird/3.0b4/releasenotes/#requirements :
“Please note that Thunderbird 3 Beta 4 no longer supports versions of Windows prior to Windows 2000…”

I would appreciate if this gets fixed - if not for 3.0, at least soon afterwards. Remember company and/or other w2k users might drop TB3 otherwise…

Comment 6

8 years ago
(In reply to comment #5)
> Unfortunately yes, and I’m quite sure this has nothing to do with the bugs
> mentioned above. This behaviour was clearly introduced during the timeframe on
> TB only - Firefox 1.9.1 does not suffer from it.

Ton, could you please post the exact TB build (Help > About TB) and your OS on which you tested this and see the bug, because I'm not seeing this. 
Here's the most current nightly:
ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/

> http://www.mozillamessaging.com/en-US/thunderbird/3.0b4/releasenotes/#requirements
> “Please note that Thunderbird 3 Beta 4 no longer supports versions of Windows
> prior to Windows 2000…”
> I would appreciate if this gets fixed - if not for 3.0, at least soon
> afterwards. Remember company and/or other w2k users might drop TB3 otherwise…

I don't understand. We are still supporting w2k, just not anything BELOW that (prior to that) (like win95, win98, winME)
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)

> Ton, could you please post the exact TB build (Help > About TB) and your OS on
> which you tested this and see the bug, because I'm not seeing this. 
> Here's the most current nightly:
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/

Mozilla/5.0 (Windows; U; Windows NT 5.0; nl; rv: 1.9.1.6pre) Gecko/20091111 Shredder/3.0pre is the ID of the most recently used version. This is on a p3-500 carrying Windows 2000, 5.00.2195 with SP 4 and the rollup update package 1 v2, Dutch, including all other available fixes. Unfortunatley I haven’t had a chance to do a fresh w2k install on another pc so far, which may lead to a slight bit of uncertainty, though the pc is used pure for l10n development, has been stable ever since and never had a similar (like the known Windows copy/paste) or other problem with any application.

Looking back in this bug to find the reported timeframe when this started occurring, I think an apology is in order, as I seem to have submitted this bug a second time and forgot about reporting this one. Please see bug 502356 (which can be considered as a dupe) for the exact timeframe. Note that bug 502356 addresses both this customiziation issue as well as a copy/paste failure, which seem to be related.
 
> I don't understand. We are still supporting w2k, just not anything BELOW that
> (prior to that) (like win95, win98, winME)

My point exactly, even though some may think otherwise (see bug 502356).

Updated

8 years ago
Blocks: 502356

Comment 8

8 years ago
Related W2K bug 502356 (copy & paste broken) has a precise one-day regression window when both copy & paste and toolbar customization stopped working on Win2K, perhaps the two issues are related:

(bug 502356, comment #0)
> For a long time, customizing toolbar icons as well as copy/paste does no
> longer work in TB 3 trunk versions on Win 2k. Trying several trunk builds to
> narrow down the problems indicate the last version working as it should is
> 3.0a1pre (2007103102), the first one suffering both issues is 3.0a1pre 
> (2007110103). What seems to be two different problems might therefore be
> related, so this bug addresses both.
> This may be OS related, as no-one mentioned them before and not many users may
> be using Win2k nowadays. For comparison, one can use the versions on
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/2007/10/2007-10-31-02-trunk/ and
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/2007/11/2007-11-01-03-trunk/ .
Summary: Customizing main mail and compose toolbars does not work → [W2K] Customizing main mail and compose toolbars does not work
Whiteboard: closeme → w2k_only

Comment 9

8 years ago
One of the main obstacles to fix this is the fact that we're probably not even seeing it, as per Wayne's bug 502356, comment #3. Please remember this is Win2K only!

Ton, could you please provide precise "Steps to reproduce" (STR) as a step by
step instruction? Please be as specific as possible, to make sure we're doing
exactly what you do when you get the bug:
fuzzy: "3. drag any icon from customization palette onto main mail toolbar"
precise: "3. drag quicksearch icon from customization palette onto main mail
toolbar (or any icon for that matter)"
This is important because in the above example, it might also be the
quicksearch icon causing the trouble, and perhaps other icons work but you
never noticed.

Updated

8 years ago
Keywords: qawanted
Whiteboard: w2k_only → w2k_only, has regressionwindow in comment #8
(Reporter)

Comment 10

8 years ago
Of course.

Steps to reproduce

1. Install a fresh recent TB 3.0pre build and create a new profile
2. In the main mail window, right click the E-mail toolbar and choose Customize (or use View, Toolbars, Customize)
3. Drag one of the icons in the palette onto the E-mail toolbar, or from the toolbar to the palette

Actual results:
The toolbar icons stay where they are and do not even indicate they are being picked up by the mouse while dragging. Only the default icons (Get e-mail, Compose, Address Book and Label) exist in the toolbar.

Expected results:
The icons are moved, i.e. added to or removed from the toolbar.

Note: exactly the same thing happens when trying to move toolbar icons in the Compose or Address book window. Clicking the Set default button indicates activity in all cases, but nothing changes.
Sidenote: as with any pre-release versions of Mozilla products used for testing (like FF, SB, SM) I use zip builds only. I can’t imagine any registry changes are required, thus needing the installer.
(In reply to comment #7)
> Please see bug 502356 (which can be considered as a dupe)
No longer blocks: 502356
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 502356
You need to log in before you can comment on or make changes to this bug.