Last Comment Bug 469499 - kill macbrowser ifdefs
: kill macbrowser ifdefs
Status: RESOLVED FIXED
fixed-in-cedar
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: mozilla7
Assigned To: Ed Morley [:emorley]
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-13 15:40 PST by Robert Kaiser (not working on stability any more)
Modified: 2011-06-10 11:41 PDT (History)
2 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove MOZ_MACBROWSER (23.13 KB, patch)
2011-05-29 17:12 PDT, Ed Morley [:emorley]
benjamin: review+
Details | Diff | Review

Description Robert Kaiser (not working on stability any more) 2008-12-13 15:40:59 PST
I just ran across some non-macbrowser-defined code in xpfe/components (which we probably should get rid of completely), and decided to see if we still have some of that code left anywhere. The places are scarce, and I really think we should get rid of those. If Camino moves on to being based on mozilla-central one time, they really should use a stock XULRunner as their base, if possible.
Comment 1 Ed Morley [:emorley] 2011-05-29 17:12:01 PDT
Created attachment 535970 [details] [diff] [review]
Remove MOZ_MACBROWSER

Removes MOZ_MACBROWSER, since it's no longer defined:
http://mxr.mozilla.org/mozilla-central/search?string=MOZ_MACBROWSER

The now removed lines in mozSpellCheckerFactory.cpp were the last users of osxspell, so takes that out too:
http://mxr.mozilla.org/mozilla-central/search?string=OSXSpell
Comment 2 Ed Morley [:emorley] 2011-05-30 09:34:03 PDT
http://dev.philringnalda.com/tbpl/?tree=Try&rev=9709dc3e5f47
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-07 15:34:17 PDT
http://hg.mozilla.org/projects/cedar/rev/f4af0c314193
Comment 4 :Ehsan Akhgari (out sick) 2011-06-08 15:00:02 PDT
http://hg.mozilla.org/mozilla-central/rev/f4af0c314193
Comment 5 Nomis101 2011-06-10 10:06:39 PDT
Aaaaah, what please is the reason for completely removing OSXSpell? I use this constantly for my own builds and I love it. And a few bugs I've opened are based on OSXSpell.
Comment 6 Ed Morley [:emorley] 2011-06-10 10:14:18 PDT
Removing MOZ_MACBROWSER caused it to become dead code per comment 1.

You presumably already had to patch your local build to enable it, so can't you just export the hg revert of this patch and add that to your mq?
Comment 7 Nomis101 2011-06-10 11:41:08 PDT
(In reply to comment #6)
> You presumably already had to patch your local build to enable it, so can't
> you just export the hg revert of this patch and add that to your mq?
Yes, I had to revert Bug 422760 to enable it. But OK, I also will add this patch to my revert list. Thanks for the hint with mq!

Note You need to log in before you can comment on or make changes to this bug.