Bundled spellcheck dictionary invisible on Mac OS X

VERIFIED FIXED in mozilla1.9

Status

()

Core
Spelling checker
P2
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: marcoos, Assigned: Josh Aas)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9
All
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

6.09 KB, patch
mconnor
: review+
mconnor
: ui-review+
Details | Diff | Splinter Review
Firefox 3 now uses the global spellchecker of OS X.  and there's no way (or at least, no way visible to non-power user) to force it to use the 1+ MB spellchecker dictionary Firefox ships with.

Mac OS X 10.5 comes with Polish localization and you can set the system
language to Polish, but it does not contain Polish spellchecker. Firefox only
allows me to use the English system spellchecker.

Steps to reproduce:
1) On Mac OS X, install Firefox 3 with a localization that doesn't have an Apple-provided spell checker in the OS, but Firefox with this locale includes a spellchecker; e.g. install Polish Firefox 3.
2) Edit text in a textarea, like data:text/html,<textarea/>
3) Open context-menu, select "Languages" (pl: "Języki")

Actual results:
1) The only item in there is the system default spellchecker, usually English (pl: "Angielski")

Expected results:
1) There should be the dictionary bundled with Firefox listed (first?)

(split from bug 419959)
I think that this will be a major issue for all users of Firefox who are using a OS X locale which doesn't contain a dictionary. They wont have the spellchecker available for their own language. I think that this will happen for most of the languages worldwide. Do we have the possibility to have the old spellchecker as a fallback option?

Asking for blocking1.9.
Severity: normal → major
Flags: blocking1.9?
Hardware: PC → All

Comment 2

9 years ago
So if a FF2 user in poland upgrades to FF3 they'll lose spellchecking...   If that is the case we need to fix - is it possible for us to get a list of locales that this impacts and choose the dictionary?
Assignee: mscott → joshmoz
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Mike, it's hard to find a list of locales with a spellchecker. But here it is:

"10.4 has dictionaries for Australian, British, and Canadian English, German, Spanish, French, Italian, Dutch, Portuguese, Swedish, Danish, and Russian."

Got this from: http://homepage.mac.com/thgewecke/mlingos9.html#spell

It means there are nearly 30 locales which don't have a spellchecker available?
(Assignee)

Comment 4

9 years ago
We should probably just disable the native spellchecker at this point.
(Assignee)

Comment 5

9 years ago
Created attachment 312317 [details] [diff] [review]
fix v1.0
(Assignee)

Comment 6

9 years ago
I'm choosing to disable the native spellchecker because it wasn't built to work in tandem with hunspell. I don't think re-architecting things, if at all possible, is a good idea at this point.
Sounds good to me, fwiw.
(Assignee)

Comment 8

9 years ago
Created attachment 312342 [details] [diff] [review]
fix v1.1
Attachment #312342 - Flags: review?(stuart.morgan)

Comment 9

9 years ago
Comment on attachment 312342 [details] [diff] [review]
fix v1.1

Has hunspell ever been used on OS X? From what I can tell, it was myspell->osxspell, and hunspell came later.

If not, this seems pretty high-risk.

If this does land, then presumably bug 339980 (and possible others) needs to be backed out.

Comment 10

9 years ago
Comment on attachment 312342 [details] [diff] [review]
fix v1.1

(r=smorgan code-wise, since I'm not in a position to make the larger call either way)
Attachment #312342 - Flags: review?(stuart.morgan) → review+
(Assignee)

Comment 11

9 years ago
Yes, we'd want to back out 339980. I'll include that in an updated patch.
(Assignee)

Comment 12

9 years ago
Created attachment 312365 [details] [diff] [review]
fix v1.1
Attachment #312365 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #312365 - Flags: review? → review?(mconnor)
Blocks: 425210
Comment on attachment 312365 [details] [diff] [review]
fix v1.1

Oy, this really kinda sucks.  I wonder if there's a way to convert hunspell dictionaries to the format OS X uses?  Not really useful now, but would be a neat trick if we had a pkg installer (install Firefox, get spellchecking in your preferred language in all Mac apps!).
Attachment #312365 - Flags: ui-review+
Attachment #312365 - Flags: review?(mconnor)
Attachment #312365 - Flags: review+
(Assignee)

Comment 14

9 years ago
landed on trunk
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040204 Minefield/3.0pre ID:2008040204

Enabled "Check Spelling" for a textarea. Now I'm able to select one of the installed dictionaries or can add a new one. Tested with German dictionary.
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla1.9
Blocks: 419959
Duplicate of this bug: 415427

Comment 17

9 years ago
I was reading the blog entry by John Gruber on Firefox 3 OSX integration (http://daringfireball.net/2008/04/firefox_3_safari_3) and it looks like this bug would apply, or a follow-up that would either allow you to choose between using the system default or the built in, no matter what language, or what comment 13 is suggesting.

From the article:

Dictionary — Firefox doesn’t support the system-wide dictionary. In Safari (and most other apps), you can hover the mouse over any word and use Command-Control-D (by default) to display the definition of that word right there in the current window.

Maybe it would be good to add "ue" to the keywords' list.

Comment 18

9 years ago
He's talking about bug 301451, not this.
Possibly caused bug 427685?

Updated

9 years ago
Attachment #312317 - Attachment is obsolete: true

Updated

9 years ago
Attachment #312342 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.