Addressbar not editable in new tabs opened in a window with disabled addressbar

RESOLVED FIXED in Firefox 3.7a5

Status

()

Firefox
General
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: A. Somozas, Assigned: dao)

Tracking

unspecified
Firefox 3.7a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729)

In a popup window with addressbar disabled, if a new tab is aopened pushing CTRL+T, the result is a blank new tab with an empty, disabled, not-editable addressbar.

Reproducible: Always

Steps to Reproduce:
1. Enter http://www.alternate.es/html/productDetails.html?artno=NTZLU6 (i.e)
2. Push the "» mostrar más imágenes" link wich opens a new popup window showing more images of the product. This popup has no toolbar and addressbar is disabled.
3. Push CTRL+T to open a new tab on this window. A new tab displays, but addressbar is still disabled.
Actual Results:  
The addressbar was not editable

Expected Results:  
The new tab should have an editable addressbar or the popup shouldn't allow the opening of new tabs.
This is intentional, the bar used to not be displayed at all only recently that was changed to give the user a visual aid as to where he was (and to prevent spoofing). However, that window is a pop-up window not to be used for further browsing, to continue browsing close the window and use your regular window.
Is possible but then you need to set dom.disable_window_open_feature.toolbar to true in about:config
http://kb.mozillazine.org/About:config
(Assignee)

Comment 3

9 years ago
The real issue here is that ctrl+t shouldn't open a tab in the popup.
Component: General → Tabbed Browser
QA Contact: general → tabbed.browser
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> The real issue here is that ctrl+t shouldn't open a tab in the popup.

I think that's the point!
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

9 years ago
Created attachment 368687 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #368687 - Flags: review?(mconnor)
(Assignee)

Updated

9 years ago
Component: Tabbed Browser → General
OS: Windows XP → All
QA Contact: tabbed.browser → general
Hardware: x86 → All
(Assignee)

Comment 6

9 years ago
Created attachment 368768 [details] [diff] [review]
patch

better test
Attachment #368687 - Attachment is obsolete: true
Attachment #368768 - Flags: review?(mconnor)
Attachment #368687 - Flags: review?(mconnor)
(Assignee)

Updated

9 years ago
Blocks: 485237
(Assignee)

Comment 7

9 years ago
Created attachment 383916 [details] [diff] [review]
updated to trunk
Attachment #368768 - Attachment is obsolete: true
Attachment #383916 - Flags: review?(gavin.sharp)
Attachment #368768 - Flags: review?(mconnor)
(Assignee)

Updated

9 years ago
Duplicate of this bug: 505415
(Reporter)

Comment 9

9 years ago
Can be fully reproduced on 3.5.3. Same behavour.
Attachment #383916 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 10

8 years ago
http://hg.mozilla.org/mozilla-central/rev/ea6efeb2bfec
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a5

Comment 11

8 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100422 Minefield/3.7a5pre

When following the steps in comment 0, I get a popup with a disabled location bar. Pressing Ctrl+T seemingly does nothing. Right-clicking a link and selection "Open in New Tab" appears to do nothing. However, when going to close the window, I get the "Are you sure you want to close 7 tabs?" message. Is that intentional?
(Assignee)

Comment 12

8 years ago
(In reply to comment #11)
> "Open in New Tab" appears to do nothing. However, when going to close
> the window, I get the "Are you sure you want to close 7 tabs?" message. Is that
> intentional?

Please file a new bug on that. "Open in New Tab" should either be disabled or open a tab in a non-popup window.

Updated

7 years ago
Depends on: 561482
(Assignee)

Updated

6 years ago
No longer depends on: 561482
(Assignee)

Updated

2 years ago
Depends on: 1296863
You need to log in before you can comment on or make changes to this bug.