Closed Bug 470348 Opened 11 years ago Closed 11 years ago

clear private data on shutdown does not delete history if "ask me before..." is enabled

Categories

(Toolkit :: Places, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla1.9.2a1

People

(Reporter: mak, Assigned: mak)

References

Details

(4 keywords)

Attachments

(1 file, 1 obsolete file)

Actually clear private data dialog is fired at quit-application, and if options "ask me before..." is enabled work is done there after the user has made a choice.

That does not work anymore because on quit-application Places executes the last sync between memory tables and disk tables and closes the database connection. So we really should move all code that requires a working Places to quit-application-granted.

asking blocking for the obvious fact we are not clearing history on shutdown when requested by the user, so this could potentially be a serious privacy issue.
Flags: blocking1.9.1?
Blocks: 423507
this is a 3.1 regression, the issue is obviously not existant in 3.0 since we don't have to sync there.
Keywords: regression
Blocks: 449086
well no, the correct bug that regressed is bug 463471, that fixed the case where we clear without "ask me dialog"
Blocks: 463471
No longer blocks: 449086
i'm sure there is a bug around that should be duped to this, where Ria commented with a regression range pointing to fsync stuff, but i can't find it anymore now :\
Attached patch patch (obsolete) — Splinter Review
Attachment #353764 - Flags: review?(gavin.sharp)
Flags: in-litmus?
Attached patch patch v1.1Splinter Review
i added a comment in the history idl about the problem, i need an additional review from dietrich about that, maybe there's a better solution to make implementers aware of that.
Attachment #353764 - Attachment is obsolete: true
Attachment #353765 - Flags: review?(gavin.sharp)
Attachment #353764 - Flags: review?(gavin.sharp)
Attachment #353765 - Flags: review?(dietrich)
Duplicate of this bug: 469961
Flags: blocking1.9.1? → blocking1.9.1+
Comment on attachment 353765 [details] [diff] [review]
patch v1.1

this seems fine, r=me. gavin might have more perspective on possible side-effects of moving sanitization up to quit-application-granted.

maybe you could add that documentation to a "Places Best Practices" page on MDC?
Attachment #353765 - Flags: review?(dietrich) → review+
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1b3
i added dev-doc-needed for now, to remember adding the note to MDC.
Keywords: dev-doc-needed
As Ian pointed out in bug 469158 comment 26, the option this bug addresses no longer exists. Is there still a problem here at all?
it should be fixed still, yes.
Whiteboard: [has patch][needs review gavin]
Attachment #353765 - Flags: review?(gavin.sharp) → review+
Whiteboard: [has patch][needs review gavin] → [has patch][has review][can land]
knocking priority down a notch, given comment 9.
Priority: P1 → P2
(In reply to comment #11)
> knocking priority down a notch, given comment 9.

I think I was actually wrong there, as the reason the pref was destroyed is because the prompt now *always* shows up, since a time-frame has to be chosen. See bug 469158 comment 28.
(In reply to comment #12)

Sorry for the bugspam, but I was wrong. The dialog will now always show up when you click "Clear Recent History", but never show up when exiting firefox.
trunk: http://hg.mozilla.org/mozilla-central/rev/053ebdb6a88c
Whiteboard: [has patch][has review][can land] → [has patch][has review]
Target Milestone: mozilla1.9.1b3 → mozilla1.9.2a1
Whiteboard: [has patch][has review] → [has patch][has review][baking]
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/00a4e7bf722b
Keywords: fixed1.9.1
Whiteboard: [has patch][has review][baking]
Regarding the in-litmus nomination, we have a Litmus test case that tests clearing private data, but not after a shutdown. Since the Ask me pref no longer exists, I guess that does not have to be factored in.
verified fixed on the 1.9.1 branch using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090108 Shiretoko/3.1b3pre and  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090108 Shiretoko/3.1b3pre

verified fixed on the trunk using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090108 Minefield/3.2a1pre and with the latest Vista trunk nightly.

To verify on both I accumulated some history, set the pref to always clear and then restarted to make sure my history was cleared.
Status: RESOLVED → VERIFIED
updated both mdc and w.m.o documentations
Depends on: 483566
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.