Last Comment Bug 423507 - clear private data -> history is NOT empty [see comment 24!]
: clear private data -> history is NOT empty [see comment 24!]
Status: VERIFIED FIXED
: compat
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- major with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 417907 439812 442885 446700 462831 464599 467349 468862 470856 482034 (view as bug list)
Depends on: 439129 470348
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 13:29 PDT by Mario Schmitz
Modified: 2011-02-24 12:25 PST (History)
29 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mario Schmitz 2008-03-17 13:29:32 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

if you turn on "private browsing" (-> delete all private items when closing firefox), the history still remembers the adresses. 

Reproducible: Always

Steps to Reproduce:
1. checked preferences
2. checked about:config-file
3. that's it.
Comment 1 Steve England [:stevee] 2008-03-17 13:32:13 PDT
Are all addresses kept, or only some? If only some, can you show us some examples of the whole URL that is still present?
Comment 2 Steve England [:stevee] 2008-03-17 13:34:48 PDT
(You may be seeing bug 415397)
Comment 3 Jo Hermans 2008-03-17 14:14:31 PDT
If you see items in the location bar after you've deleted the history, don't forget that bookmarks are now also shown in the popdown. That confuses people that are used to older versions of Firefox. The history itself can be seen in the sidebar (view->sidebar->history) and in the History Window (history->show all history).
Comment 4 Larry Seltzer 2008-03-19 07:12:26 PDT
I'm seeing this on beta 4 on Vista SP1 and it's not bookmarks I'm seeing. 

It could be that for some of the addresses I'm seeing after a history delete, some other address on that domain is bookmarked. Is this documented behavior?

It looks like some addresses go away and others don't.

Incidentally, I can also go through the list with the Del key and they still come back.
Comment 5 Larry Seltzer 2008-03-22 05:51:19 PDT
(In reply to comment #3)
> If you see items in the location bar after you've deleted the history, don't
> forget that bookmarks are now also shown in the popdown. That confuses people
> that are used to older versions of Firefox. The history itself can be seen in
> the sidebar (view->sidebar->history) and in the History Window (history->show
> all history).
> 

Is there a way to turn off this behavior for the location bar? Specifically, I don't want to see bookmarks in there (and I don't understand the point of the functionality). I don't see anything in the menus or about:config. 
Comment 6 John Doe 2008-03-26 18:01:57 PDT
This is an aweful addition to Firefox.  Please help me remove this somewhere, like the about:config.
Comment 7 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-05-16 09:06:14 PDT
Works For Me. As Comment #3, I think he get confused with the bookmarks.
Comment 8 Mats Palmgren (:mats) 2008-05-27 14:37:43 PDT
Comment 4 seems to confirm there is a problem...  What would really help
is *exact* steps to reproduce, starting from a fresh profile.
Comment 9 Larry Seltzer 2008-05-27 15:20:46 PDT
Comment 4 author here. I stopped using FF3 a while ago, waiting for final code. Too many problems with plug-ins back then.

I don't have exact steps, but my real concern at this point is that in the thrust of comments 5 and 6: This whole retention of history, against the user's explicit command to delete it, is really bad. There should at least be a way to turn it off.
Comment 10 Steve England [:stevee] 2008-05-27 16:55:03 PDT
(In reply to comment #8)
> Comment 4 seems to confirm there is a problem...  What would really help
> is *exact* steps to reproduce, starting from a fresh profile.

Comment 4 also says he was seeing the problem with beta 4. Bug 415397 was fixed for beta 5, so I think confirmation that history is being erroneously remembered using Fx3 RC1 is required.
Comment 11 Carlos 2008-06-06 15:08:32 PDT
(In reply to comment #10)
 
> Comment 4 also says he was seeing the problem with beta 4. Bug 415397 was fixed
> for beta 5, so I think confirmation that history is being erroneously
> remembered using Fx3 RC1 is required.
> 

I'm seeing this problem in Fx3 RC1.  I just upgraded.  Clear Private History is not clearing the browsing history.  I'm using WinXP SP2.
Comment 12 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-07 12:05:06 PDT
1) Go to Tools -> Options -> Privacy tab -> Settings (in Private Data section): Browsing History is checked?

2) where you see the not deleted history entries? If they are at urlbar, they are all links you have in bookmarks?
Comment 13 Steve England [:stevee] 2008-06-19 06:00:17 PDT
The original reporter, Mario Schmitz, hasn't replied to any questions since he submitted the bug.

(via email) Larry Seltzer says what he was seeing is covered by comment 3.

Carlos hasn't replied to comment 12.

John Doe, are you seeing actual history in the address bar after clearing history, or are you just seeing bookmarks?
Comment 14 Carlos 2008-06-21 12:33:39 PDT
Hi Steve, 
I downloaded the latest version of Fx3 just now and the problem seems fixed. The website I visited was cleared from the list.  

However, I do agree with some of the comments above: the new features that display bookmarks by clicking the toolbar's drop-down or that attempts to guess the web address user is typing from the bookmarks is very pesky and still a dangerous privacy issue.  

Users should be able to turn off both of these features independently as none of my friends should be exposed to my private information that readily just because I allow them to do some quick browsing on my laptop.  

I know I will still not be using Fx3 until a fix/enhancement is provided to cover both of these privacy breaches.
Comment 15 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-21 12:57:36 PDT
You can set browser.urlbar.matchOnlyTyped to True to avoid this.
Comment 16 Mumia W. 2008-06-28 00:14:49 PDT
I was not able to reproduce this bug with this Firefox:

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0


I created a new profile and browsed to www.w3.org , support.microsoft.com , and lists.debian.org . I closed and restarted the browser and typed "ww", "sup", and "li" into the location bar to verify that the location bar remembered where I had gone; it did.

Then I enabled the preference to clear private data and closed Firefox. When I restarted the browser, typing "ww", "sup", and "li" into the location bar revealed no matches (except for those in the bookmarks).

There are a number of items that start with "www" in the bookmarks, so "ww" matched them, but "sup" and "li" returned nothing.
Comment 17 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-28 01:28:10 PDT
Yes, this bug seems to be WFM now. About the requests to disable searching in bookmarks, see Bug 395161.
Comment 18 Larry Seltzer 2008-06-28 03:52:00 PDT
>>see Bug 395161.

I don't see it in there, at least not stated head-on.

I've since found <a href="https://addons.mozilla.org/en-US/firefox/addon/7429">the Hide Unvisited 3 add-on</a> to do this.
Comment 19 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-28 04:12:36 PDT
Sorry you are right. The correct bug is Bug 424557.
Comment 20 james passmore 2008-07-02 06:19:28 PDT
I think I have the same bug as reported by Mario Schmitz, or something very similar.

I have installed FF3 over FF2.

I'm using Windows XP SP2. ~ Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0.

Clear Private Data, all boxes are ticked. 

Also 'Always clear my private data when I close FF' ticked.

If I close FF or if I Clear Private Data via tools, the location bar still remembers my browsing history.

Also, If I click the down arrow icon on the RHS of the location bar use my keyboard down arrow and delete manually, the location bar still remembers the history, even if I restart FF or if I restart the PC.





Comment 21 james passmore 2008-07-02 06:47:07 PDT
Doh! apologies to all, 

Confused myself it's not browser history that's stored so no bug.  I was confused over the location bar showing me apparently random bookmarks.

What a terrible feature.  Can this functionality be easily disabled?

regards

Comment 22 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-07-02 07:01:16 PDT
I'm more and more sure also other users got confused. Anyway I think leaving this 'bug' opened avoids duplicates.

@James Passmore: see comment 19
Comment 23 Chris Moise 2008-07-03 10:40:05 PDT
I am using Windows XP.  Firefox 3.0 does not clear browsing history when you manually select Clear Data.  Had to go back to 2.0 Version.
Comment 24 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-07-03 10:58:25 PDT
@Chris Moise: have you read comment 12, comment 15, and comment 19?
Comment 25 Larry Seltzer 2008-07-03 11:00:29 PDT
Probably Chris hasn't read the previous comments and has missed the fact that those are not browser history, but bookmarks.

All this reinforced the conclusion that this is a confusing feature, poorly implemented. There shoudl at least be an obvious way to turn it off.
Comment 26 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-07-04 02:09:36 PDT
IMO the best thing is to add a first-time help when you open the dropdown menu of location bar (a balloon for example). And furthermore we must wait Bug 424557 fixing.
Comment 27 Matt Welsh 2008-07-04 11:43:29 PDT
With Firefox 3, it seems that if you EXPLICTLY TYPE a URL into the urlbar, it is remembered across browser restarts, *even if "Clear Private Data" is enabled*.

To reproduce:
  - Set browser.urlbar.matchOnlyTyped to "true" (in about:config)
     - This disables the urlbar from matching bookmarks.
  - Quit the browser.
  - Delete places.sqlite from your profile.
  - Start the browser.
  - Type "www.google.com" into the url bar (don't surf there some other way)
  - Note that no history results should be shown.
  - Quit the browser.
  - Start the browser.
  - Type "www" into the url bar. The match for www.google.com will appear.

It seems that "Clear Private Data" is *not* clearing URLs that were explicitly typed into the urlbar - although other browsing history is being cleared.



Comment 28 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-07-05 07:12:39 PDT
(In reply to comment #27)
> [cut]

I can't reproduce. Can you install the latest trunk ( http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ) and test this bug in safe mode, or better with a blank profile? Disable also all plugins temporary.

If it works in this way, but not with your normal profile, probably it's a problem caused by an extension. So try to disable them one-by-one. 

When you find the problematic extension(s), inform us and its author.
Comment 29 vstarre 2008-08-28 01:15:44 PDT
Perhaps the problem is bookmarks not being deleted?

I am seeing /deleted/ bookmarks (ones that were automatically added by stumbleupon, before I uninstalled that add-on) in my URL history.
Comment 30 Josh Wand 2008-12-01 20:15:22 PST
After clearing browser history and cache, I am still seeing location bar autocomplete entries that are *not* bookmarks. 

Shift-delete removes entries temporarily, but hitting backspace and typing the matching string again causes these entries to show up again. 

Agree that bug 424557 will fix this, but as evidenced by the many dupes of this bug, to most users the autocomplete in the location bar is synonymous with browsing history.

Options:
--Change the default behavior of the clear browsing history to remove all non-bookmark entries in the awesomebar datastore.
--Add an additional option "location bar history" in the Clear Private Data dialog.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Comment 31 Josh Wand 2008-12-01 20:25:01 PST
some dupes, if anyone cares to go clean them out:
 Bug 467349 -  Clear Private Data doesn't work property  
 Bug 464599 -  History does not delete after choosing the clear all private data option  
 Bug 461918 -  Browser history will not clear (drop down from toolbar)  
 Bug 445302 -  Frecency score of bookmarks not set to zero when history is cleared and bookmark scoring set to zero  
 Bug 442885 -  Recently visited Sites are Not cleared from Address bar, after clearing History.  
 Bug 441958 -  Browsing History For Address Bar Is Not Cleared/Cannot Be Cleared  
 Bug 395162 -  It is impossible to clear the browsing history neither by "Preferences" nor "Tools"  
 Bug 265678 -  Clear Location History  
 Bug 424329 -  Action "Clear Private Data" (Ctrl+Shift+Del) doesn't clear browsing history
Comment 32 S.Peck 2008-12-01 21:40:18 PST
Okay, original complainant here.... whether you call it browser history or bookmarks or WHATEVER, all I know is it's different (functionally and visually) and far less user friendly than the version of FF I had before. I have (multiple times) tried all the fixes discussed above - point is, I don't WANT my bookmarks showing up in my browser history, that's the point of having BOOKMARKS, so I know where to go find links I only visit ever so occasionally. I want my drop-down window from the URL location bar to just show me where I've been based on however many days I have it set to save that info.

I have found it SO FRUSTRATING and annoying, I have, out of desperation, added my top 7 sites to the 'Bookmark Toolbar' and have it displayed under the navigation toolbar.

This is a stupid feature. I hope it goes away.
Comment 33 S.Peck 2008-12-01 21:43:27 PST
oops - sorry, I am the original complainant of bug # 461918, which the comments to referred to this bug report.
Comment 34 Marco Bonardo [::mak] 2008-12-02 01:09:46 PST
(In reply to comment #30)
> After clearing browser history and cache, I am still seeing location bar
> autocomplete entries that are *not* bookmarks. 

unless you can provide us a places.sqlite that shows the issue it's hard for us to find why that happens. History table is correctly cleared, so must be something related to places table.

If those are not bookmarks and are not livemarks child, this could be a bug, but we need to be able to reproduce, and we are not.
Comment 35 bernhard krumm 2008-12-02 01:54:29 PST
1. 
It's not a bug it is a function, as You can see below.

2. 
To remove the URL-Bar's history 
You have to enter in the URL-line  (instead of www.xxx or other )
    about:config
    then scroll down to:
    browser.
    urlbar.maxRichResults
    change the default of 12 to 0. 
The default setting is 12 and if you want nothing, you enter 0.
Comment 36 Josh Wand 2008-12-02 17:03:40 PST
(In reply to comment #34)
> (In reply to comment #30)
> > After clearing browser history and cache, I am still seeing location bar
> > autocomplete entries that are *not* bookmarks. 
> 
> unless you can provide us a places.sqlite that shows the issue it's hard for us
> to find why that happens. History table is correctly cleared, so must be
> something related to places table.
> 
> If those are not bookmarks and are not livemarks child, this could be a bug,
> but we need to be able to reproduce, and we are not.

Would prefer not to supply my places.sqlite in public, but happy to email it to a developer privately. 

Using sqlite manager, I can see that moz_places has 13406 entries before clearing browsing history, and has 13406 entires *after* clearing browsing history.
Comment 37 Josh Wand 2008-12-02 17:06:38 PST
More disturbingly, I see 21554 entries in moz_historyvisits after clearing browsing history.
Comment 38 Marco Bonardo [::mak] 2008-12-03 02:05:21 PST
(In reply to comment #37)
> More disturbingly, I see 21554 entries in moz_historyvisits after clearing
> browsing history.

that's not correct. does anything change if you try Firefox in Safe Mode?
If your places.sqlite is not too big you can send it to me by mail (or upload in a private ftp and mail me the download link)
Comment 39 Marco Bonardo [::mak] 2008-12-11 08:09:52 PST
*** Bug 464599 has been marked as a duplicate of this bug. ***
Comment 40 Tracy Walker [:tracy] 2008-12-16 10:08:21 PST
*** Bug 467349 has been marked as a duplicate of this bug. ***
Comment 41 Marco Bonardo [::mak] 2008-12-18 17:34:47 PST
apart miscomprehensions on unvisited bookmarks shown in the locationbar, i'm adding a couple bugs as blocking this, since those are most likely related to some of the cases that have been reported. There's no need to further comment on them, so please maintain the discussion here if you're going to provide some constructive idea.
Comment 42 Marco Bonardo [::mak] 2008-12-20 01:51:13 PST
confirming this bug, but should be fixed by its dependancies.
Notice also 3.1 will contain options to configure the locationbar to hide bookmarks.
Comment 43 Marco Bonardo [::mak] 2008-12-20 07:24:16 PST
*** Bug 468862 has been marked as a duplicate of this bug. ***
Comment 44 Marco Bonardo [::mak] 2009-01-08 12:56:11 PST
this bug is fixed by its dependancies, notice after clearing history the locationbar won't be empty, it will contain your bookmarks instead (and nothing more than that).
To change that behaviour you can set the appropriate preference to make the locationbar search only into history.
Comment 45 Marco Bonardo [::mak] 2009-01-08 12:58:56 PST
*** Bug 470856 has been marked as a duplicate of this bug. ***
Comment 46 Marco Bonardo [::mak] 2009-01-15 02:02:07 PST
*** Bug 417907 has been marked as a duplicate of this bug. ***
Comment 47 Marco Bonardo [::mak] 2009-01-15 02:02:09 PST
*** Bug 462831 has been marked as a duplicate of this bug. ***
Comment 48 Thomas K. (:tom) 2009-01-25 15:43:06 PST
*** Bug 442885 has been marked as a duplicate of this bug. ***
Comment 49 Tracy Walker [:tracy] 2009-01-27 08:48:34 PST
vierfied with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090127 Shiretoko/3.1b3pre
Comment 50 Matthias Versen [:Matti] 2009-03-07 13:32:09 PST
*** Bug 482034 has been marked as a duplicate of this bug. ***
Comment 51 Dozza 2009-03-10 19:37:38 PDT
The bug is NOT fixed. In 3.0.7 under Windows XP it still persists. Note that the bug's behavior seems to depend on when I try to clear my private data. If I try immediately after Firefox has started, the data is not cleared (including browsing history, cookies and cache). If I wait for about 20 seconds, the data is usually cleared as it should be.
Comment 52 Marco Bonardo [::mak] 2009-03-11 07:53:27 PDT
*** Bug 446700 has been marked as a duplicate of this bug. ***
Comment 53 Tracy Walker [:tracy] 2009-03-11 08:56:23 PDT
Dozza, if timing is the issue, that would be another bug.  There are many initialization operations that happen at start up that are likely locking out  clear private data until start up init. is complete.
Comment 54 Dozza 2009-03-12 00:14:03 PDT
Tracy, I originally commented on Bug 462831, where the description referred to selecting Tools->Clear Private Data, it was later merged with this bug as it was assumed they were the same bug. I don't know if timing is the issue or not, I just noticed the relation between time and the bug's occurrence and thought it would give a hint.

Either way, the bug is NOT fixed.
Comment 55 Tracy Walker [:tracy] 2009-03-12 06:56:36 PDT
You said it works as expected after some time (20 secs).  If you can't clear PD during startup, that is a different bug.  Please file a new one with your findings.  This one IS fixed.
Comment 56 Dozza 2009-03-12 08:51:34 PDT
Opened a bug report under Bug 482967 to reflect my comment above.
Comment 57 pliny.the.ill 2009-05-25 10:59:49 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Here's my experience.  

1. Location bar remembered visited sites, even after "Clear Private Data" operations (either Ctrl-Shift-Del or by closing the browser with "always clear private data" selected).

2. Opened profile directory, ran "sqlite3 places.sqlite".  Executed "VACUUM;".  Result: "Constraint failed".

3. Location bar still remembers visited sites, even after "Clear Private Data".

4. Opened profile directory, ran "sqlite3 places.sqlite".  Executed:
  .output temp.sql
  .dump

5. Deleted places.sqlite, ran "sqlite -init temp.sql places.sqlite".  Got about five messages; I can't remember exactly what they were, but something like "key (blah blah blah) cannot be NULL".

6. Ran "sqlite3 places.sqlite", executed "VACUUM;", no complaints.

7. Start up Firefox.  Location bar has lots of old sites.  "Clear Private Data".  Location bar cleared as expected (only bookmarked sites).

Obviously this report is missing some key information; I cleaned everything up after I was done, so I don't have my broken "places.sqlite" or my SQL dump anymore.  Sorry about that.

Whether you want to call this a new bug or not, I think it's fair to say that "Location bar retains history through Clear Private Data if places.sqlite is corrupted" is an issue in 3.0.10.
Comment 58 Marco Bonardo [::mak] 2009-05-25 11:14:50 PDT
(In reply to comment #57)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316
> Firefox/3.0.10 (.NET CLR 3.5.30729)
> 
> Here's my experience.  

This is demonstration that the issue is not 3.0.10 but your places.sqlite file, that looks like had a broken schema, this could often happen when users execute direct queries (DELETEs, UPDATEs) on the db without using provided APIs.
We can consider your issue due to a corrupt places.sqlite, probably a separate case from what was discussed here.
Btw, thanks for reporting that this bug could be fixed for some user replacing their places.sqlite with a correct one.
Comment 59 Marco Bonardo [::mak] 2009-06-08 17:05:48 PDT
*** Bug 439812 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.